[RTEX] Pi4 - SSD mSATA – Pi OS 64Bits Buster – Jeedom V4

Tags: #<Tag:0x00007f38587f4b48> #<Tag:0x00007f38587f4968> #<Tag:0x00007f38587f46e8> #<Tag:0x00007f38587f4508> #<Tag:0x00007f38587f42b0>

Bonjour à tous, c’est akenad :slight_smile: ,

Aujourd’hui je vais vous présenter un retour d’expérience sur la mise en œuvre d’un Pi4 avec boot USB SSD mSATA sur Pi OS 64 Bits (Buster) et Jeedom V4.

Les équipements utilisés sont les suivants :
(Configuration type)

  • RPi4B 4Go 2018 (avec alim 3A), ventilo Pi-FAN 5v 0,2A silencieux
  • SSD 32 Go Transcend (TS32GMSA370)
  • boîtier SSD USB/mSATA (Inateck Boîtier USB 3.0) pour y placer le SSD
  • Z-wave : Aeotec Z-Stick Gen5 (ce n’est pas le nouveau modèle 2020, donc ne fonctionne pas sur un port USB3 du Pi4)
  • EnOcean : TCM310 (FTDI) avec antenne
  • Zigbee : ConBee 2 (Dresden)
  • 4G/SMS: Huawei E3372h-123
  • Bluetooth BLE 4.0 SENA Model Parani-UD100a, avec une antenne additionnelle SMA ominidirectionnelle 2,4 Ghz 12dbi
  • HUB USB2 ORICO 10 Ports (avec alim 2,5A)

Avec le Pi4 je recommande d’utiliser du « mSATA », c’est-à-dire du Mini-SATA, autrement dit je ne recommande pas d’utiliser du SATA.

Les étapes :

1- mettre à jour le firmware de l’EEPROM du Pi4
2- Graver l’image Pi OS 64 Bits sur SSD
3- Installer Jeedom V4

  1. mettre à jour le firmware de l’EEPROM du Pi4

Voir ici : [Présentation] akenad

  1. Graver l’image Pi OS 64 Bits sur SSD

Avec Raspberry Pi Imager (choisir « custom » dans liste OS), graver l’image ici : https://downloads.raspberrypi.org/raspios_arm64/images
(Créer un ficher vide de nom « ssh » à la racine de la SSD .)

  1. Installer Jeedom V4

En SSH, installation en ligne de commande :

$ sudo su -
# wget https://raw.githubusercontent.com/jeedom/core/master/install/install.sh
# chmod +x install.sh
# ./install.sh

Pi4-SSD-Hub-USB2

  • Le SSD mSATA (sans alim propre) est USB3, connecté sur un port USB3 (bleu) du Pi4.
  • Le Hub (avec alim propre) est USB2, connecté sur un port USB2 (noir) du Pi4.
  • Les clés USB sont USB2, connectées sur le HUB.
  • certaines clés ont une rallonge USB et des antennes externes.
$ lsb_release -d
Description:    Debian GNU/Linux 10 (buster)
$ arch
aarch64
$ uname -a
Linux hostname 5.4.42-v8+ #1319 SMP PREEMPT Wed May 20 14:18:56 BST 2020 aarch64 GNU/Linux

Page Santé Jeedom :
Version OS : Linux hostname 5.4.42-v8+ #1319 SMP PREEMPT Wed May 20 14:18:56 BST 2020 aarch64 GNU/Linux [10.4]

Voila j’espère que ce retour d’expérience sera utile aux membres Jeedom.

akenad :slight_smile:

4 J'aimes

Bonjour @akenad et merci pour les tutos

Juste un détail: j’ai eu pas mal de soucis avec BalenaEtcher sur mac, en OS 10.15, impossible de graver les images.
A savoir que raspberry a sorti un outil similaire qui lui fonctionne très bien (et qui peut même télécharger la version de raspbian), qui s’appelle raspberrypi imager: https://www.raspberrypi.org/downloads/

1 J'aime

Bonjour @drs,

Oui, j’ai utilisé Raspberry Pi Imager pour la 1ère étape décrit dans le premier post, il suffit de cliquer sur le lien.

akenad :slight_smile:

Bonjour,

nickel cette install. Je viens d’acheter un Pi4 8Go et tout est installé.
J’attends juste mon hub car même sur cette OS 64B, toujours le même problème.

Une question juste, comment activer le bluetooth sur cette version ? Toujours avec la même commande ??

Tu as pris quoi comme Hub ?

Bonjour.

Le.bt est activé par défaut.
hciconfig pour contrôler.

Vous l’avez eu où, chez Kubii il n’est pas encore disponible.

Quelqu’un peut me donner le retour de cette commande :
cat /etc/*-release

Merci

Un hub dlink USB 2.0

@Fabrice chez mchobby livré en moins d’une semaine…

PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

akenad :slight_smile:

1 J'aime

@Fabrice, j’ai acheté mon rpi4 8Go chez Kubii (livré début de semaine dernière) il était bien dispo mais il a du être victime de « son succès » ou plutot que c était les seuls ou presque à le proposer à la sortie

Bonjour.

Merci. Moi ils m’ont annoncé une disponibilité courant juillet.

Tu es contents de cette machine ?
Le hub USB est vraiment encore nécessaire ?
Tu as pris quelle alimentation, sur Kubii il vendent un grosse alimentation pour le pi4.

@akenad : veux tu que je supprime tout le hors sujet après ?

Meuh non, c’est Kool !

akenad :slight_smile:

1 J'aime

@Fabrice, pour tout te dire j’attends mon SSD perdu par Chronopost, donc remboursé et recommandé, il sera la mercredi.
Pour le moment j’ai juste fait la mise à jour de l’eeprom du pi4 pour le boot USB
Sur Kubii, leur alim officielle pour RPI4, mais elle n’est pas grosse en taille bien au contraire j’ai été surpris (https://www.kubii.fr/14-chargeurs-alimentations-raspberry/2678-alimentation-officielle-153w-usb-c-pour-raspberry-pi-4-kubii-3272496300002.html)

J’ai pris un hub USB, mais USB 3, j’espere que cela va aller pour ma clé, mais je testerais aussi sans.
Réponse en fin de semaine.

Ok, merci pour ces précisions.
Pour le hub, quand tu auras réalisé les tests, je suis intéressé pour savoir (référence du hub aussi, c’est pour capitaliser ce qui est bon et pas).

Pour l’alimentation, je parlais pas de l’officielle, mais de celle-ci :
https://www.kubii.fr/14-chargeurs-alimentations-raspberry/2953-alimentation-argonone-pi-4-3272496301504.html

  • Elle à quelque w de plus que l’officielle, du coup, j’aurais tendance à la préférer.

@akenad, j’ai suivi tes tutos pour le boot usb sur un SSD
Carte SD avec OS lite + flash eeprom + vérif : OK

  • J’ai gravé l’image de ton lien sur le SSD avec PI imager.

Mais là si je laisse que le SSD branché, rien dans putty

Doit on laisser la carte SD ?
Si oui comment on sais que l’on boote sur le SSD, ce que je doute si car sans la SD cela ne marche pas

J’ai essayé de modifier l’ID de boot comme vu dans l’autre post et là je pense qu’il boote sur le SSD (comme sans carte SD surement) mais rien avec putty.

Ou alors est ce l’image qui a pu être mal gravé sur le ssd , pourtant l’outil l’a vérifié apres et c était OK
Enfin là je suis donc dans une impasse, car le rpi ne boote plus sur rien

Bonjour @Steph034,

Dans le premier post du présent sujet, la SD n’est utilisée (seule) que pour mettre à jour le firmware de l’EEPROM du Pi4.
Si la mise à jour a été faite correctement, le boot directement sur USB SSD (seule) fonctionne. (ne pas laisser la SD).

Si le Pi4 ne boot même plus avec une SD (seule) fraichement gravée, c’est que la procédure de mise à jour du firmware de l’EEPROM du Pi4 n’a pas été suivie à la lettre, et donc que le Pi4 est parti en vrille.
Si c’est le cas (la led verte ne clignote pas) il convient alors de suivre la procédure de Recovery indiquée ici : https://www.raspberrypi.org/downloads
(Cela consiste a booter une fois sur une SD spécialement préparée)

akenad :slight_smile:

Si le rpi4 bootait sur la SD seule avant que je ne modifie le fichier de conf (car pour le modifier j’ai du remettre la SD) pour mettre l’ID du DD SSD (qui était vu sur le rpi).
Mais lui doit avoir un soucis donc pour booter, car je pense que le rpi4 essaie bien de booter dessus mais je n’ai rien

Je ne sais pas de quoi tu parles, cette opération n’existe pas dans le présent RTEX.

akenad :slight_smile:

@akenad, en fait j’ai trouvé ce matin (la nuit porte conseil) et erreur de débutant (que je suis), je n’avais pas créé le fichier ssh en racine du SSD (peut être à rajouter dans ton tuto) et donc pas d’accès putty (je n’ai pas d’écran sur le rpi) et donc pas d’installation jeedom possible tout simplement
Sinon oui je boote sans soucis sur le SSD finalement, ton tuto est suffisant, peut être en ajoutant ici ou là donc quelques recommandations pour les débutants, à voir, car à vrai dire on se pose des questions vis à vis d’un autre post qui dit de copier des fichiers de la SD vers SSD etc,

Bonjour,

Pour une installation, pas à pas, il y a ce tuto :


Dans votre cas, peut importe le Pi, c’est pareil, sauf quand je l’indique.

@akenad et / ou @Steph034 : Question, avez vous la DEL d’activité qui est toujours en activité quand le Pi boot sur le SSD et qui stop quand une carte MicroSD est présente dans le Pi ?

@Fabrice OK je regarde ton tuto
3 questions:
Les optimisations de l’OS sont elles les mêmes sur un rpi 4 ?
Le swap peut on le passer plus haut sur un rpi4 8go (2048 ou cela ne sert à rien) ?
Peut on mettre à jour l’OS, même si on est sur une beta du firmware (et peut être de l’OS d’ailleurs, j’ai pris l’image de Akenad, mais je ne sais pas exactement si beta ou autre) ?