Firmware & pas de cle visible

Tags: #<Tag:0x00007f282c830ad0>

Donc la clef est bien visible (par intermittence)
Pour suivre les recommandations il faut bien sur au préalable avoir téléchargée la version firmware depuis le site de Dresden

Bon, j’y suis pas encore arrivé. j’abandonne pour ce jour : je me garde se plaisir pour demain.
Il faut dire que j’avais choisi une conbee en m’attendant à du plug and play… C’en est assez loin :roll_eyes: :roll_eyes:

C’est bien plug and play mais il faut comme sur un PC par exemple avoir le bon programme qui tourne sur la clef. Imagine toi en train d’essayer d’installe MacOS X sur un PC destiné à Windows. ET pourtant les deux sont plug and play :wink:
Télécharge en attendant le firmware . Ca prend quelques minutes tout au plus pour la programmation de la clef ConBee2

Malgre une heure de plus, je suis au meme point :slight_smile: Ca doit etre ca d’etre doué :sunglasses:
image

1 J'aime

Tu as bien claqué le firmware sur la conbee2 ?

Si oui il faut t’en assurer en refaisant un

sudo GCFFlasher_internal -l

Tu dois voir apparaitre qqch dans ce genre ensuite :

GCFFlasher V3_13 © dresden elektronik ingenieurtechnik gmbh
Path | Vendor | Product | Serial | Type
-----------------±-------±--------±-----------±------
/dev/ttyAMA0 | 0x0000 | 0x0000 | | RaspBee
/dev/ttyACM1 | 0x1CF1 | 0x0030 | DE2124544 | ConBee II

de manière stable (en gras les données importantes qui doivent s’afficher).

1 J'aime

Bonjour @Kraken,

Des infos DeCONZ ici : [Présentation] akenad

et Pi4, hub USB ici : https://community.jeedom.com/t/29807

akenad :slight_smile:

1 J'aime

Je penserai que j ai fait le nécessaire mais visiblement non :cane fonctionne pas. Je m y remets demain

Avant toute chose je vois sur ton profil que tu utilise un Rpi4

Les alimentations des rpi4 sont très limitées.

Je te conseil donc d’utiliser un port usb alimenté et de mettre ta ou tes clefs dessus.

Les connexions/dé-connexion sont peut être juste un problème d’alimentation.

Les 2 ports USB qui ne sont pas USB 3 ne sont pas permutables. L’un est alimenté et l’autre non ?

Tu peux trouver les réponses aux questions qui se posent sur le sports USB RPI ici :
https://www.raspberrypi.org/documentation/hardware/raspberrypi/usb/README.md#overview_pi4

As tu essayé de passer ta clef ConBee2 sur PC Win10 et voir si elle est reconnue par l’application deCONZ ?
Si ça marche sur PC alors ton dongle est OK.
Tu peux vérifier sa version firmware au passage sous deCONZ.
Réinstalle la clef sur ton RPI4 en la connectant sur une petite rallonge USB et sur un port USB 2 (pas ceux en bleu).
Si ça ne fonctionne toujours sur ton RPI4 pas alors passer par un HUB USB2 alimenté et y brancher ta clef.

Sinon si ça ne marche pas sur PC il faut reclaquer le firmware selon indications données précédemment.
Si ça ne marche pas encore près cela c’est retour de la ConBee2 en SAV (garantie). Sinon passer à l’étape ci dessus en rebranchant ta clef sur le RPI4.

Merci de votre aide,
je viens d’essayer de nouveau, en ssh et sur le PC (je n’ai pas de win 10 juste un win7) pas de retour d’information sur le port avec un GCFFLasher, j’ai essayé de le flasher avec des firmwares differents, je connais le port par difference (le seul qui ne me renvoie pas une fin de non recevoir immédiate) mais pour seule réponse :"retry, fail’
J’y repasse 1 heure max demain et retour case depart avec demande de remboursement pour cette grosse m**de

Edit: ca ne retire rien à la qualité de votre aide pour laquelle je vous remercie, soit je suis une burne, soit c’est une merde… mais je reste bien decu.

Va pour un double post …
Essai avec rallonge, avec un autre PC, reessai en SSH, et tout le tremblement = Retour casse depart avec une demande de remboussement
Expérience très décevante de cette grosse merde à 50€ - Seule utilité, faire de la musique sous windows pour la connexion / deconnexion incessante

Et avec cette méthode Mise a jour firmware conbee 2 - windows

Mais effectivement si « GCFFLasher » ne te voit pas la clé sous windows (7 ou 10), c’est que la clé a un soucis.

La cle n’est pas vue sur le Rpi4, mon RPi1, mon PC pro, le perso en win 7 et mon perso en win 10 que je suis aller chercher expres pour l’essai

Je reviens a l’instant de la zone commerciale, je viens d’acheter un hub xiaomi…

Hub Xiaomi ! Et bien là effectivement c’est la fin du monde :slight_smile:

Au moins il marchera avec les seuls capteurs Xiaomi.

Après réflexion je me dis que c’est peu être normal de ne pas voir la clé sous « GCFFLasher » vu la vitesse a laquelle elle déconnecte ? Ou alors faut avoir du bol a taper la commande au bon moment ?

Je sais que ça marche mais je l’ai jamais fait de mon coté, peut être que les gens tapent les commande en aveugle ?

C’était bien une commande avec « -t 60 » et « -R 100 » ?

sous Win10 :

GCFFlasher -d COM7 -t 60 -f ../firmware/deCONZ_ConBeeII_0x26580700.bin.GCF

en remplaçant COM7 par COM5 ou COM9 en testant jusqu’à ce que ça marche.

Et j’ai aussi vu « -R 100 » c’est le nombre de retry, mais avec du recul 100 ça fait pas mal quand même.

Bonjour,
La ligne de commande que j’ai utilisé ressemblait à ça:
.\GCFFlasher.exe -d COM5 -f deCONZ_ConBeeII_0x26580700.bin.GCF -t 20 -R 100
Ça a marché du premier coup, je ne sais pas pourquoi j’ai du ajouter " .\ " :thinking:

En fait le nb de retry peut rester élevé car dès le premier OK la boucle s’arrête. Ça laisse plus de chances.

L’option -t spécifie le time out au delà duquel si la clef n’est pas trouvée le programme de flash s’arrête.
On peut cumuler les deux pour donner ceci

Sous Win10 (je crois que GCFFlasher ne marche pas sous Win7) en remplaçant le x par le numéro de port sur lequel est branché la clef (résultat de la commande GCFFlasher -l)

GCFFlasher -d COMx -t 60 -R 100 -f ../firmware/deCONZ_ConBeeII_0x26580700.bin.GCF

Sous Linux en remplaçant le x par le numéro de port de la commande GCFFlasher_internal -l

sudo GCFFlasher_internal -d /dev/ttyACMx -t 60 -R 100 -f deCONZ_ConBeeII_0x26580700.bin.GCF