Pour ceux qui utilisent un RPI3 ou 4 avec SSD sans SD

Bonjour, ça ne concerne pas directement Jeedom mais comme beaucoup font tourner Jeedom sur RPI ça peut être utile
J’ai un Jeedom qui tournait sur RPI3B+ et SD. Apres une corruption de sd (air bien connu !!) je suis passé sur SSD et pour ne pas me casser la tête, j’ai juste modifié le cmdline.txt en remplaçant le
disk=/dev/mmcblk0p2 quiet par disk=/dev/sda2 quiet.
Il y a quelques jours, j’ai retiré la SD qui est normalement inutile et là je me suis aperçu que l’activité du CPU a fortement augmenté !!.
En remettant une SD en place (vide MAIS formatée en ext4) tout revient dans l’ordre !! après moulte recherches je suis tombé sur ce sujet (traduction)
Utilisation élevée du processeur lors du démarrage à partir d’USB
en English:
CPU usage when booting from USB
Voili voilou

3 J'aimes

Salut,

Pour le moment un PI4 avec un SSD mais sans carte SD ça ne boote pas…

Oui mais une fois que le Pb de boot sur le 4 sera résolu, il sera intéressant de vérifier l’augmentation ce CPU sans carte SD

Bonjour.

Un pi3b+ sait booter nativement sur un port USB, sans jamais avoir vue de carte micro SD.

Tutoriel ici :

Pas d’activité de CPU suspects.

Si tu lis la page 2 de ton lien, le Kernel a été mis à jour, il y a un paramètre à mettre dans le fichier de config pour que le rpi ne Check pas en permanence la présence de la sd:

dtoverlay=sdtweak,poll_once

Apres, le sujet date de 2018 donc je ne sais pas si c’est encore d’actualité…

2 J'aimes

Je viens de tester, cela fonctionne sur mon installation.
La led d’activité de la carte SD est maintenant à l’arrêt.

MERCI pour l’information.

Intéressant, je vais tester

Bonne journée à tous

Oui, par flemme, j’ai d’abord mis une SD vide formatée en ex4 , puis finalement j’ai fait la modif du config, finalement on peut faire l’un ou l’autre… ou les deux quand on est un peu parano :smiley:

1 J'aime

Bonjour,

Rappel du matériel :
RPI 3B+ avec SSD mSATA

Alors, après avoir ajouté cette ligne dans /boot/config.txt :
dtoverlay=sdtweak,poll_once
suivit d’un redémarrage du Jeedom

Voici les constats :

  1. Sur le PI, la LED « ACT » ne s’allume plus (c’est l’effet visible, mais la cause est bien la désactivation de la recherche de la carte MicroSD).

  2. Sur les ressources du PI :
    Le trait rouge est placé au moment du changement et redémarrage :
    Annotation 2020-03-09 070005

Conclusion :
Il y a bien un changement significatif des charges du système.

Un possible degré °C en moins semble se pointer à l’horizon, mais je pense qu’il est encore trop tôt pour pouvoir l’affirmer.

Merci @Kerdale pour cette trouvaille !

1 J'aime

Merci @Kerdale / Fabrice pour cette une bonne nouvelle

salut il faire un sudo quoi apres pour modifie le fichier config.txt

Bonsoir,

sudo nano /boot/config.txt

une fois la modification effectuée, faire :
ctrl + o pour sauver
ctrl + z pour quitter

sudo reboot

merci on vas voir si la charge diminue

ça fonctionne, j’ai confirmé en plaçant des graphes avant / après (voir plus haut ici même).

J’en ai profité pour mettre à jour mon tutoriel pour installer Raspbian et Jeedom sur un Raspberry PI 3B+ sur SSD (mais il se suit aussi pour une installation sur une carte MicroSD).

https://community.jeedom.com/t/installation-de-raspbian-buster-lite-et-jeedom-sur-pi3b-sur-un-disque-ssd-msata/14650

il est ou le tuto?

Ici…

Très bon tuto :slight_smile:
Philippe

j’ai effectivement constaté sur mon PI (sans carte SD) une activité de la Led (SD)
j’ai donc suivi les indications de Fabrice (merci à lui !) généralement…ça marche sauf que (j’y connais pas grand chose en ligne de commande !) ça marchait pas !

ce ne serait pas plutôt ?
sudo nano /boot/config.txt

bon, c’est surtout pour ceux qui comme moi…copie bêtement avant de réfléchir ! et surtout sans remonter quelques messages plus haut !
et je confirme…ma Led (SD) ne clignote plus !

Merci, c’est corrigé.
En plus de ne plus clignoter, cela fait baisser la charge et au final, la température de la CPU.

=> Rendons à César se qui lui appartient, c’est une astuce de @Kerdale

Bonsoir,

Quelqu’un a t’il essayé sur un PI4?

Bonsoir.

A voir ici :