Préparation tuto Virtualisation (réglages des problèmes)

Bonjour
J’avance à petit pas sur l’installation de JEEDOM en Virtualisation station sur le nas qnap.

Je prépare un tuto mais avant de le diffuser je veux régler tous mes soucis (pour compléter au max mon tuto)
« Ce tuto comprendra l’installation de A à Z comme sur synologi. »

Donc à ce jour j’ai réussie à installer Debian version 11 + jeedom.

Je rencontre 5 problèmes, je vais commencer par les dongles.
3 sont installés:

  • RFXcom pas de problème fonctionne 100%
  • Zwave reconnu sur lsUSB mais impossible de lancer demon en NOK (on dirait qu’il manque des ports)
  • Combee2 alors lui tout en vert mais quand je regarde sur virtualisation l’usb se déconnecte en permanence (essai sur rpi pas de problème).

PI: je précise que j’ai activé seulement le port USB2 sur virtualisation bien sûr, pour combee2 je l’ai mis sur un hub pour éliminer le problème de tension mais cela ne change rien, mon combee2 et sur une rallonge éloignée de toutes sources perturbatrices.

Ensuite 3 autres plugin sont en NOK mais j’en parlerai après.

Voila pour l’instant si vous avez des idées pour avancer ? car avec ma petite connaissance j’ai du mal à avancer.

On voit bien le combee2 mais il se déconnecte et reconnecte en permanence et créé un nouveau numéro usb style 1-8 puis 1-9 …
Capture

voici la liste des ports sur le plugin ZWAVE on dirait qu’il en manque.
2

Cordialement CARI

Il faut debian 10 (python2).

2 J'aime

merci donc tous mes soucis viennent de la version debian ? , ou trouve t on cette distribution ?

merci

https://www.debian.org/releases/buster/debian-installer/

merci je suis bon pour recommencer à zéro, je refais un retour demain

1 J'aime

Bonjour,
Il serait peut être intéressant d’installer directement le nouveau #plugin-zwavejs (qui est en Bêta pour le moment mais très proche de la stable) et qui supporte Debian 11.

1 J'aime

Salut,

Avais-tu vu ce que j’avais mis sur ton précédent post. C’était pas pour rien que je te donnais le lien de la V10

  • Combee2 alors lui tout en vert mais quand je regarde sur virtualisation l’usb se déconnecte en permanence (essai sur rpi pas de problème).

PI: je précise que j’ai activé seulement le port USB2 sur virtualisation bien sûr, pour combee2 je l’ai mis sur un hub pour éliminer le problème de tension mais cela ne change rien, mon combee2 et sur une rallonge éloignée de toutes sources perturbatrices.

A mon avis tu as un souci avec la cascade usb, l’alimentation n’est pas suffisante sur la clé ou ton hub est usb3 branché sur usb 2 en cascade ou incompatible avec le port USB du NAS QNAP (ce serait pas une première). Je n’ai aucune autre explication rationnelle à proposer.

tu peux regarder l’historique des connexion / déconnexion pour comprendre ce qui se passe :

sudo cat /var/log/kern.log | grep usb

et

sudo cat /var/log/syslog.1 | grep usb

ensuite tu dois bien comprendre l’architecture de ton NAS et pour ça il te faut voir le résultat de :

sudo lsusb -v -t

il te montre combien tu as de bus usb et qui est branché sur quoi. avec cette commande tu peux jongler pour changer de hub et pas seulement de port.

exemple d’un ordinateur à 2 hub usb avec tout sur le bus 1 :

/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/6p, 5000M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/7p, 480M
    |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 2: Dev 3, If 0, Class=Communications, Driver=cdc_acm, 12M
    |__ Port 2: Dev 3, If 1, Class=CDC Data, Driver=cdc_acm, 12M
    |__ Port 4: Dev 36, If 1, Class=CDC Data, Driver=cdc_acm, 12M
    |__ Port 4: Dev 36, If 0, Class=Communications, Driver=cdc_acm, 12M

ce qu’il faut savoir c’est que les clés consomment 100mA en général, c’est pas beaucoup mais bon …

S: Product=ConBee II
C: #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA

ça tu peux le voir avec cette commande :

sudo usb-devices | grep 'Product=\|MxPwr'

branche ta clé en direct et tente un autre port pour voir si la connexion usb est durable. ajoute ta rallonge ensuite et reteste. Tu as peut être aussi un souci avec ça …

Certains ports ne sont pas alimentés de la même manière c’est certain.
Tant que l’usb est pas stable côté OS ce n’est pas la peine de regarder la couche applicative jeedom :slight_smile:

bon seul chose que je n’avais pas essayé c’est le hub branché sur le port usb 3 du nas et combee2 sur un port du hub, cela fait 30 minutes que je n’ai pas de connexion, à suivre ne crions pas victoire… c’est vicieux quand même

j’ai fait plusieurs essai et il y a que hub sur usb3 et combee sur port usb 1 du hub si je mets la rallonge cela ne fonctionne pas déconnection intempestive.

voici les nouveaux résultats après la manip ci-dessus:
5

6

Par contre impossible de lancer le bon fonctionnement du plug in, tout est en vert sur l’interface mais il ne se connecte pas au combee2, lorsque j’appuis sur le bouton ci dessous pour aller sur la page de phoscon j’ai un message que le « ce site est inaccessible ».
8

merci pour ton aide

je pense que ta rallonge manque de blindage. c’est toujours un problème de mettre des antennes déportées filaires avec autre chose que du coax. si tu as un bon câble usb pour l’audio, ils sont en général très bien blindés, tu peux essayer alternativement.

je ne sais pas te dire pour le site web phoscon, je n’utilise plus le plugin en question, mais le zigbee officiel qui marche sans tout ce mic-mac :slight_smile:

merci neurall tu m’as déja bien aidé.

point situation :
installation débian et jeedom ok

  • rfxcom fonctionnel
  • zwave fonctionnel
  • deconz ok, accès à phoscom ok quand je branche la clé, mais il me semble quelle ne fonctionne plus au bout d’un moment car je n’ai plus le firmware affiché voir impression écran , impossible de faire une intrusion et ma sauvegarde a bien été chargé mais non fonctionnelle que ce soit phoscom ou le plug in deconz de jeedom.
    10

2 plug in en nok soit : google cast et web os TV mais pour l’instant priorité combee2

bonjour ,

aujourd’hui combee2 opérationnel pourquoi…, peut être parce que j’utilise une rallonge blindée et que le stick est éloigné de source perturbatrice (de plus plus besoin de hub)

Bon à voir la stabilité (mini 24h00 pour commencer)

donc reste à régler 1 plugin en NOK

  • google cast impossible de lancer le demon (en nok)…
    - plugin webos tv ou les dépendances ne s’installaient pas, réglé en supprimant et re-installant.

  • reste également l’accès vers l’extérieur pour cela faut il que j’utilise lets encript et installation classique ou y a t il une manip spéciale sur un NAS ?

par contre je prépare mon tuto ou d’après vous je le poste.

Pour l’accès ext;

Je viens de regarder rapidement pas tout compris dsl le reseaux ce n’est pas mon fort.

J’ai un domaine ovh, je peux l’utiliser ? La mise en place de lets encript sur debian, je peux utiliser la méthode classique soit https://certbot.eff.org/ avec config apache et debian10 ? Via putty?

Et qnap ssl + reverse proxy c’ est une surcouche de protection mais pas obligatoire ou une autre façon d 'accéder de l’extérieur ?
Dsl pour toutes ces questions.

Cdt cari

pour accéder à ton Jeedom sans te prendre la tête avec zéro maintenance, tu peux utiliser les DNS de Jeedom. pour en savoir plus tu peux lire l’article suivant :

c’est ce que je fais pour la domotique, en nuc et vm et ça marche plutôt très bien. Tu as une adresse permanente que tu peux choisir sur leurs serveurs DNS qui permet d’accéder à ton Jeedom depuis l’extérieur via un tunel VPN.

salut SWR j’ai installé le certificat let’s encrypt SSL dans qnap, fait la redirection de mon nas vers l’extérieur du coup j’accède a mon menu du nas via internet, mais comment lié ip jeedom au reverse proxy ?
par contre quand je regarde le réseau de mon VM jeedom
il n’y a rien d’écris sur l’adresse ip mais j’y accède quand même avec 192.168.1.52
11
et sur qnap cloud mon routeur rate le test je suis sur sfr fibre
13

Tout dépend, si tu veux utiliser le domaine OVH que tu as (redirection sur jeedom & letsecrypt) ou utiliser le domain Qnapcloud (le reverse dns offre une protection supplémentaire, et un peu plus simple).

Note: la config auto du routeur est NOK (c’est juste une option automatique), il n’est d’ailleurs pas recommandé de l’activer pour une raison de sécurité.

je veux utiliser le domaine qnapcloud mais je n’arrive pas a le configurer . et ceux malgré le tuto que tu m’as envoyé

Il est déjà actif puisque tu as l’adresse sur la dernière copie d’écran.

Ouvre le port sur ton routeur et l’envoi sur le nas en 443(ou autre si différent)
Et utilise le reverse proxy pour renvoyer sur la VM (comme le tuto)
reverse_proxy_07

on est d’accord que je mets l’ip de jeedom sur localhost soit 192.168.52 ? et sur port number dessous je mets le chiffre qui correspond au numéro de port dans administration système ?

et sur mon routeur je mets l’adresse ip de nas 192.168.1.40 ou de mon jeedom 192.168.1.52 pour le renvois ?
ce qui me dérange c’est que l’ip n’est pas indiqué cela ne peut pas foutre le bordel
11

dsl je suis novice en réseau