[Partage] Thermomètre et hygromètre avec Image + réveil

Tags: #<Tag:0x00007f3854b5dd10>

Bonjour,

Je viens de faire un widget thermomètre avec Image en réutilisant des images existantes comme dans la version 3 de « ajja17 ».

J’ai fait une version simpliste affichant pour le moment le thermomètre à gauche et la température (+stats) à droite. Au lieu d’avoir 3 images, j’en ai mis 10 de plus :
image

Voici un aperçu du widget :
image

Les images et le script sont sur mon git : https://github.com/Heliospeed/jeedom_widget_v4/

8 J'aimes

Sympa, merci :+1:

Dans ma lancée des widgets, je viens de faire le widget Hygromètre comme celui du thermomètre.
J’ai repris les images du widget v3 de « Dany21000 » que j’ai redimentionnées pour être à la même taille que les images de la température :
image

Voici un aperçu du widget :
image

4 J'aimes

Merci, tres chouette!

Je suis content que ça plaise.

Je viens de faire un widget de reveil en réutilisant les images du widget v3 alarm-clock. Je ne le trouve plus sur le market pour identifier l’auteur des images…

Dans ma version, la commande d’info doit contenir une date au format « jj/mm/aaaa hh:mm:ss » et la date s’affiche si l’alarme est future et dans les prochaines 24h.
Il y a un paramètre ratio optionnel pour réduire ou agrandir légèrement l’image.

voici un exemple :
image

Bonne soirée

Bonjour
Petite question, j’ai l’impression que la tendance ne fonctionne pas. Quelle est la configuration à appliquer? J’ai déjà activé l’historique sur la commande.
Merci

Bonjour,
Il n’y a rien à appliquer, c’est le fonctionnement Core de Jeedom. J’ai juste déplacé les infos visuellement. Sinon par défaut cela s’affichait sous le widget « min|moy|max|tendance » sans légende.

Dans la configuration des commandes de Jeedom, il faut par défaut avoir 2h d’historique pour la tendance et 24h pour les min/max et moyenne.
C’est paramétrable dans Système/Configuration/Commandes :
image

J’espère que cela va t’aider.

Bonjour
ça fonctionne, c’est que sur les température intérieur, la variation était trop lente.
Merci beaucoup pour l’aide.
Nicolas

Exactement ce que je cherchais ! Merci beaucoup pour ton travail !

Hello,

j’ai un thermometre zwave qui remonte 2 chiffres après la virgule, et l’affichage ne fonctionne pas bien, ça s’affiche en dessous au lieu d’être à côté.

ça marche très bien sur mes sonde rfxcom, qui n’ont qu’un chiffre après la virgule.
Comment puis-je soit changer la largeur d’affichage, soit tronquer à 1 chiffre après la virgule, le second est vraiment inutile.

image

Mulb

Il me semble que c’est dans les propriétés de la valeur, onglet configuration.

Antoine

1 J'aime

Bonjour,
Je viens de publier une nouvelle version qui n’affiche q’un seul chiffre après la virgule.

quelle réactivité !! merci

Bonjour , merci déja pour le boulot nickel pour le thermomètre , par contre j’ai un soucis avec l’humidité je sais pas si j’ai fait une erreur mais a la place de l’image de l’humidité j’ai le script qui s’affiche
image

Salut,

il doit manquer un guillemet quelque part (") ou un truc du genre…

Bonjour,

Refait un copier-coller du contenu du fichier et remplace le dans le widget, cela devrait fonctionner.
https://raw.githubusercontent.com/Heliospeed/jeedom_widget_v4/master/hygrometer/cmd.info.numeric.hygrometer.html
Il faut peut-être ensuite désactiver et réactiver le cache des widgets. Il m’est arrivé qu’il faille attendre un certain temps pour être pris en compte par le navigateur…

Merci pour vos réponse j’ai recopier le contenu et vider le cache mais toujours le même résultat j’ai essayer de trouver une erreur mais vu mon expérience lol je n’ai rien trouvé.

Bonjour,
Tu utilises quel navigateur ?
De mon côté j’ai testé avec Chrome, Edge Chromium et Safari, je ne rencontre pas ce problème.
J’ai appliqué le widget sur le plugin thermostat, ça marche aussi.
J’avoue ne plus avoir trop d’idée comme ça.

J’utilise chrome

Je viens d’essayer sur Edge et c’est pareille