[Jeedom Connect] Beta 0.17.x

Tags: #<Tag:0x00007fcb9a2bc4e8>

Bonjour à tous,

je crée ce post qui a pour but de discuter de la version 0.17.0 Beta (Plugin + App).
Lien direct vers la version 0.17.0

Version 0.17.0 (04/03/2021)

  • Ajout d’un bouton Dupliquer pour les widgets
  • Ré-écriture du sélectionneur d’icônes / images
  • Possibilité de choisir image ou icône sur les widgets
  • Possibilité d’ajouter des commandes infos à tous les widgets
  • Images sous conditions dans tous les widgets
  • Possibilité de personaliser les champs Nom et Sous-titre à l’aide de commandes infos
  • Améliorations diverses et corrections de bugs dans l’appli

Version 0.17.1 Beta (05/03/2021)

  • Possibilité d’envoyer plusieurs images dans les notifications
  • Images dans les notifications accessibles en cliquant dessus (plein écran, zoom et scroll)
  • Widget clim : fanSpeed non limité
  • Nouveau slider pour la température de blanc dans les widgets de lumière
  • Nouveau widget Web View qui permet d’afficher un design, le dashboard ou n’importe quelle page web
  • Bug fix

Il est maintenant possible pour un widget d’afficher :

  • Une image avec option Noir et Blanc
  • Une icône (Jeedom, Material Design ou Font Awesome) avec option de couleur (si pas de couleur, elle sera noire en thème clair et blanche en thème sombre)

Vous pouvez maintenant ajouter autant de commandes Info à chaque widgets.
Ces infos et leur historique apparaitront dans la page de détails du widget.
Acompagnées de la nouvelle notion de variables (dispo à gauche de la page de config) elles servent aussi à :

  • Définir des conditions pour l’affichage de l’image/icônes.
  • Formater les champs Nom et Sous-titre . Un sous-titre pourra par exemple être #statusText# à #[Salon][Lampe][Intensité]#% et donnera Allumé à 60%. Vous pouvez aussi utiliser la fonction time pour écrire par exemple #statusText# depuis time(#[Chambre][Lampe][Etat]#) qui pourra donner dans l’appli Allumé depuis 24min 30s

Attention breaking changes : de nombreux champs d’images ont disparu de la configuration et seront perdus (car doublon avec images sous conditions). N’hésitez pas à retourner dans la config de votre widget et faire Sauvegarder.
Je n’aime pas trop faire ça mais j’espère que vous comprendrez que c’est un mal pour un bien :wink:

2 J'aimes

Hello. Page blanche pour moi suite à la mise à jour…
plugin 2021-03-04 11:18:05 . C’est le bon ?

Oui c’est le bon :wink:
Pourrais-tu désactiver tes menus puis les réactiver un à un pour voir ?
Si tu tombes sur un menu qui bug, désactive ses widgets et réactive les un à un.
N’hésite pas à refaire les images dans les widgets puis valider et Sauvegarder.

N’hésite pas non plus à redémarrer l’appli

1 J'aime

Hello

Testé à l instant de mon côté, cela fonctionne correctement.
Merci

C’est bon j’ai trouvé, effectivement , à priori le widget info global qui avait perdu sa conf. et un autre widget dans le même menu qui avait perdu ses commandes.
un des deux cas.
mais ça semble résolu, merci pour ton aide

Bravo pour cette version, que des améliorations ! encore plus pratique à utiliser et configurer !

Merci !!! impec cette mise à jour.

J’ai un petit souci sur le générique actions.
Les icones ne s’affiche pas (perso ou non).

ex:
image

J’ai vidé le cache de mon application mobile mais rien n’y fait.

Merci d’avance :wink:

En effet je les avaient oublié ceux là !
Je corrige ça pour la prochaine maj !

1 J'aime

Merci à toi Jared, toujours au top :love_you_gesture:

La personnalisation se simplifie et est assez efficace…

De mon côté, le chargement de sélection d’image est assez long ! Je ne sais pas comment c’est chez les autres, mais si cela se généralise, pourrait on envisage le choix de les portefeuilles d’icônes (activer que ceux de jeedom par exemple et pas FA/MD ) ?

Autre chose, c’est normal qu’il n’y a pas d’icône auto sur les widgets « PIR », « porte » et « fenêtre » alors que sur « alarme » c’est bon ?

chez moi tout va bien !
est ce que tu as essayé plusieurs fois ? c’est peut etre la mise en cache initiale qui peut prendre du temps !?

pas certain d’avoir compris le « icone auto » ?
dans la partie assistant tout est OK.
par contre une fois sur l’apk on se retrouve avec l’icone « i » (infos) => c’est ça que tu veux dire !?

ça c’est vraiment top !! :+1:

deux petits bugs pour moi :

  • un côté affichage sur le plugin : ( :slight_smile: )
    image
    j’ajoute une info que j’utilise en sous-titre perso : lors de la création tout est OK. quand on revient en édition par contre on a le numéro de commande (et non plus le string humanReadable)

  • un côté apk :
    j’ai défini une action RAZ, quand je clic sur la vignette correspondante dans l’apk, l’appli se kill (et je ne vois nul part l’icone que j’ai sélectionné sur le plugin pour cette action)
    rien dans les logs

Merci pour ton retour !
Pour la lenteur niveau icônes tout est relatif mais ça devrait pas prendre plus de 3 ou 4s. C’est bien sûr du au fait qu’il y a énormément d’icônes !
C’est du JS qui s’en charge donc exécuté côté client sur votre browser.

Pour les icônes auto je suis pas bien sûr de comprendre ta question. Est ce que tu veux dire que tu n’as configuré aucune icônes/images et que tu n’as pas le comportement par défaut dans l’appli ?

Pour le premier bug je vais voir ça ! Est ce tu as le human name dans le bouton + ?

Second: est ce qu’il s’agit du générique action ? C’est la vue détails qui fait buguer ?

yes avec les +
image

oui

visiblement oui.
l’icone choisi pour l’action n’est pas visible en mode vignette, il n’est montré qu’en mode détail c’est bien ca ?

C’est l’icône d’une action ou l’icône du widget ?

image
l’icone de l’action => mais je ne la vois pas. j’imagine elle est affichée que sur la vue détails !?
donc puisque ca plante avant (quand je click sur l’icone de la vignette pour aller sur la vue détail) c’est surement normal que je ne vois pas :slight_smile:

Affiché dans la vue détails et dans la vue ‹ carte ›.
L’action a été créée avant la 0.17.0 ?

Je confirme, j’ai du les mettre avec images sous condition pour que ce soit ok.
(Cela veut dire que le widget n’affiche pas les icônes par défaut si aucune image sous condition définie).

Sinon j’ai un bug avec le groupe de volets, les images sous conditions sont purement ignorées peut importe la variable utilisée, c’est celles par défaut qui sont affichées.

non je viens de la créer, car j’avais besoin des « autres infos » pour que le widget soit intéressant à créer :slight_smile:

en image :
Screenshot_20210304-202758_Jeedom Connect_1
lors que suis en mode vignette, si je clique sur une de ces 2 actions génériques pour voir le détail et accéder à l’action => l’apk se kill


Screenshot_20210304-202754_Jeedom Connect_1
si je bascule en mode carte, alors je vois bien l’icone de l’action (probleme d’icon d’ailleurs j’avais choisi un mdi ! ), et là au click l’action est correctement réalisée