[Tuto] Homebridge et Google Smart Home

Tags: #<Tag:0x00007fcba006baa8> #<Tag:0x00007fcba006b9e0>

Je vois que @noodom à configuré des volets aussi, tu peux nous éclairer @noodom ? :wink:

1 J'aime

Ce qui est étrange j’ai le même soucis avec les sondes températures alors que la case est bien cochée !
ce qui fonctionne :wink: :

  • prises
  • thermostat
  • ampli
  • presence iphone

J’utilisais plus ma Nesthub pour mes volets et je viens de voir que ça ne fonctionne plus.
je crois que je vais devoir refaire l’installation, j’ai un peu tout cassé depuis avec pas mals de manips diverses…

Par contre, les volets sont toujours bien présents en effet.

D’après moi, impossible de piloter les volets sur l’appli Google uniquement à la voix.
Idem pour les capteurs de température non pris en charge par Google

Alors je viens de tester et effectivement à la voix sa fonctionne. Idem pour la température. On ne peut juste pas les associer à une pièce.

Oui car non pris en charge par Google :-1:

1 J'aime

Rectificatif de ma configuration :
Je suis sur un Docker Homebridge et après une mise à jour de ses plugins Homebridge Google Smart Home et Homebridge UI,
je peux à nouveau utiliser les volets depuis ma NestHub (depuis l’écran et par la voix)

J’ai bien la déclaration des volets dans chacune de mes pièces et j’ai pu ouvrir mes volets en précisant le nom des volets et de la pièce.

Tu es configuré comment dans Homebridge ?

Moi aussi mais c’était pareil avec le plugin Google SmartHome de Jeedom.
Je pense que c’est le comportement normal.

Alors, je viens de réinstaller avec ce nouveau tuto : encore une fois, bravo @nebz
Installation parfaite !

Donc voilà pour mes premiers retours (avec un test « ouvre les volets de la chambre ») :

  • transfert des équipements vers l’appli Google Home OK
  • utilisation des volets depuis le vocal de Google Nest Hub OK
  • utilisation des volets depuis l’écran de Google Nest Hub OK
  • utilisation des volets depuis le vocal de l’application Google Home sur iPhone OK

Application Google Home :

  • refus sur certains équipements de modifier la pièce (OK après relance appli)
  • doublon inexpliqué de volets dans une pièce (ancienne config ? à voir)
  • Il me reste pas mal de configurations en cours par rapport à mon ancienne config (suppression du lien de l’appli Google Home)
  • thermostat : il me demande de migrer vers un compte Nest (pas validé avant de me renseigner)
1 J'aime

Si tu regarde le lien du tuto, les capteurs température sont pas pris en charge par Google il dit

1 J'aime

Bonjour @nebz et merci pour ce tuto.

L’installation s’est faite sans problème et tout fonctionne parfaitement sauf que j’ai un petit problème avec mes équipements CPL Legrand (J’utilise le plugin Boxio pour piloter mes équipements CPL) :

J’ai plusieurs éclairages et prises commandées dans certaines pièces et lorsque je demande à Google Home de tout allumer ou tout éteindre, cela se passe mal car si les commandes CPL sont envoyées trop rapidement les unes à la suite des autres elles se perdent.

Dans certains de mes scénarios, lorsque je souhaite commander plusieurs équipements CPL à la suite, je suis obligé de mettre un sleep de 200 ou 300 ms.

Comment faire avec Homebridge pour rajouter cette tempo entre chaque commande ?

Merci.

Hello, ce n’est pas possible. Pour moi c’est lié au matériel, donc doit être géré dans le plugin du matériel.

Passe par un virtuel qui lance un scénario qui inclus des pauses pour temporiser

2 J'aimes

Impossible de déverrouiller une serrure aussi sur l’appli
J’ai un engrenage :gear: sur le logo de la serrure comme pour les volets roulants

Pareil pour vous ?

C’est aussi l’idée que j’avais mais c’est un peu lourd.

Elle se perdent ou ? Le plugin CPL reçoit les demandes je suppose. Donc c’est lui qui sait pas gérer l’espacement des commandes

C’est le seul moyen a moins que le plugin que tu utilises pour le CPL, gère un spool de commande pour les envoyés de façon espacé

Elles se perdent ou plutôt se télescopent sur le réseau CPL.

J’ai déjà des virtuels pour pratiquement toutes mes lumières. Je regarde pour mettre un sleep dans chaque commande des virtuels dans roue crantée/configuration/Action après exécution de la commande.

Merci.

Oui donc c’est au plugin de gérer un spool pour les espaces

Pas sur que ca bloque l’appel d’une autre commande.

Oui, en fait cela ne fonctionne pas, les commandes sont envoyées en parallèle par homebridge.