Probleme plugin BLEA + dongle USB

Tags: #<Tag:0x00007f243218f5d0>

Que donne la commande hciconfig ?

Et pourquoi la log parle du hci1 alors que le dongle USB est le hci0 chez vous ?

Salut Fabrice‚

Le Hciconfig est indique que mes BT sont DOWN !

Capture d’écran 2020-05-01 à 19.42.19

Pour ta 2eme question j’en ai aucune idée ? j’avais pourtant configurer le port hci0

et maintenant je n’arrive plus a forcer un UP

Capture d’écran 2020-05-01 à 19.53.20

ca me rend fou cette affaire !

Bonsoir.

Je n’arrive pas à trouver de solution pour aider.

Bonsoir,

Est-ce qu’après un reboot du rpi le port du bluetooth réapparaît tout seul dans BLEA ?

Bonsoir.

Oui (en principe, c’est comme cela sur tous mes pi)

C’est malheureusement un problème connu sans solution.
Certains disent que c’est la cohabitation d’une clé Z-wave et du bluetooth sur le même rpi…
Je ne sais pas, moi j’ai mis un système de surveillance du plugin, dès qu’il perd le port bluetooth, il reboot…

Ah oui effectivement j’ai aussi une clef Zwave sur le meme RPI !

Amarock85, tu as résous ton problème comme ca ? en rebootant a chaque fois le RPI ?
Quand tu reboot la configuration du BLEA se relance correctement ?

Est ce un problème liée au RPI 3 ? sur un RPI 4 se serait pareil ?

Bonjour @Cyssou40,

Oui en rebootant, le port bluetooth est configuré correctement. Il ne reboote que les 2-jours, parfois c’est plus court, parfois plus long…
Pour le rpi4, je ne sais pas. J’ai un rpi3b+ et un rpi2 qui me sert d’antenne bluetooth deportée. Le rpi2 n’est pas affecté.

Ok du coup J’ai 2 solutions :

1/ soit j’install mon dongle sur USB sur un 2eme RPI

2/ soit je reboot mon RPI dés que le plugin blea perd le port du dongle.

Petite question bête mais trop rebooter un RPI ca ne l’endommage pas ?

Je ne sais pas…
En revanche tout est en stable (core et plugins) afin d’éviter le moindre problème au démarrage.

Ok je vais commencer par suivre le tuto sur t’as mis en lien pour rebooter le rpi.

On verra après pour une antenne déporté

Merci je test ca et je ferais un retour d’état

Ok.
Petite précision quand même je boote sur un petit SSD mSata de 30 Go . Pas sur la carte SD où je n’ai que le fichier bloot.ini .(J’ai un hub alimenté qui me posait problème à l’époque, résolu grâce à ça)

ok je boot direct sur la carte SD du RPI. est ce que cela change quelques choses du coup ?

Dans watchdog tu as mis combien en tempo ?

oubli la carte SD (trop fragile), je boote sur le SSD.
Je n’ai mentionné la carte SD uniquement parce que j’avais un Hub qui empêchait tout redémarrage. Si tu n’as pas de problème de démarrage, ne l’utilise pas.
Concernant watchdog, je ne l’utilise pas finilement. je suis parti sur un scénario qui exclu les heures de sauvegardes pour le reboot.

Je ne suis pas du tout d’accord avec cela.

J’ai plusieurs Pi et je n’ai pas de perte de Bluetooth et une clé Zwave aussi.
Sur les Pi, j’ai un SSD (mSATA) un RFXCom, une clé Bluetooth et une clé ZWave.

  • Et pas de déconnection Bluetooth.

  • Le problème est ailleurs que dans la configuration matériel.

1 J'aime

Je n’ai pas dit que j’étais d’accord avec ça. Je pense tout de même à un problème matériel, mais lequel ? C’est une situation qui se reproduit chez pas pas mal d’entre nous dont personne ne donne une solution fiable après des nombreuses recherches sur le nouveau et l’ancien forum.
Seule solution, le reboot…

Je suis d’accord avec toi Fabrice. C’est une solution de repli effectivement.

Je n’invente rien malheureusement‚ je suis une bille en prog. Je ne suis bon qu’a suivre vos super tutos (un grand merci au passage !!). Dans ce context je suis complètement dependant des gens compétant qui finiront par trouver une solution.

En attendant de trouver d’ou vient le problème‚ rebooter le rpi pour relancer le demon blea est une bonne idée.

Pareil :wink:

Bon ca y est j’ai tout mis en place Jeelink et watchdog configuré. J’ai aussi configuré pour recevoir une notification lorsque demon blea s’arrête comme ca je verrais si ce que j’ai fait fct bien.

Salut @Fabrice,

En fait il y a bien un lien entre zwave (usb) et bluetooth (interne)… Lors de l’installation des dépendances de zwave, si l’installation détecte un pi2/pi3, il y a désactivation de l’uart (qui est lié au BT). C’est censé permettre l’usage de la carte Razberry sur GPIO…
J’avais fait l’analyse il y a déjà un moment

RPI_BOARD_REVISION=`grep Revision /proc/cpuinfo | cut -d: -f2 | tr -d " "`
if [[ $RPI_BOARD_REVISION ==  "a02082" || $RPI_BOARD_REVISION == "a22082" || $RPI_BOARD_REVISION == "a020d3" ]]
then
   systemctl disable hciuart
   if [[ ! `grep "dtoverlay=pi3-miniuart-bt" /boot/config.txt` ]]
   then
      echo "Raspberry Pi 3 Detected. If you use a Razberry board you must Disabling Bluetooth"
      echo "Please add 'dtoverlay=pi3-miniuart-bt' to the end of the file /boot/config.txt"
      echo "And reboot your Raspberry Pi"
   fi
fi

Quand on a pas de carte Razberry (mais juste un PI), c’est quand même désactivé…à chaque fois que les dépendances se lancent…Et au reboot suivant, c’est le drame si on utilise le BT interne, le port n’est plus dispo etc…
Si on a utilise le BT USB, on passe au travers… si on a un pi4, on a pas ce souci non plus