Plugin MyAudi : Impossible de lancer le daemon

Tags: #<Tag:0x00007fe319b54f88>

Bonjour @Mips2648

Je viens d’installer ton plugin MyAudi et je n’arrive pas à lancer le démon.
Je suis en version 3.3.9 de jeedom

Dans le log « myaudi_daemon » j’ai le message suivant « sudo : python 3.7 : command not found »
J’avoue ne pas trop savoir qu’en faire mais je peux faire quelques vérifications sur tes conseils si tu en as.

bonne soirée

Bonjour,
Je vois ce message par hasard, mauvais pseudo…
Si jeedom ne vous propose rien avec le @mips4567 c’est que ce n’est pas bon :wink:

Pour le problème, je vois ce que c’est; ma faute. Je vais pousser un fix

Bonjour, ok pour le pseudo, je l’avais récupéré du market j’avoue;)
pas de soucis pour le fix
bonne journée

Nouvelle beta devrait etre ok, force un refresh des mises à jours

Oui je viens de l’appliquer, le démon se lance merci pour la correction.
A l’ouverture j’ai erreur 500 mais je vais regarder en détail avant de te solliciter si ce n’est pas de mon côté

Donc le plugin fonctionne, je récupère bien les infos de mon véhicule.
Cependant quand j’ouvre mon équipement, la page se charge mis à part la photo du modèle ce qui est peut être normal et j’ai une bannière rouge apparaissant en haut de page « 500 : Internal Sever Error ».
Pas d’erreur dans les log du plugin.
Pas contre dans le log « http.error » j’ai l’erreur ci après :
[Thu Mar 19 18:09:51.882611 2020] [:error] [pid 595] [client 192.168.59.254:60937] PHP Fatal error: Uncaught Error: Class ‹ arlo › not found in /var/www/html/plugins/myaudi/core/ajax/myaudi.ajax.php:30

Une piste ?

Avec cette erreur, on sait quel plugin a servi de base au plugin myaudi. :wink:

Editer le fichier cité et remplacer arlo par myaudi à la ligne 30

parfait merci :slight_smile: ne sachant pas ce qu’était arlo … je ne pouvais pas corriger.
@Mips, à l’occasion petite correction à faire dans le plugin

Oups désolé, le copier coller c’est le mal :innocent:

Voila, c’est fixé.
Merci les versions betas :wink:

oui j’ai installé en connaissance de cause, il s’agit d’une béta :wink:
après si je peux aider en remontant les petits désagréments autrement appelés bug

Sur. Ne te prives pas.
Pareil sur les fonctionnalités :wink:
Quel type de véhicule as-tu ? Surtout niveau carburant / moteur (thermique, électrique ?)

Dans les fonctions à rajouter dans ma liste :

  • statut des fenêtres et portes ;
  • statut du verrouillage.
  • pouvoir verrouiller / déverrouiller les portes.

A4 Avant TFSI 2.0 190CH
J’ai vu oui ce que tu prévois d’ajouter :wink:

Bonjour,

Je viens d’installer le plug-in et pb de démon qui s’arrête.

[2020-03-24 09:12:27.654][ERROR] : Fatal error : API error: {‹ errorCode ›: ‹ VSR.security.9007 ›, ‹ description ›: ‹ The service: statusreport_v1 for VIN: WAUZxxxxxxxxxxx could not be found. ›}

Le compte et MdP sont corrects, j’ai bien eu la création de la voiture et tout est à 0.

Une idée ? Je suis en version bêta.

Merci

Bonjour,

Il n’y a pourtant pas beaucoup de sujet sur le plugin…

N’est-ce pas le même problème?

Je pense avoir trouvé. Je n’ai pas accès à toutes les infos dans l’appli my audi. On me demande d’appeler la concession pour qu’ils me valident comme propriétaire du véhicule. On verra après le confinement

Bonjour,

Alors d’abord merci pour ce pluggin, ca va être super sympa !

Pour ma part impossible de démarrer le Démon pour l’instant.
Je suis en Jeedom 4.0.45.
J’ai vérifié mes login et pwd Audi, ils sont justes.
J’ai toutes les remontées d’info dans l’application MyAudi.

Voici le message d’erreur que j’ai en log :

      *SyntaxError: invalid syntax*
      *Traceback (most recent call last):*
      *File "/var/www/html/plugins/myaudi/resources/myaudid/myaudid.py", line 11, in <module>*
      *from audiapi import API, Services*
      *File "/var/www/html/plugins/myaudi/resources/myaudid/audiapi/Services.py", line 66*
      *return super().url(part, **format_data, vin=self._vehicle.vin)*

Des idées ? Des suggestions ? Ais-je merdé quelque part ?

Merci d’avance et bon courage !

Bonjour,

peux-tu donner la versin de debian/raspbian sur laquelle jeedom se trouve ainsi que le résultat de la commande suivante:

python3 --version

Merci pour le retour.

Mon Jeedom tourne sur un Raspbian Jessie.

La commande pour Python donne : Python 3.4.2

Il faut minimum python 3.5 qui n’est dispo que sur stretch.
Il faut que tu mettes à jours linux en stretch, tu vas avoir le problème sur plus en plus de plugin car les dépendances ne sont plus disponibles sous Jessie et nous n’y pouvons rien, Jessie n’est plus maintenu.