Plugin jMQTT : présentation et informations de mise à jour

Tags: #<Tag:0x00007fda3002fed8>

Bonjour,

Le plugin jMQTT connecte Jeedom à un ou plusieurs brokers MQTT locaux ou distants.

Voici les caractéristiques principales:

  • Version minimale du core requise: 3.3.19
  • Support multi brokers
  • Installation (optionnelle) du broker Mosquitto en local sur la machine Jeedom.
  • Découverte des équipements et des commandes en mode automatique, ou manuel.
  • Ajout manuel d’équipements et configuration du topic souscrit (caractères # et + supportés).
  • Duplication d’équipement.
  • Décodage des payload JSON, avec possibilité de choisir les valeurs convertie en commandes info
  • Ajout manuel de commandes (topics publiés) avec configuration de la persistance (retain) par commande.
  • Accès à toute l’API JSON RPC via le protocole MQTT.

Merci de préférer le forum pour les demandes de support (créer des sujets dédiés avec le tag plugin-jmqtt), et GitHub pour les bugs ou demandes d’évolution.

La documentation est ici.

Ce sujet est dédié à l’information sur les mises à jour du plugin.

Bonjour,
Nouvelle version du plugin publiée ce matin. Elle améliore la gestion des payloads JSON:

  • Il est maintenant possible, via le panneau JSON, de choisir les valeurs de la payload qui sont converties en commandes info;
  • La case à cocher parseJSON disparait;
  • La version est compatible ascendant et conserve vos commandes info existantes dérivant de payload JSON. Vous pourrez supprimer les commandes des niveaux inutiles.

La documentation est à jour, bien lire la section Payload JSON du chapitre Commandes de type information.

bonjour,
je pense qu’il ya un souci avec la V4 de jeedom , j’ai des accolades un peu partout .
mais c’etait deja le cas avant la derniére mise à jour .
image
image
image

Oui, la compatibilité V4 est le prochain point que je regarde

Bonsoir domotruc,
je pense avoir le même problème que jul3925 sur le nouveau forum.
J’ai un payload json qui n’est plus rafraichi sur une des valeurs de type binaire.
Par contre je n’ai plus le bouton parseJson que je sois en mode classic ou json :neutral_face:

Si ça n’a pas changé c’est quelquechose dont on ne parle pas ici.
Le nom était même bloqué sur l’ancien forum.
@Alexandre: c’est volontaire de l’avoir débloqué ?

Bonjour,

Depuis la mise à jour, je ne peux plus séparer les valeurs avec Parse JSON du coup comment faisons nous pour récupérer seulement ce que l’on souhaite… ?
json

Je rectifie je viens de lire la doc suite à la mise à jour, j’ai comrpis la modificationet j’ai fait ça du coup :
jsond2

Mais que faisons-nous des anciens périphériques fabriqués avec parse Json on doit refaire pour que tout fonctionne bien ? Merci

Bonjour @kwet,
Les anciens périphériques fabriqués avec parseJSON doivent fonctionner, ils ont normalement été mis à jour. Ce n’est pas le cas?

Bonjour sisi désolé j’avais pas lu toute ta doc depuis la mise à jour que tu viens de réaliser, cela semble bon :wink: par contre j’ai un autre problème et je ne sais pas si cela vient de ton plugin ou de mon zigbeemqtt, j’ai posté cela d’ailleurs sur le fourum, tu as une idée ?
"
Vous avez déjà eu cela ?
Rectif, ce matin tous les capteurs (temperature, détecteur de mouvements, capteurs de portes, vibration) ne remontent pas les status à jours dans Jeedom (ok sous sudo journalctl -u zigbee2mqtt.service -f) mais pour que ça remonte dans Jeedom je dois redémarrer Jeedom…
La nuit j’ai mon wifi qui se coupe de 1h du matin a 5h du matin mais cela impacte normalement que les périphériques en wifi (type lampe Yeelight, prises électriques connectées) mais je vois pas le rapport avec mon architecture xiaomi en zigbee …

Merci
je vais devoir trouver un moyen de faire une relance jeedom automatique tous les matins vers 5h15 en attendant…"

Salut @Domotruc
Lien vers ancien forum
Meme probleme de mon cote suite a la mise a jour de jMQTT. Une idee du souci?

ça me rassure de ne pas être le seul :slight_smile:

@kwet , si tu jettes un oeil a l’ancien forum, tu verras que j’ai trifouille un petit peu le daemon, les dependances etc… La reinstall des dependances est bloquee a 60% a cause d’une question que pose le systeme a laquelle je ne sais ni quoi ni comment repondre… Bref, l’install est bloquee pour le moment mais les valeurs sont a nouveau remontees… Tu peux tenter, ca fonctionnera mais y’a un truc a eclaircir avec les dependances… Au bout de 30 min, Jeedom m’a mis un message d’erreur:
Attention : l'installation des dépendances a dépassé le temps maximum autorisé : 30min
Mais tout fonctionne… Je n’y touche plus!

Bonjour @Arnox,
Pour ce problème de mise à jour des dépendances, qui ne concerne pas la dernière mise à jour du plugin (c’est lié à une mise à jour des packages de l’OS), voici ce que je recommande:

  • Se connecter à sa station Jeedom via une console ssh
  • Relancer l’installation des dépendances via la commande sudo apt-get upgrade
  • De mémoire il indique que la dernière mise à jour ne s’est pas terminée et recommande de lancer la commande dpkg --configure -a. Le faire, et choisir l’option 1.
  • Revenir sous Jeedom et le plugin jMQTT et relancer l’installation des dépendances qui devrait se terminer correctement.

Ça devrait résoudre le problème d’installation des dépendances. Je comprend de ton message précédent que tu n’as que ce problème, et qu’il n’a pas d’impact fonctionnel sur jMQTT?

Bonsoir @kwet,
Quand tu as ce problème, dans le plugin jMQTT, est-ce que le démon associé au broker (aller dans l’onglet broker de l’équipement broker) est bien démarré (configuration et statut ok)?

Tout comme @kwet je n’avais plus de remontee d’infos depuis la maj. Le broker etait vert, je l’ai relance pour verifier que rien n’etait plante de ce cote la, et c’est la reinstall des dependances qui a tout decoince malgre l’erreur…

Vraiment bizarre, j’avoue ne pas saisir le lien. Tant mieux si tu as pu te déplanter :slight_smile:

Bonsoir @domotruc, merci déjà de prendre le temps pour mon problème.
Je vais essayer d’être complet. J’ai constaté depuis 2 jours que mes périphériques zigbee ne remontent plus de mises à jour d’informations durant la nuit. Le matin je dois relancer que jeedom et tout refonctionne.(pour voir l’heure de coupure je regarde l’historique de mes sondes température a quel heure plus de mises a jour).
Je regarderai demain si c’est planté le statut du demon du broker.
Ce que j’ai fait ce matin malgré que les statuts ne remontaient pas sur jeedom j’ai passé la commande : sudo journalctl -u zigbee2mqtt.service -f en ssh et la je vois bien les périphériques zigbee envoyer les bonnes informations… Pour moi le lien ne peut être que jqmtt après je suis novice dans Jeedom… Ou d’autres pistes ?
Merci et a demain :grin:

@domotruc
J’ai suivi tes instructions et ça a fonctionné parfaitement. Les infos remontent normalement… Merci pour le support!

1 J'aime

@domotruc bonjour
Bingo tu as vu juste le démon du broker est Pok (offline) ce matin…j’ai relancé manuellement sans erreur… Dernière remontée température a 00h00 bizarre comme hier
Que dois je faire pour trouver le problème ?

Merci

Bonjour @kwet,
Tu dis que tu coupes le wifi. Comment ta station Jeedom est-elle connectée au broker MQTT, via wifi?

Ceci-ci dit, normalement, si la connection au broker tombe, jMQTT essaye de la relancer chaque minute.

Pourrais-tu:

  • Regarder que dans le panneau de configuration de jMQTT, le cron est bien activé;
  • Me passer le log jMQTT en mode debug, le matin avant de relancer le broker;
  • Me passer le log du broker en mode debug, le matin avant de relancer le broker.

Merci