Plugin jMQTT : présentation et informations de mise à jour

Tags: #<Tag:0x00007f5924dc5508>

Le broker cc2531 est en USB sur mon raspberry pi4 qui lui est en wifi.
Je pensais que sans wifi ça n’avait pas d’incidence pour toute la partie en zigbee…
Le cron est bien activé.
Je viens de passer en debug, je verrai demain matin et je testerai le. Lendemain en laissant le wifi activée.
Demain je t’enverrai les logs (ce matin en default elles sont vides)

1 J'aime

@domotruc
Mais pour toi le raspberry doit obligatoirement avoir accès à internet pour que le réseau zigbee broker etc…fonctionne ?
Merci

PS : Pour info j’ai les logs depuis l’activation du mode debug donc demain en coupant le wifi j’espère avec tous les éléments pour confirmer.

Je ne connais pas zigbee.
Mais si ta passerelle zigbee, le broker mqtt et jeedom ne sont pas tous sur ton RPi4, il te faut le wifi (puisque ton RPi4 est connecté en wifi).

Si justement ils sont tous sur le RPI4.

Alors essayes d’utiliser partout l’adresse de loopback 127.0.0.1 pour configurer les services (et pas une adresse en 192.168.x.x attribuée par et nécessitant la connexion au routeur).

C’est pas bete…
j’ai voulu t’envoyer les logs ce matin car le service etait arreté. Je l’ai donc redémarré manuellement depuis le broker. Et la je regarde les logs, j’ai que depuis le redémarrage ce matin… :frowning_face:

Je vais laisser activer mon wifi cette nuit.

Bonjour,
Je viens de publier une nouvelle version qui corrige un problème introduit avec la version 2019-10-19.

Super mise à jour effectuée !
et je te confirme sans couper le wifi pas de coupure du démon du broker… cela m’embete un peu mais je vais devoir le laisser toute le temps en fonction c’est bizarre quand meme pour le fonctionnement de la clé zigbeemqtt…

Merci

Bonsoir @kwet,
Je comprend que ça t’embête de ne plus pouvoir couper le wifi.
As tu essayé d’utiliser l’adresse 127.0.0.1 pour configurer les services?
Autre solution : créer un scénario qui se lance un peu après l’heure de réactivation du wifi et qui désactive l’équipement broker puis le réactive; ça va forcer la relance du démon.

Bonsoir,
Une nouvelle version du plugin vient d’être publiée pour compatibilité core v4.
Cordialement

Bonsoir
J’ai remarqué suite à la dernière mise à jours, la gestion des majuscules, minuscules dans le nom des topic est devenu importante. Auparavant ça ne faisait pas de différence. Ça m’a value un peu de temps avant de trouver pourquoi mes chauffages était suspendu. Le temperature c’est pas identique à Temperature.
Au cas au quelqu’un d’autre est dans mon cas, ça ira plus vite pour le suivant.
Nico

Bonsoir @Nicocha,
Merci pour le retour, c’est je pense un effet de bord non conscient de l’évolution sur la gestion des payloads JSON. A vrai dire, je n’avais jamais réalisé que, précédemment, le topic était insensible à la casse. Comme c’est logique qu’il le soit, je vais laisser tel quel.

Merci pour la confirmation. Effectivement, maintenant je suis au courant je ne me referait pas avoir.
Colle ça ça respecte le principe du mqtt qui est effectivement sensible à la cass.

Bonjour,
Je vous alerte sur la présence de 2 bugs dans la version courante, voir GitHub :confused:
L’un est majeur, présent depuis la version 2019-10-19 ayant modifiée la gestion des payloads JSON: il conduit à la perte de commandes info, voir dans quelles conditions sur le fil GitHub dédié.

2 J'aimes

Bonjour,
Nouvelle version disponible (2019-10-31) corrigeant les 2 problèmes remontés dans le post précédent.

2 J'aimes

Merci 1000 fois @domotruc, tu fais un travail exceptionnel autour de ce plugin qui est un plugin majeur pour beaucoup d’entre nous.

Merci pour vos feedbacks, ca fait plaisir :smile:

Bonjour,
Encore une version en ce jour de Toussaint (2019-11-01) qui corrige le problème mineur de non visibilité des icônes pour plier/déplier les nœuds en vue JSON et core v4.

1 J'aime

Hello

Question svp, sur mes 6 shellies 2.5 la seule commande info qui soit remontée toute seule est “online”
Toutes les autres commandes info créées automatiquement sont remontées dans un device “shellies” qui regroupe donc toutes les commandes des 6 shellies en place. Son topic (remonté tout seul lui aussi) est “shellies/#”

J’ai peut etre mal paramétrés mes topics de mes shellies ?, ils ont la forme : "shellies/nom_de_la_pièce/#

Je souhaite utiliser l’info de conso instantanée dans mes scénarios et ca n’est pas pratique que l’info ne soit pas liée a la pièce concernée pour s’y retrouver… d’ou cette question !

thx

Bonjour @antar,
Quel est son topic?

Il faut que tu crées tes équipements manuellement, sans utiliser le mode d’Inclusion automatique.
Tu en crée autant que de pièce et tu leur attribues le topic d’inscription shellies/nom_de_la_pièce/# (EDIT: /# ajouté).