[PARTAGE] Jauges Highcharts paramétrable, ouvert aux contributions

Tags: #<Tag:0x00007f3853260358>

et CTXT2 fonctionne ?

oui il fonctionne lui

Salut @Spine
Tu as des news sur ton projet de solidjauge gradué ?

bon il a pas de raison alors sauf si tu a bricoller dans le code …
voici le miens
cmd.info.numeric.JaugeHorizontal.html.TXT.txt (15,6 Ko)
enleve les 2 .txt a la fin et remplace ce que tu a …

1 J'aime

j’ai rien bricole dans le code ca c’est sur
je te remerci et te tiens au courant

:money_mouth_face: :+1:

je n’ai toujours pas trouvé de solution pour le changement de couleur progressif

Cherche cherche … tu va trouver

peut être de l’inspiration de @Salvialf par ici :

Bonjour @snoopyfb ,

Je ne vous ai pas oublié mais je trouvais qu’une Solid gauge monochromatique perdait vraiment tout son intérêt. Et puis je me suis rendu compte un peu par hasard que mes Solid gauge de test fonctionnaient parfaitement en Alpha (4.1), pour l’explication la classe .highcharts-color-0 qui posait problème a été placé dans une sous classe, il suffit donc de supprimer la classe « mère » pour avoir de beaux gradients de couleur :
Gif
Donc elle arrive avec la 4.1, désolé de vous l’avoir vendu un peu prématurément mais d’après kiboost la 4.1 ne va plus tarder, soyez donc patient. :wink:

4 J'aimes

C’est beau le :foot: :parachute:

1 J'aime

re @olive
j’ai essaye avec ton fichier et cela ne change rien
par contre est ce que ca a voir si j’ai deplace le fichier "fonts " comme @jpty
bonne soiree

Le fichier font doit respecté sa position car le fichier html fait référence au chemin.
Dit moi si tu fait un virtuel vide sans aucunes valeurs et sans aucune options
quel est la couleur du texte 1 dans le dashboard ?

j’ai bien sur change le chemin du fichier html
depuis que j’ai fait ca plus d’erreur dans mes logs http
tiens il met la bonne couleur
Capture d’écran 2020-05-09 à 21.04.04

alors pkoi pas les autres
parametre optionnel du widjet. il n’y a rien

Et maintenant si vous mettez cette jauge sur un design, la couleur du texte essai est-elle verte ?

oui sur un design j’ai essaye et elle est bien verte
c’est a se prendre la tete je comprend pas

Le rendu est très sincèrement très sympathique
Je serais patient et merci d’avance

1 J'aime

bonjour
je vient a nouveau de ressayer si je fait un virtuel avec pas de valeur comme conseille c’ets bon tt fonctionne des que je prend un virtuel et que je met une valeur pas moyen de changer la couleur du nom du widjet
c’est dingue ca

si le virtuel apres je met une valeur dedans ca fonctionne aussi
la faut m’expliquer

bon je commence a trouver si j’e donne le nom « ville » au virtuel ca marche si je rajoute « eau » ca repasse en blanc
why ?

si je met des tiret entre les nom ca marche
pression eau ville ko
pression-eau-ville ok

vous aviez deja eu ce pb?

oui c’est pareil ici il ne faut qu’un seul mot sans césure

donc avec plusieurs il faut les tirets

Bonjour
Merci pour ce superbe widget !
Suite à la recommandation de @Salvialf
/Transparence du cadre du graphique/ .graph-widget {background-color: transparent!important;} ,
j’essaie de mettre le cadre du widget en transparent pour l’inclure dans un design mais sans succès .
Je suis en V3 avec la dernière version du GitHub

Auriez vous une solution à me recommander ?

Merci

image

fond rgba(0,0,0,0)

Merci @olive pour cette réponse rapide, mais le paramètre fond ne correspond t il pas au fond du cadran ?
image
image

Si j’essaie le paramètre back rgba(0,0,0,0) fond du widget, je n’ai pas de transparence…
image