[Optimisation] Ressources Proxmox

Tags: #<Tag:0x00007f592a3a7098>

Bonjour @ tous,

Finalisant ma migration V4 je suis reparti d’une fresh install proxmox 6.1-5.

Malgré le passage du contrôle de la réplication de la minute au mois, je trouvais la charge du nœud un peu plus importante mais surtout avec des pics par moment pas forcément justifiés à première vue.

J’en suis arrivé à désactiver l’émulation du pointeur de la souris dans les options de la VM:
Proxmox6Ressources

Grand bien m’en a pris car les consommations de la VM et du noeud ont bien baissées suite à cette manipulation. L’utilisation CPU de la VM qui était entre 5 et 6% tourne aux alentours des 1-2% et la charge à 5 minutes du noeud qui était entre 0.1 et 0.2 est maintenant à 0.03/5 :partying_face: :star_struck: :partying_face:

Bon j’ai pas de recul dessus car je l’ai fait dans l’après-midi et c’est peut-être une info connue mais je partage au cas où :smiley:

4 J'aimes

Merci pour l’astuce, je le mets en place tout de suite :blush:

Je sais pas pour toi @drs mais pour ma part on voit la différence :wink: :

NUC:

CPUNUC

VM Jeedom:

CPUVM

J’ai appliqué le changement hier aussi.
sur la moyenne par jour, sur 2 vms jeedom de test j’ai gagné 3% (6%->3%, 8%->5%), sur une 3eme avec docker aussi 13%->10%
mais sur ma vm prod jeedom, ca n’a pas bougé, je suis toujours à 10%; peut-être parce qu’elle est bien occupée et que ce setting finalement devient anecdotique?
mais du coup mon docker qui bosse un peu qd meme, lui ca a joué…
bref, je n’explique pas les résultats
du coup sur le noeud j’ai -2% en moyenne.

Bonjour,

Merci d’avoir partagé cette astuce. Je mets en place également !

Ah merci pour le retour @Mips !

Tu as modifié aussi le pve replication runner qui flood les logs toutes les minutes ? A part si tu utilises la réplication ça ne sert à rien.

Il faut éditer le fichier /lib/systemd/system/pvesr.timer avec la commande:

systemctl edit --full pvesr.timer

Changer minutely par monthly, fermer et sauvegarder.
Puis pour relancer et prendre en compte la modification :

systemctl daemon-reload

Et voilà les logs redeviennent lisibles et en terme de perf ça doit avoir son petit impact même si c’est moins flagrant que l’astuce au-dessus :wink:

1 J'aime

Salut @Salvialf

Alors voilà les images, c’est flagrant. Pour la VM Jeedom:

jeedom

Et pour mon serveur DNS, c’est encore plus flagrant:

dns

Et du coup, je viens de mettre en place ta dernière astuce :slight_smile:

Merci :slight_smile:

1 J'aime

Ah oui ! Quand même !

Proxmox 6 aussi?

Oui Proxmox 6.1.3

Idem, je viens de mettre en place l’astuce sur toutes mes VM KVM.

Exemple sur une VM :
image

Merci :wink:

1 J'aime

Bien vu. Passage de 8 à 4% pour ma part. Proxmox 6 également.

1 J'aime

Merci pour le retour :blush:

Depuis ça ronronne:
optimisationProxmox

Merci beaucoup @Salvialf mes VMs ont divisé par 2 l’utilisation du CPU sous proxmox 5.

1 J'aime

Bonjour,

Je viens de vérifier sur mon Proxmox v5.4.13.
Cette option existe.
Et l’effet est le même : réduction impressionnante du CPU pour les VM (LibreMMS, PiHole et aussi Jeedom après un petit moment).

Merci pour ce partage.

1 J'aime