Modification temps de descente sur modules ‘curtain module zigbee 3.0’

Tags: #<Tag:0x00007fa7b0e7e618>

Bonjour,
J’ai acheté des modules ´curtain module zigbee 3.0’ sur un célèbre site de vente en ligne chinois (modèle QS-Zigbee-C01).
Pas de problème pour installer physiquement ses modules.
Quelques difficultés pour les relier avec la clé conbee 2 :

  • La mise à jour du firmware n’a marché qu’après mainte tentatives sous W10, je n’ai pas réussi sur ma box jeedom sur Rasp4. De nombreuses heures sur le forum mon permis de trouver LA solution dans la multitude de posts. Dommage qu’il y ai l’option dans Jeedom mais que cela plante la clé systématiquement…
  • j’ai réussi à l’associer avec Phoscom en tant que lumière puis sur le plugin Deconz

Mon problème : Que ce soit en appuyant physiquement sur l’interrupteur (tristable) ou par jeedom, le module ne reste actif que 10 secondes puis s’arrête. Les volets mettant entre 15 et 25 secondes à s’ouvrir, ceux-ci s’arrêtent avant la fin de course.
Sur l’interrupteur, je dois donc mettre en position arrêt pour relancer et finir la course. Pas pratique du tout !!!
Sur Jeedom, j’ai réussi à faire un Virtuel relié à un scénario qui donne 2 ordres à 10s d’intervalle et ça fait le job mais c’est de la bidouille…
Comment peut on régler le timer pour que l’impulsion soit d’un timing équivalent à la durée de la course totale pour pouvoir ensuite gérer les ouvertures en % et surtout pour pouvoir ouvrir les volets en entier quand j’utilise les interrupteurs ?
J’ai cherché pas mal de temps sur ce forum et sur goo…le (francais et anglais) sans trouver de réponse. Je pensais trouver une astuce pour les flasher mais sans succès… je craque :rage::rage::rage:
Merci pour votre aide

PS : Je débute sur Jeedom mais le forum est une mine d’info. Merci aux contributeurs !!!
Ma config : Raspberry 4, Jeedom, 10 sondes Temp zigbee 3, 12 capteurs porte xiami, 12 volets roulants, 4 switch module pour piloter des équipements (notamment chauffes eau et piscine en heure creuse en lien avec linky), robot Worx, PAC Mitsubishi, capteur fumée zigbee et interrupteur wifi Tuya. Tout ne fonctionne pas encore, j’ai été ambitieux de tout lancer en même temps😄

Bonjour, je viens d’acquérir le même produit et j’ai le même problème de timeout à régler.
Est ce que vous avez une solution ?
Merci

La réponse est ici :

Il va falloir soit mettre les mains dans deCONZ GUI soit passer par le REST API de la dernière version beta 2.9.0 de deCONZ pour envoyer la commande de calibration du module volet roulant.
PUT, PATCH /api/<apikey>/lights/<id> avec les data {"calibration":true}

Et une fois la calibration finie:
PUT, PATCH /api/<apikey>/lights/<id> avec les data {"calibration":false}

avec :
: la clef API de votre Gateway Phoscon (celle qui est affichée dans la page de configuration du Plug In Deconz)
: le numéro de votre module à calibrer

Pour connaître le numéro du module il suffit de taper l’URL suivante dans votre navigateur web préféré puis de faire un peu de lecture ensuite pour repérer en toute lettre votre module et donc son numéro
http://IP_BOX_JEEDOM:8484/api//lights

Par exemple pour mon télérupteur Legrand voici le texte montrant ou trouver l’id qui est ici le numéro 9
image

Bonjour,

Je suis novice en Jeedom et de plus j’utilise la Pizigate avec le plugin Zigate.
Et je ne vois pas comment lancer ces commandes.

Merci

Ah OK. Mille excuses je croyais que tu étais sur une ConBee2.
Pour la Pizigate là je ne peux par grand chose car je n’ai pas le matériel pour tester les procédures de dépannage. Désolé.

Bonjour,

Merci pour ta réponse Yves.
J’avoue avoir cherché longtemps cette explication.

J’ai trouvé plus simple : J’ai simplement acheté une passerelle Zigbee Wifi Tuya à 12€.
Grâce à celle ci, tu appaires ton module à ton wifi et à Tuya (Smarthome pour ma part), tu configures ton module en 2 clics puis tu l’appaires à ta clé (conbee2 pour moi mais ça doit marcher avec toutes les autres).
Et voilà le module est ok. Ca impose de le faire en 2 fois quand tu installes le module mais ce n’est pas très long.
Perso, j’ai 12 modules et même en ajoutant le prix de la passerelle (gateway sur ali…pres), ça donne une solution vraiment très économique !

Je clôture ce sujet avec ces 2 solutions ?
(En fait je sais pas comment le fermer :thinking:)

Bonjour,
Oui en effet, avec la gateway Tuya, j’ai réussi à calibrer le module.
Merci pour l’info.

Bonjour,
J’ai le même problème de paramétrage …
A-t-on une autre solution que l’achat de la passerelle tuya ?
A-t-on aujourd’hui une solution incluse dans jeedom ?

Merci