Historique et Maximum Jour décalage de journée

Tags: #<Tag:0x00007fcb9c9a25a8>

Bonjour à Tous,
Nouveau sur Jeedom depuis 1mois depuis migration Domoticz (merci confinement), je constate une anomalie dans l’exploitation des consultations d’historique. J’ai épluché les sujets mais j’ai rien trouvé se rapportant à mon problème.
J’ai créé un virtuel qui me remonte une consommation sur une commande. Cette commande est configurée en lissage Aucun.
Quand je regarde la courbe d’historique j’ai ca par exemple en ce moment (03 juin)
image

J’ai donc une consommation de 15552 Wh le 03/06 à 18h58.
Si je bascule en regroupement Maximum par Jour pour ne garder que la valeur max de ma commande j’ai :
image

Je me retrouve donc à avoir ma valeur max de 15552 non plus le 03/06 mais le 02/06. Toutes les valeurs se retrouvent décalées d’un jour vers le passé.

Qu’est ce qui peut engendrer ce phénomène ?
Merci pour vos retours.

1 J'aime

Bonjour,

Je complète la remontée du bug sur le décalage de l’historique en cas de regroupement :

  • le décalage se produit également sur les fonctions min et moyenne
  • le décalage est toujours d’une unité en arrière (1 heure pour un regroupement à l’heure: 1 jour pour un regroupement par jour, …).

Jeedom V4.0.58 (VM Debian V9.11)

Bonjour, je constate le même bug (décalage d’un jour) sur la fonction « Maximum par jour » que j’utilise. Par exemple :
image

Maximum 1.35€ le 6 septembre, sauf que ce 1.35€ c’est aujourd’hui et non le 6. Et tout le reste est décalé d’un jour.

Bonjour j’ai le même problème. Mais c’est global non ?
Comment le remonter à l’équipe Jeedom ?

Bonjour,

J’ai le même soucis.
Y a-t-il du nouveau?

Cdlt,

Non pas de nouveau mais je pense avoir compris le problème :

Jeedom doit considérer que la dernière mesure est faite à minuit pile. Donc la dernière mesure du 24/11 est faite le … 25/11 matin à minuit pile. Dans ce cas le -1 fait sens et fonctionne.
Par contre si la dernière mesure est fait le 24/11 à 23h30 par exemple, ça ne fonctionne pas.

:face_with_head_bandage:

1 J'aime

Bonjour à tous

Je rencontre le même souci. Décalage de 1 (jour, heure…) sur les graphiques avec regroupement ou Max.

Quelqu’un a t-il trouvé une solution ?
Merci

Bonjour à tous,
Probleme similaire chez moi.
En detail :
Voici les calculs realises dans excel (en exportant les données depuis jeedom). Ces données et les dates sont fiables. Il y une valeur moyenne journaliere (temperature) et trois sommes journalieres (consommation)
image

Dans jeedom > Analyse > Historique : les valeurs du 30/1 dans excel apparaissent au 29/1
image

image

Dans jeedom > Accueil > Vue
La temperature du 30/1 est correcte, pas de decalage
image
Les conso du 30/1 apparaissent le 29/1

image

Dans la table de données, on comprend un peu mieux le probleme

image
Tous les chiffres encadres en rouge devraient avoir une date au 30/01
Hors 2 d’entre eux sont horodatés une seconde trop tot (23:59:59 la veille)
Et en plus le graphique ne correspond pas a la table : par exemple la valeur 0.19 apparait le 29/1 sur le graphique, et le 30/01 sur le tableau

Ce serait chouette que l’equipe jeedom se penche la dessus :wink:

@Chadweek @Kevin_Patault @sACLe

Vous savez comment alerter les devs Jeedom ? Pas sûr qu’ils lisent nos problèmes

  • 1 même problème bon après je n’ai pas encore migré sous 4.1 vous avez toujours le même soucis ?

Bonjour,
On lit bien les soucis vous inquiétez pas (on ne répond pas toujours car on préfère passer du temps a corriger les probleme plutôt qu’a répondre)

Pour le soucis ici de mémoire c’est corrigé dans les dernières version du core ou sera corrigé en 4.2

3 J'aimes

Je suis content de voir que vous avez noté ce problème. Merci pour cette confirmation.

Et je confirme que le problème existe toujours sous Jeedom 4.1.22

Exemple : consommation de ma caméra :
0,28kWh le 05/04 (donc 0kWh le 05/04 à 00h01 jusqu’à 0,28kWh relevé le 06/04 à 00h00)
0,22kWh le 06/04 à 22h (journée non terminée)

Si je fais le max par jour : j’ai 0,28kWh le 06/04, bien sûr je m’attends à 0,22kWh

Attention 00h00 appartient à la journée en cours et non à la journée précédente donc si a 00h00 tu as 0.28 c’est normal qu’il ne prenne pas 0.22 en max

Pardon, j’ai croisé les problèmes.
Ca c’est un problème de l’historique sur le plugin Energie qui crée une entrée à 00h00 pour le dernier relevé du jour précédent. Il devrait créer une entrée à 23h59 plutôt.

Je vais tester un autre cas en dehors du plugin Energie