Gros problème suite à mise à jour du Pi, plus de connexion au routeur

Tags: #<Tag:0x00007f7531f670e0>

Bonjour,

J’ai un RPI4B avec un SSD et Jeedom à jour (stable).

Tout allait bien sur mon installation depuis des mois, tous les 15 jours je fais un petit sudo apt update suivi d’un sudo apt full-upgrade et d’un reboot.

Suite au reboot de ce matin… plus rien, impossible de se connecter depuis mon navigateur, connexion ssh impossible, jeedom non connecté à mon routeur.

Vu que j’avais le temps, plutôt que de batailler je me suis dit que j’allais en profiter pour repartir d’une SD propre avec restauration de Jeedom que je clonerai ensuite sur mon SSD.

Procédure normale (celle de @Fabrice 📌 Raspberry Pi 4B : Installation de Raspberry Pi OS et Jeedom, sur un disque SSD mSata)
J’installe la dernière version 64 bits (2021-05-07-raspios-buster-arm64-lite) avec Pi Imager.
J’ajoute les petits fichiers qui vont bien (ssh et wpa_supplicant.conf).
Je met la SD dans le raspberry, ça boote, je me logue en SSH (pi / raspberry), tout fonctionne normalement.
Je fait alors sudo apt update && sudo apt full-upgrade -y et sudo reboot et là, même problème que ce matin, plus de connexion wifi, mon Pi n’est plus connecté à mon routeur.

J’ai essayé de rebooter mon routeur, pareil.

J’ai recommencé plusieurs fois, pareil.

Si je me connecte en RJ45 c’est bon mais ça ne m’arrange pas.

Quelqu’un a t’il le même problème, ou une idée ?

Merci.

Lo,

As-tu configuré ton IP en dur dans ta pi avec cette commande -> `sudo nano /etc/network/interfaces``
Depuis ce fichier tu peux configurer ton IP local pour quelle ne change pas,

The primary network interface

allow-hotplug ens18

iface ens18 inet dhcp

iface ens18 inet static
address 192.168.X.X
netmask 255.255.255.0
gateway 192.168.X.Y
dns-nameservers DNS1 DNS2

Je ne sais pas si cela reoudra ton problème, mais je sais que par défaut je configure ce fichier sur toutes nouvelles installation, que ce soit une VM ou sur une PI,

Au plaisir, bon week-end,

1 J'aime

Bonjour Toms,

Merci pour ton message.

Non, c’est ma livebox qui gère mes IP fixes mais mon RPI a bien une IP fixe, d’ailleurs lorsque je boote avec la SD avec l’OS vierge elle reconnais l’adresse MAC et affecte directement mon pi sur son IP fixe.

Là je suis connecté en éthernet et tout fonctionne normalement par contre ma box m’a affecté une nouvelle IP.

Je ne vais pas tenter ta modif aujourd’hui car je sais que la livebox est un seurveur DHCP peu performant et que même une fois supprimées, elle va garder l’IP bloquée. J’ai peur d’ajouter un conflit d’IP à mon problème de wifi.

Une question en revanche, si je fais cette modif, l’IP choisie sera valable en éthernet et en wifi ?

Lo,

Il faut savoir que la carte ethernet porte une adresse MAC différente de ta carte WIFI, par conséquent ta PI portera une adresse IP différente dans les deux cas,
C’est bien pour ça que je t’ai indiqué dans mon post cette ligne -> iface ens18 inet dhcp
Cela indique que ta connexion est en ethernet,
Si tu veux configurer en WIFI il te faut aller dans le fichier -> sudo nano /etc/wpa_supplicant/wpa_supplicant.conf et indique avec tes informations dans ces lignes que tu colleras:

country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
  ssid="NOM_RESEAU"
  scan_ssid=1
  psk="MOTDEPASSE"
  key_mgmt=WPA-PSK
}

Au plaisir, bon week-end,

1 J'aime

J’ai bien créé ce fichier et je l’ai ajouté dans la partition boot avant le premier démarrage de mon Pi avec la SD.

Il est également dans ma config actuelle (sur mon SSD) et conforme à ton modèle.

J’ai tenté la commande ifconfig mais j’ai une erreur -bash: ifconfig: command not found

En revanche avec ip address show j’obtiens pour le wifi :

3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qle                                                                                         n 1000
    link/ether dc:a6:32:a9:22:9f brd ff:ff:ff:ff:ff:ff

Tu peux me montrer ton fichier stp,

Voici celui que j’ai mis dans ma SD :

country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
  scan_ssid=1
  ssid="Livebox-XXXXXXXX"
  psk="XXXXXXXX"
  key_mgmt=WPA-PSK
}

Je ne pense pas qu’il soit en cause car ça fonctionne, mon Pi se connecte à mon wifi et je peux lancer une mise à jour en SSH. C’est la mise à jour qui fait planter mon wifi, dans le cas de mon installation standard et dans le cas de ma tentative de repartir d’une nouvelle installation.

J’ai un autre Pi avec l’OS full et MagicMirror qui tournait. Je vais tenter ce soir de faire une mise à jour pour voir si le problème est le même sur cette seconde machine.

Bonjour,

J’ai un Raspberry pi 3b+, qui est en wifi (antenne blea).
Je viens de faire la même mise à jour et je n’ai pas le problème.
Mon fichier de configuration wifi est différent.

Comme cela fonctionne en ethernet, utilisez raspi-config pour paramétrer le wifi et regardez si cela fonctionne.

Bonjour Fabrice,
Je viens de tenter même si ces infos étaient bien dans le fichier wpa_supplicant.conf.

Malheureusement ça ne change rien.

Je continue de chercher,

J’ai deux réseaux Wifi à la maison (un SSID par fréquence). Jusqu’à présent mon Pi était sur le réseau 5Ghz mais dans le doute j’ai rentré les infos pour le réseau 2.4 Ghz :

country=FR
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="XXXXXXXX"
        psk="XXXXXXX"
}

network={
        ssid="XXXXXXXXX_5GHz"
        psk="XXXXXX"
}

Ca ne fonctionne pas non plus.

Je viens d’essayer mon autre 4B avec l’OS full, pas de soucis sur celui-là. :thinking:

C’est un problème de la distribution.

https://www.raspberrypi.org/forums/viewtopic.php?t=320686

Mon réseau wifi n’est pas caché. :frowning_face:

Je vais continuer mes recherches ce soir. :mag:

Merci.

Bonjour,
ça m’intéresse ce sujet car j’ai le même problème ou presque…
Mon RPI4 a bien les 2 connexions, wifi et filaire, et il a donc 2 adresses IP. Je n’avais fixé que celle sur eth0 (filaire) considérant que c’est mieux. Et un jour sans prévenir, probablement suite à un update / upgrade d’ailleurs, l’IP a sauté, impossible de se connecter ni via HTTP ni via SSH. J’ai donc rapidement permuté sur l’autre IP et donc désormais je suis sur l’IP wifi, que j’ai fixé également via la box.

Je n’ai pas creusé plus que ça. Mais un point intéressant: la commande ifconfig me donne bien les 2 « cartes » réseau, eth0 et wlan0. Mais eth0 n’a que une IPV6 et pas d’IPV4 ! Et, en fait, ça marche, je ne savais pas mais on peut se connecter en IPv6 (en http : http://[ab:cd:ef:gh:ij:kl]) et aussi en ssh avec la même syntaxe. Je ne sais toujours pas pourquoi l’IPv4 a sauté sur eth0 - et pas sur wlan0. Ni comment le remettre…

Bonjour
Une petite idée (ca n’a peut etre rien a voir) mais j’avais lu sur d’autre forum que la commande de mise a jour full-upgrade :

Dans la plupart des autres cas, l’option dist-upgrade ou full-upgrade est à privilégier car vous obtiendrez toutes les dernières mises à jour sur votre système et du noyau. Lorsque vous souhaitez changer de version majeure de distribution (par exemple pour passer de Debian 8 à Debian 9), c’est cette commande que vous devez utiliser

Hors actuellement c’est bien Debian 11.0.0 qu’on trouve en distribution ???
N’avez vous pas MAJ en debian11… avec les problemes qui pourraient en decouler ??
C’est juste une question ???

Bonsoir.

Raspberry pi OS est encore sur Buster (Debian 10).

dist-upgrade n’est pas recommandé ici.

Bonjour, je suis bien sous Raspberry Pi OS, donc pas (encore) de Debian 11.

Aujourd’hui j’ai regardé du côté du DHCP de ma Livebox que j’ai cleané.

Je n’ai plus d’IP fixe allouée donc à priori aucun blocage possible du côté de la box.

Ce soir si j’ai le temps je vais essayer de faire la même manip sur mon second Pi (celui qui est avec l’environnement graphique de bureau) pour voir si je reproduis le même problème si j’y installe la version lite.

A+

Salut,

J’ai testé la même image sur la même SD dans mon autre Pi4B et le wifi fonctionne bien après un update/upgrade, aucun problème.

C’est donc à priori lié à mon Pi Jeedom. La seul différence visible entre les deux c’est que mon Pi Jeedom est équipé d’une carte d’extension Geekworm X825 2.5 Pouces SATA HDD/SSD avec son SSD mSATA et d’une grosse alim.

Si je n’ai pas d’autre piste j’essaierai vendredi le mettre « à poil » (sans son adaptateur SATA) avec son alim d’origine. En attendant heureusement que ça tourne en Ethernet.

Du coup je me suis remis à regarder les NUC ! :roll_eyes:

A+.

Salut,
Comme prévu je m’y suis remis aujourd’hui :

  • Arrêt du Pi, démontage total (carte geekworm X825+SSD), carte SD + alim officielle + Pi OS tout neuf --> Wifi OK
  • sudo apt update && sudo apt full-upgrade -y et sudo reboot --> CA MARCHE TOUJOURS !
  • Je remonte le Pi avec son SSD, je le démarre --> pas de Wifi
  • Connexion éthernet puis sudo apt update && sudo apt full-upgrade -y et sudo reboot --> C’est bon !

Je pense que quelque chose dans la mise à jour de la semaine dernière plantait mon wifi et que ça a été rectifié depuis.

Merci à ceux qui ont tenté de m’aider.

A+.

1 J'aime

Bonsoir,

C’est fixé depuis le 5 octobre.
C’est indiqué à la fin du lien que j’avais donné.

1 J'aime