DECONZ - Installation OK mais aucun périphérique détecté

Tags: #<Tag:0x00007fa7aaed50b8>

Merci Hugo
J’ai désinstallé le plugin Deconz mais j’ai pas trouvé quoi supprimer à la main (en ssh) pour qu’il ne garde aucune info … j’ai réinstallé … toutes les infos de ma conf ainsi que celle du phoson ont été gardée … j’ai refait l’inclusion de l’objet dans la pièce ou est le dongle conbee 2 … du coup tout marche bien … j’ai balader la sonde dans toute la maison pour voir si je captais … tout semble OK … mais tjs pas de logs … prochain point à voir les logs … :slightly_smiling_face:
Concernant les logs …
Deconz_server
DeconzServer_log
Deconz
DeconzLog
J’ai redémarrer le serveur jeedom, relancer le daemon mais rien y fait … avez vou un conseil ?
Donc en résumé pour que cela fonctionne sur un DS918+ avec Vm de 2vcpu et 1go Ram il faut :

  • Monter le périphérique usb (virtual manager) avant installation du plugin Deconz
  • modifier les droits sur le point de montage /dev/ttyACM0 (chmod 666) ==> reste a trouver le user utilisé par le plugin pour l’ajouter au groupe dialout
  • installer deconz et suivre les instructions
  • faire l’inclusion de l’objet dans la même pièce que le dongle conbee2
    Voili voilou
    Encore merci pour votre aide … et à très bientot sur le forum … sur d’autres post … :slight_smile:
    Christophe
1 J'aime

Et si tu montes le “niveau log” ? Y aurait pas plus d’infos ?
Par contre je viens d’y penser, tu n’as qu’un seul capteur pour tester ? Si oui, tu le laisses 1 journée a 1m, 1 journée a 5m, 1 journée a 8m, ect …
Je me souviens pas, tu as essayé d’éloigner la conbee de la machine avec un cordon USB ?
Et vérifie bien de temps en temps si le firmare ne passe pas en “not connected” sur phoscon/gateway.

Salut,
Moi aussi j’ai 2 deCONZ lancés, un normal, et l’autre en sudo:

beelink:~$ ps ax | grep deCONZ
 2289 ?        S      0:00 sudo deCONZ --auto-connect=1 --dbg-error=1 --http-port=8484 --ws-port=20877 --upnp=0 -platform minimal --dbg-info=1 --dbg-aps=0 --dbg-zcl=0 --dbg-zdp=0 --dbg-http=0
 2292 ?        Sl     2:24 deCONZ --auto-connect=1 --dbg-error=1 --http-port=8484 --ws-port=20877 --upnp=0 -platform minimal --dbg-info=1 --dbg-aps=0 --dbg-zcl=0 --dbg-zdp=0 --dbg-http=0
12632 pts/0    S+     0:00 grep deCONZ

Je ne sais pas si c’est normal ou pas. Et si il vaut mieux n’avoir qu’une seule instance lancée…

C’est normal. Il n y en a qu’un seul qui tourne.
le premier c’est deconz, le second c’est sudo (c’est une application aussi)

merci à toi.

Bonjour, j’ai reçu ma Conbee II aujourd’hui j’avoue que j’ai fait l’installation a l’one again… je n’ai pas trouvé de procédure claire nulle part. bref, je me suis retrouvée avec le même problème Firmware: not connected. J’avais reussi à connecter 2 capteurs (ouverture et T°) mais ils n’envoyaient pas d’état… Voici ce qui a marché pour moi:

  1. flasher la GW avec
    sudo GCFFlasher_internal -d /dev/ttyACM0 -t 60
    -f /usr/share/deCONZ/firmware/deCONZ_ConBeeII_0x26490700.bin.GCF

à noter que ça n’a pas marché du premier coup, j’ai eu plusieurs timeout, invalid CRC… faut insister! si ca marche vous aurez ça:

GCFFlasher V3_13 © dresden elektronik ingenieurtechnik gmbh
Reboot device /dev/ttyACM0 (ConBee II)
R21B18 Bootloader
Vers: 2.07
build: Jun 17 2019
flashing 158985 bytes: |==============================|
verify: .
SUCCESS
Wait 10 seconds until application starts

  1. suivre la procédure de Yves19 sauf que je suis en 264A0700 (comme ça marche je ne pense pas changer)

Petit détail intéressant: les capteurs que j’avais déjà ajoutés sont réapparus mais ne marchaient toujours pas, j’ai dû les supprimer et les rajouter

Oui c’est un soucis récurrent, ils devraient la vendre sans firmware ^^ ça serait pas pire.

Pour les capteurs Xiaomi, si la passerelle n’est plus joignable pendant trop longtemps (quelques heures) ils quittent le réseau. C’est un des gros probleme avec Xiaomi.

Le firmware 264A0700 est vraiment conseillé et résout beaucoup de problèmes de testabilité réseau ZigBee.
Note bien que chaque mise à jour firmware va imposer de régénérer la clef API sous Jeedom vers l’API deCONZ (via Phoscon). Je n’ai pas vérifié si cela changeait aussi la ref du Dongle Conbee2 .J’espère que non car autrement il faudrait … régénérer le réseau (ré inclusions et tout le toutim) autant dire la galère et sans les rames.

Bonjour,

Question peut être nuke, mais comment faites vous pour modifier les droits du point de montage?

Cordialement

sudo chmod 666 /dev/ttyACM0 si tu veux que tout le monde puisse lire et écrire sur le point cité dans la commande

pour ta gouverne voici la référence UNIX que tu peux trouver très facilement sur Internet

chmod 666 file/folder means that all users can read and write but cannot execute the file/folder;
chmod 777 file/folder allows all actions for all users;
chmod 744 file/folder allows only user (owner) to do all actions; group and other users are allowed only to read.

permission to:  user(u)   group(g)   other(o)     
                /¯¯¯\      /¯¯¯\      /¯¯¯\
octal:            6          6          6
binary:         1 1 0      1 1 0      1 1 0
what to permit: r w x      r w x      r w x

binary         - 1: enabled, 0: disabled

what to permit - r: read, w: write, x: execute

permission to  - user: the owner that create the file/folder
                 group: the users from group that owner is member
                 other: all other users
1 J'aime

Merci beaucoup.

Je vais faire ça ce soir.

Cordialement

Bonjour,
Je suis sous Docker en Bridge sur un DS218+ (merci @Didier3L)
J’ai un cas aussi proche : ma clé à l’air détectée mais impossible de lancer Phoscom… lorsque je clique sur le lien il m’envoie vers http://172.17.0.2:8484/
Mais la page ne se charge pas : normal c’est une page interne
Voici ma config réseau :
Capture2
Le Demon fonctionne bien. Et j’ai récupéré la clé API en cliquant sur récupérer la clé API :
Capture1
Mon réseau Deconz est un peu byzarre sur la version du firmware…
Capture3
Bref je suis un peu perdu…

comment savoir si ma clé conbee 2 est bien connectée au NAS ?

merci à vous
Lemars

Bonsoir essaye l’adresse ip ton nas:8484 directement dans le navigateur

Bonsoir,
Ne fonctionne pas…
Erreur de chargement.
voici mes ports USB sur le NAS :

root@DS_LS:~# dmesg |grep tty
[    0.000000] Command line: root=/dev/md0 earlyprintk=apl console=ttyS2,115200n8 ihd_num=2 netif_num=1 HddHotplug=1 SataPortMap=21 syno_hw_version=DS218+ vender_format_version=2 syno_hdd_detect=18,179,176,175 syno_hdd_enable=21,20,19,9 syno_usb_vbus_gpio=11@0000:00:15.0@1,10@0000:00:15.0@2,13@0000:00:15.0@3 sn=1880PCN917719 macs=00113299ce4f
[    0.000000] Kernel command line: root=/dev/md0 earlyprintk=apl console=ttyS2,115200n8 ihd_num=2 netif_num=1 HddHotplug=1 SataPortMap=21 syno_hw_version=DS218+ vender_format_version=2 syno_hdd_detect=18,179,176,175 syno_hdd_enable=21,20,19,9 syno_usb_vbus_gpio=11@0000:00:15.0@1,10@0000:00:15.0@2,13@0000:00:15.0@3 sn=1880PCN917719 macs=00113299ce4f
[    5.119020] dw-apb-uart.1: ttyS0 at MMIO 0x9131c000 (irq = 44, base_baud = 115200) is a 16550A
[    5.158808] console [ttyS2] enabled
[    5.178991] dw-apb-uart.2: ttyS1 at MMIO 0x9131e000 (irq = 45, base_baud = 115200) is a 16550A
[    5.180114] console [ttyS2] disabled
[    5.180326] dw-apb-uart.3: ttyS2 at MMIO 0x91320000 (irq = 6, base_baud = 115200) is a 16550A
[    5.180342] console [ttyS2] enabled
[    5.186100] dw-apb-uart.4: ttyS3 at MMIO 0x91322000 (irq = 47, base_baud = 115200) is a 16550A
[   32.402976] synobios open /dev/ttyS1 success
[   51.373092] synobios open /dev/ttyS1 success
[   52.620576] cdc_acm 1-1:1.0: ttyACM0: USB ACM device
[   52.814767] usb 1-2.1: GSM modem (1-port) converter now attached to ttyUSB0
[   52.844957] usb 1-2.1: GSM modem (1-port) converter now attached to ttyUSB1
[   86.276420] usb 1-2.4.3: FTDI USB Serial Device converter now attached to ttyUSB2
[   86.612471] usb 1-2.4.4: FTDI USB Serial Device converter now attached to ttyUSB3
[18130.936675] cdc_acm 1-3:1.0: ttyACM1: USB ACM device
[18134.859065] cdc_acm 1-3:1.0: ttyACM1: USB ACM device

A priori ma clé est sur ACM1

et les log du deconzserveur

19:57:23:570 failed to reconnect to network try=8
19:57:23:570 enqueue event config/localtime for /config/
19:57:23:726 COM: /dev/ttyACM0 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyUSB0 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyUSB1 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyACM1 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyUSB2 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyUSB3 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyS0 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyS1 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyS2 :  (0x0000/0x0000)
19:57:23:726 COM: /dev/ttyS3 :  (0x0000/0x0000)
19:57:24:569 enqueue event config/localtime for /config/
19:57:24:718 COM: /dev/ttyACM0 :  (0x0000/0x0000)
19:57:24:718 COM: /dev/ttyUSB0 :  (0x0000/0x0000)
19:57:24:718 COM: /dev/ttyUSB1 :  (0x0000/0x0000)
19:57:24:718 COM: /dev/ttyACM1 :  (0x0000/0x0000)
19:57:24:718 COM: /dev/ttyUSB2 :  (0x0000/0x0000)
19:57:24:718 COM: /dev/ttyUSB3 :  (0x0000/0x0000)
19:57:24:719 COM: /dev/ttyS0 :  (0x0000/0x0000)
19:57:24:719 COM: /dev/ttyS1 :  (0x0000/0x0000)
19:57:24:719 COM: /dev/ttyS2 :  (0x0000/0x0000)
19:57:24:719 COM: /dev/ttyS3 :  (0x0000/0x0000)

Peut être que @GBT peut m’aider ?
Car son sujet a été fermé mais je ne connais sais pas la solution exacte au probleme qui a l’air proche du mien ?

Pour ma part j’ai mis dans la config réseau l’adresse de mon ethO mais sans port
et cela permet au plugin rfxcom de fonctionner parfaitement sur mon docker en bridge
Capture1

Pas moyen de joindre Phoscom sur l’adresse de mon NASinterne:8484

Et le lien Phoscom tente de joindre cette adresse mais sans success…
172.17.0.2:8484

Je ne sais pas comment faire…

Voici les log du lancement du Demon :

[2021-01-22 17:56:16.324][INFO] : Opt deconz deamon ['sudo', 'deCONZ', '--auto-connect=1', '--dbg-error=1', '--http-port=8484', '--ws-port=20877', '--upnp=0', '-platform', 'minimal', '--dbg-aps=2', '--dbg-info=2', '--dbg-zcl=2', '--dbg-zdp=2', '--dbg-http=2']
[2021-01-22 17:56:16.327][INFO] : Launched DeconZ with pid 4006
[2021-01-22 17:56:16.328][DEBUG] : Start socket thread
[2021-01-22 17:56:21.488][DEBUG] : Client connected to [127.0.0.1:33806]
[2021-01-22 17:56:21.489][DEBUG] : Message read from socket: b'{"apikey":"4l2hKrWVspmGDJW1lvACurnvr1lI1HIU","cmd":"addgateway","gateways":[{"id":"0000000000000000","name":"ma_cl\u00e9","internalipaddress":"172.17.0.2","internalport":"8484","websocketport":"20877","apikey":"8FE2467DF1","manageTimeZone":"0"}]}'
[2021-01-22 17:56:21.489][DEBUG] : Client disconnected from [127.0.0.1:33806]
[2021-01-22 17:56:21.495][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2021-01-22 17:56:21.495][DEBUG] : Closing All Websockets
[2021-01-22 17:56:22.496][DEBUG] : Add gateway : ma_clé
[2021-01-22 17:56:22.497][DEBUG] : Starting WebSocket for ma_clé on ip 172.17.0.2 and port 20877
[2021-01-22 18:56:31][DEBUG] : 172.17.0.2:8484/api/8FE2467DF1/sensors type : POST
[2021-01-22 18:56:31][DEBUG] : {"1":{"config":{"configured":true,"on":true,"sunriseoffset":30,"sunsetoffset":-30},"etag":"b820642761c738ea13d0639826c3d39f","manufacturername":"Philips","modelid":"PHDL00","name":"Daylight","state":{"dark":true,"daylight":false,"lastupdated":"2021-01-22T17:56:16.769","status":220,"sunrise":"2021-01-22T07:02:06","sunset":"2021-01-22T16:36:15"},"swversion":"1.0","type":"Daylight","uniqueid":"00:00:00:00:00:00:00:00-01"}}
[2021-01-22 18:56:31][DEBUG] : 172.17.0.2:8484/api/8FE2467DF1/lights type : POST
[2021-01-22 18:56:31][DEBUG] : []

Personne pour m’aider … :pensive:
Lemars

Dans la configuration réseau Jeedom du n’as pas mis le port 80
J’ai arrêté mes essais car mon Jeedom tourne pour le chauffage de la maison

Ce lien peut te donner ta configuration réseau pour deconz https://phoscon.de/discover
Par contre sur un NAS, c’est a tester …

Voici ma conf qui fonctionne :

  • Dans Jeedom-Configuration-Reseaux-Acces Interne : j’ai 127.0.0.1 port 80. Cette valeur est utilisée par le démon Deconz.
  • Dans Jeedom-Plugin Deconz : j’ai l’IP et le port web + websocket de mon instance Phoscon. Dans mon cas j’utilise une instance docker séparée de Jeedom. Ce port est utilisé par le plugin deconz pour parler à phoscon.

Si tu as une instance Phoscon en local, il faut que tu NAT le port Phoscon sur un port de ton host pour que tu puisses y avoir accès depuis ton navigateur.

Merci pour vos réponses

Je viens de vérifier en branchant la clé conbee sur mon pc j’arrive a commander une mapoule : ma clé est ok

J’ai un DS218+ et un Docker en mode Bridge (clé zwave / enocean / rfxcom) avec la config réseau jeedom modifiée pour etre en 127.0.0.1 port 80 comme toi @GBT . Tout fonctionne sauf une alerte dans santé sur la config réseau interne :
Capture1
Si je mets 172.17.0.2 cela devient ok dans analyse santé
Capture2

J’ai essayé et ce n’est pas mieux : pas possible de joindre Phoscom par le lien proposé par Deconz…

Si j’ai bien compris : Phoscom est comme le systeme qui va gérer les ampoules et autres en zigbee.
Et Deconz est le plugin permettant de passer les commandes a Phoscom pour allumer les ampoules par ex ?

Dans le réseau Deconz je trouve dans résumé une clé qui n’est pas ma clé conbee mais mon NAS…
Capture3
en effet le MAC indiqué correspond a eth0 de la config réseau : en 172.17.0.2 (voir 1ère copie écran)

Ce qui me fait raler est que la clé conbee branchée sur le NAS est bien reconnue par la NAS car dans la fenetre terminal de mon Docker Jeedom je la vois : Dresden Elektronic…
Capture4

Donc pour que cela fonctionne il faut que je garde mon jeedom sur le docker actuel en Bridge
et que je crée un autre Docker en host pour phoscom ? Qu’appelles tu une instance Phoscom ?
Je ne sais pas comment joindre Phoscom dans mon navigateur quand la clé est sur le NAS…

Merci encore à tous

Lemars

J’ai la meme alerte que toi dans la Santé, donc cest OK pour moi.
Il te manque juste la declaration d’un port NAT dans ton container Docker pour acceder a ton phoscon installé en local depuis ton navigateur.
Ton déconz utilise le port 8484 à l’interieur du conteneur Jeedom.
Dans la definition de ton container, il faut associer le port 8484 (interne) à un port externe (à definir, tu peux choisir 8484 ou un autre) que tu pourras utiliser depuis ton navigateur.
Aujourdhui, tu as deja le port Jeedom (80) qui est NATté vers le port ??? de ton NAS.

Peux tu me montrer la config reseau de ton conteneur Jeedom ?