BlueSwim : problème d'authentification

Tags: #<Tag:0x00007f752379dd40>

Bonjour, à la demande de @Mips, j’ouvre un sujet spécifique sur mon problème.

Possesseur d’une sonde BlueConnect, j’avais installé le plugin BlueSwim dès sa sortie en version béta et cela fonctionnait sa problème.
Depuis le 29 juillet, le plugin semble ne plus pouvoir s’authentifier auprès du serveur BlueConnect.
J’ai désinstallé le plugin pour le passer en version stable mais rien n’y fait :
dès l’appui du bouton « activer » (même sans avoir notifié mon mail et MdP d’authentification), j’ai l’erreur suivante dans le log :

[2021-08-07 17:21:39][INFO] : Début d'activation du plugin
[2021-08-07 17:21:40][INFO] : Info sur le démon : {"launchable_message":"","launchable":"nok","state":"nok","log":"nok","auto":0}

J’entre mon mail et MdP, je clique sur « synchroniser », aucun équipement n’apparait et une ligne supplémentaire apparait dans le log :

[2021-08-07 17:24:11][ERROR] : Impossible de s'identifierEchec de la requête HTTP : https://api.riiotlabs.com/prod/user/login cURL error : Resolving timed out after 2000 milliseconds

@Kitof : tu m’as répondu, avant que post soit clôturé, que

Peux tu m’éclairer un peu plus sur cela?
Je rappelle quand même que le plugin a fonctionné sans problème jusqu’au 29 juillet (je ne me souviens plus qu’and est-ce que j’ai fait le mise à jour de la dernière version du plugin).
Merci
Stéphane

Bonjour,

N’oubliez pas de mettre le tag du plug-in sur le sujet pour qu’il ait une meilleure visibilité; je l’ai fait pour vous.

Sinon je confirme que cette erreur est un problème de résolution du serveur.
Testez cette URL dans votre navigateur sur votre ordi pour voir, cela va retourner une erreur de token mais au moins on saura si le serveur est trouvé.

Si c’est le cas, montrez la page santé jeedom et la page de config réseau.

Merci @Mips pour ton aide.
J’ai en effet un soucis de configuration réseau. Je suis surpris car ca fait longtemps que je n’y ai pas touché et tout était OK auparavant, et le problème n’est survenu que le 29 juillet
Ci-dessous les captures d’écran demandées :
Capture
Capture1

J’ai tenté de redémarrer le DNS Jeedom, mais après de longues minutes d’attente, j’obtiens une erreur 502 Bad Gateway - Openresty.
Stéphane

Je viens de tester la désactivation de la gestion du réseau par Jeedom, dans la page santé, la configuration du réseau externe passe en OK !
Mais par contre, toujours la même erreur au niveau du plugin. :frowning:

Il ne faut pas faire cela sauf si on sait ce que l’on fait, la case n’est pas en rouge pour rien :wink:

Cocher cette case veut dire que jeedom va considérer que la config est bonne car l’utilisateur sait ce qu’il fait et donc il indique ok
mais dans votre cas votre config ne fonctionne pas
en d’autres termes cela masque juste le problème, c’est comme mettre la poussière sous le tapis.
Donc décochez la case.

Par contre là je ne vois pas ce qui cause le problème, il faudrait plus de logs, le log « openvpn_DNS_Jeedom » pour commencer.
Si on ne voit rien, vous pouvez aussi tester de redémarrer jeedom si pas encore fait.

En me basant sur votre profile, ce qu’on voit là c’est la smart ou celui sous proxmox? si proxmox, êtes-vous sur de votre config réseau sous proxmox et sous linux?

Bon, la connerie est faite !!
C’est le système sous proxmox qui est présenté, mais je rencontre la même chose avec la smart.
Un redémarrage n’a rien changé.
Voici les log de « openvpn_DNS_Jeedom » :

[2021-08-10 12:00:47][INFO] : Lancement openvpn : sudo openvpn --config /tmp/jeedom/openvpn/openvpn_115.ovpn >> /var/www/html/core/class/../../log/openvpn_DNS_Jeedom  2>&1 &
Tue Aug 10 12:00:47 2021 WARNING: file '/tmp/jeedom/openvpn/openvpn_auth_2QbmK5ahesJbVQd8YyEysLA0npjHeq.conf' is group or others accessible
Tue Aug 10 12:00:47 2021 OpenVPN 2.4.7 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
Tue Aug 10 12:00:47 2021 library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Tue Aug 10 12:00:47 2021 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Tue Aug 10 12:00:52 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]135.125.10.213:1200
Tue Aug 10 12:00:52 2021 UDP link local: (not bound)
Tue Aug 10 12:00:52 2021 UDP link remote: [AF_INET]135.125.10.213:1200
Tue Aug 10 12:00:52 2021 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Tue Aug 10 12:00:52 2021 VERIFY OK: depth=1, C=FR, ST=IDF, L=Paris, O=jeedom.com, OU=jeedom.com, CN=jeedom.com CA, name=jeedom, emailAddress=postmaster@jeedom.com
Tue Aug 10 12:00:52 2021 VERIFY OK: depth=0, C=FR, ST=IDF, L=Paris, O=jeedom.com, OU=jeedom.com, CN=server, name=jeedom, emailAddress=postmaster@jeedom.com
Tue Aug 10 12:00:52 2021 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1542', remote='link-mtu 1342'
Tue Aug 10 12:00:52 2021 WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1300'
Tue Aug 10 12:00:52 2021 Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, 1024 bit RSA
Tue Aug 10 12:00:52 2021 [server] Peer Connection Initiated with [AF_INET]135.125.10.213:1200
Tue Aug 10 12:00:53 2021 Data Channel: using negotiated cipher 'AES-256-GCM'
Tue Aug 10 12:00:53 2021 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Tue Aug 10 12:00:53 2021 Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Tue Aug 10 12:00:53 2021 TUN/TAP device tun0 opened
Tue Aug 10 12:00:53 2021 /sbin/ip link set dev tun0 up mtu 1500
Tue Aug 10 12:00:53 2021 /sbin/ip addr add dev tun0 local 10.15.4.62 peer 10.15.4.61
Tue Aug 10 12:00:53 2021 Initialization Sequence Completed

@Mips : dans ton post précédent, tu me demandes si les configurations réseau de PROXMOX ou de LINUX est correcte : cela dépasse mes compétences, mais j’ai regardé la page santé de la box SMART, et j’ai aussi un problème de NOK sur la configuration d’accès Externe à Jeedom et j’ai donc aussi la même erreur d’authentification sur le serveur de BlueConnect

Est-ce que la box est accessible via votre url dns.jeedom.link ?
Il faudrait régler le problème réseau mais là avec les infos je ne vois pas le soucis.

Merci @Mips de ton aide
Oui, les 2 box sont accessibles sans problème depuis l’extérieur avec les dns jeedom.
Stéphane

Bonjour
Le relance mon post avec quelques précisions concernant la configuration physique du réseau de ma maison.
1- Freebox Delta Fibre comme modem/routeur avec 4 règles de redirection de port : 80 et 443 vers un serveur APACHE - 9001 vers un serveur MQTT et 9500 vers un serveur VPN sur NAS Synology
2- Serveur APACHE puis redirige les connexions extérieurs avec mon nom de domaine vers le matériel souhaité (Freebox, Switch, serveur Internet qui héberge mon site de météo, NAS…)
3- 1 Jeedom sur VM Proxmox
3- 1 Jeedom sur box smart.

Les 2 Jeedom sont accessibles depuis l’extérieur par 2 DNS Jeedom

Peut-être que ces précisions vont éclairer vos lanternes :wink:
Stéphane

Et il n’y a qu’un seul suis réseau ?
Donc tout le monde a la même plage ip sur le 192.168.1.x?

Bonjour @Mips
Oui, je suis sur un seul sous-réseau. et donc une seule plage d’adresse en 192.168.1.x
Stéphane

Bonjour, je rencontre exactement le même problème. Suite à l’installation de la stable sur la beta et en parallele le changement de ma sonde (j’ai supprimé l’ancienne HS avant de vouloir synchroniser la nouvelle). Mais rien n’y fait, la sonde ne veut pas apparaitre…

Regarde la santé de ton Jeedom pour voir si l’accès externe est NOK !

Tout est ok, vert … Toujours pas de synchro ce matin :pensive:

@Kitof une idée ?

Bonjour,

  1. Vous êtes hors sujet (ou vous vous exprimez mal): le sujet parle d’un problème d’authentification et vous avez un problème de synchro, je n’appelle pas cela « le même problème ».
  2. Vous ne fournissez aucun log ni aucun détail sur votre installation.

Consultez ce lien et créez une nouvelle demande si besoin: Comment nous aider à vous aider - ou Comment poser une bonne question?

1 J'aime

Probablement que je m’exprime mal… comme beaucoup de néophyte ! Peu-être un peu d’indulgence et de diplomatie, en par exemple demandant un complément d’information.
D’autre par, je confirme que je ne suis pas hors sujet, le point initial du problème est bien le même que celui de @Stephane_Bec avec le même problème in fine. Peut être inutile d’ouvrir un autre sujet ??
Le manque de synchro semble lié à un problème d’identification et/ou de communication avec les serveurs chez blueriott.

Merci pour l’aide qui nous sera apporté sur ce sujet.

Jeedom 4.2.2 sur RPI 3 B SSD avec abo smart et dns en jeedom.link

Si vous le dites…

@Chichi, lors de ton premier post, on pouvait croire que nos problèmes étaient similaire, or, tu dis ne pas avoir de NOK dans la santé de Jeedom (ATTENTION : vérifie que tu n’as pas coché la désactivation de la gestion du réseau par Jeedom car cela inhibe la vérification : j’ai fait la connerie au début du post)
Si tout est ok pour toi, il te faudra ouvrir un nouveau post avec tes logs.
Stéphane