Tutoriel ZIGBEE2MQTT sur DELTA

Bonjour,

J’ai reçu tous les équipements pour créer mon sniffer Zigbee et j’ai réussi à flasher le bon fichier.

J’ai installer une seconde vm debian 10 (la première étant Jeedom) et les 2 marches en même temps.

Mais après je sèche. Je n’arrive pas à suivre le tuto du ghithub, quelqu’un a un tutoriel avec ce que je dois mettre dès que je suis loggé.

Après la partie JMQTT est prête.

Merci pour votre aide.

Bonjour
voici un lien pas mal c’est un de ceux que j’ai utilisé pour l’installation :
https://www.zigbee2mqtt.io/
autrement :
https://projetsdiy.fr/test-du-pont-zigbee2mqtt-hack-gateway-xiaomi-smart-home-aqara-partie-1-assemblage-systeme-dalarme-en-5-avec-node-red/

ou

https://projetsdiy.fr/zigbee2mqtt-projet-de-pont-domotique-zigbee-vers-mqtt-compatible-xiaomi-aqara/

hésitez pas …

Merci pour la réponse. Je me sers justement des 2 tutos pour essayer de l’installer. Mais je suis nul dans ce domaine.

En l’occurrence quand je cherche le port utilisé ça fonctionne. Mais après :thinking:… je n’arrive à rien.

Recherche de node et npm ne fonctionne pas, j’ai un message : « command not found ». En gros toutes mes requêtes donnent ça.

Bonjour,

voici le lien que j’ai utilisé pour nodered https://projetsdiy.fr/installer-node-red-raspbian-jessie-lite-raspberry-pi-zero-w/

il me semble qu’au lancement du script il prévient qu’il n’est pas à jour, et en donne un autre. A vérifier lors du déroulement de celui ci …

Après
image

Merci. Effectivement je suis sur les mêmes tutos.

Malheureusement sur la ligne :

bash <(curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered)

j’ai un message :

-bash: curl: command not found

Je suis désolé je débute vraiment en DEBIAN, j’avais installé JEEDOM sur DELTA sans soucis car le tuto était vraiment un pas à pas et la je pense qu’il me manque une étape…

Rassurez vous moi aussi
tentez : curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered
Suivant votre niveau de login tentez avec sudo devant.
nb : penses bien a regarder les messages il risque de vous proposer un autre lien…c’est tout de mémoire :thinking:

même message d’erreur.

-bash: curl: command not found

et en sudo :

sudo: curl: command not found

Bon je vais relancer l’installation.

(encore merci pour l’aide…)

edit : j’ai tout réinstaller. Idem, quoi que je face je n’ai pas la commande curl:
Je reprécise à toutes fins utiles je suis sur une DELTA en DEBIAN 10.

Bonsoir j’avais bien lu ça.
Je regarde demain si je trouve quelque chose de spécifique pour debian 10.
Je ne vois pas trop pourquoi ça ne fonctionne pas, mais je suis pas spécialiste :roll_eyes:

J’avance dans mon micmac.

Je ne comprends pas pourquoi, mais je n’ai pas curl et si je veux l’installer avec la requête : apt-get install curl, ça me dit que je n’ai pas les droits root.
Donc j’essaye de passer root en tapant SU mais ça me dit : authentification failure…

alors une chose que je sais c’est pas ‹ su › mais ‹ sudo su › après le prompte finit avec un # pour revenir en utilisateur normal c’est ‹ exit ›.
sur ce lien il explique comment installer sur un Environnement virtuel https://www.zigbee2mqtt.io/information/virtual_environment.html
pour info je suis rpi3 buster

Bon j’ai beaucoup avancé !

En fait je n’avais pas curl et quand je voulais lancer l’installation bêtement je voulais le faire en SU alors qu’en SUDO ça a fonctionné et du coup le reste aussi.

Mais tout n’est pas rose.

Je bloque sur : sudo chown -R pi:pi /opt/zigbee2mqtt
Et j’ai comme réponse : chown: invalid user: ???pi:pi’

Je touche au but !

Oui c’est pour donner les droits de lecture à l’utilisateur pi. Avec votre vm je ne pense pas que vous soyez utilisateur pi, vous devez porter un autre nom.
Voici un lien
https://www.framboise314.fr/les-droits-linux-sur-le-raspberry-pi/
Mais au moins si vous en etes la c’est que node et npm sont en place ! courage

Bonjour,

J’ai réussi à aller au bout du tutoriel. J’ai une erreur à la toute fin donc je recommence au propre.

Une question. En l’occurrence « pi:pi » c’est l’user ou l’user c’est « pi ».

Merci.

Ca fonctionne je vais publier la démarche que j’ai fait tout à l’heure ou demain soir car pour DELTA il y a des subtilité, ça peut aider d’autres…

1 J'aime

pi:pi utilisateur(user) est pi : groupe (groupe) est pi
la commande:
sudo chown -R pi:pi /opt/zigbee2mqtt
est là pour donner les droits en lecture à l’utilisateur pi et au groupe pi sur le dossier /opt/zigbee2mqtt et ses sous dossier.
un exemple :
vous voulez changer le propriétaire(paul) et le groupe propriétaire (amis) du dossier de /photo/ph/2019/07 vous utilisez sudo chown -R paul:amis /photo/ph/2019/07. Si vous êtes le propriétaire de ce dossier, pas besoin de sudo devant l’instruction.
ais je répondu à la question ?

C’est super et c’est une très bonne idée ça devrais aider pas mal de monde.
Merci par avance pour le partage

En tout cas merci pour votre aide;

Bon avant de poster les étapes pour la DELTA j’ai un bug ! Quand je veux faire le process pour le démarrage automatique.

Tout se passe bien, j’arrive à l’étape finale je vois le status qui est bon donc je fais la requête

sudo systemctl enable zigbee2mqtt.service

Et ensuite si je relance

npm start

La j’ai des erreurs partout… est-ce car je n’ai pas besoin de le lancer il se lance automatiquement ? est-ce car j’ai fait la requête de démarrage automatique dans le dossier ```
/opt/zigbee2mqtt

Merci.

en effet j’ai eu ça je regarde

Que donne sudo systemctl status zigbee2mqtt ?
Si il répond ça doit être bon

image

Ca sera plus simple…