Sonoff mini DIY - erreur time-out / remontée info WIFI SSID

Tags: #<Tag:0x00007fa79f7ba540>

Bonjour

j’ai installé un sonoff mini DIY pour le fil pilote d’un radiateur électrique, en version firmware 3.6.0. c’est un nouveau modèle où le passage en DIY se fait logiciellement.

Le fonctionnement manuel du switch est correct : le bouton on/off actionne bien le fil pilote, en utilisant les commandes natives du plugin sonoff-diy.

Mais de temps en temps, j’ai un message time-out qui s’affiche : Capture1

Pourtant, la connectivité du switch est correcte, jeedom est branché en giga derrière la box internet et le sonoff est branché directement sur le wifi de la box internet. je fais des ping toutes les 5 min avec le plug-in network et j’ai une latence moyenne de 3 ms.

peut-on régler ce time-out ?

Pas d’événement particulier dans les log debug :

[2020-11-11 12:50:37][INFO] :  ╔══════════════════════[Envoi sur Sonoff Mini Parents]═════════════════════════════════════════════════════════
[2020-11-11 12:50:37][INFO] :  ║ ════envoi══> http://XXX:8081/zeroconf/switch {"deviceid":"XXX","data":{"switch":"on"}}
[2020-11-11 12:50:37][INFO] :  ║ <══réponse═  {"seq":12,"error":0}
[2020-11-11 12:50:37][DEBUG] : ╠═ Enregistrement de switch dans Sonoff Mini Parents : on
[2020-11-11 12:50:37][DEBUG] : ╠═ Enregistrement de startup dans Sonoff Mini Parents : stay
[2020-11-11 12:50:37][DEBUG] : ╠═ Enregistrement de pulse dans Sonoff Mini Parents : off
[2020-11-11 12:50:37][DEBUG] : ╠═ Enregistrement de pulseWidth dans Sonoff Mini Parents : 500
[2020-11-11 12:50:37][DEBUG] : ╠═ Enregistrement de rssi dans Sonoff Mini Parents : -67
[2020-11-11 12:50:37][DEBUG] : ╠═ Enregistrement de IDdetectee dans Sonoff Mini Parents : xxx
[2020-11-11 12:50:37][DEBUG] : ╚═══════════════════════Sauvegarde Sonoff Mini Parents══════════════════════════════════════════════════════════════════════════════════════

l’ID est bien configuré.

Par ailleurs, l’info du réseau WIFI utilisé ne remonte pas correctement au niveau du plug-in (champ vide). y a-t-il possibilité de l’afficher s’il vous plait ?

merci pour votre aide

Sylvain

Sly78N j’ai exactement le même soucis mais c’est très rare, genre une fois par semaine.

@Sly78N alut Sylvain,

Tu le vois où le souci TimeOut ? L’ordre s’exécute ?
Je n’arrive pas à reproduire ton souci.

C’est une Sonoff Mini R2 que tu as (avec les 2 borniers gris et plus d’antenne) ?

Merci Sigalou pour ta réponse,

le time-out s’affiche lorsque je mets le plug-in visible, il y a un petit signe d’horloge dans le titre du plug-in sur le dashboard de l’objet parent. Apparemment la commande s’execute lorsqu’elle est declenchée par le scenario, mais je n’ai pas pu tester de façon répétitive pendant la nuit.

il n’y a rien de special dans les logs. C’est un Mini de 1ere génération mais sans le jumper qui le met en mode DIY (configuration logicielle).

j’ai mis un test network en http et je n’ai pas de latence particulièrement élevée.

merci encore

Le sujet est clos ?

Bonjour, oui , je pense au final que le probleme de time-out n’en est pas vraiment un.

concernant l’affichage du SSID , y a -t-il quelque chose à faire pour le faire s’afficher ? Quand on interroge le device, il s’affiche bien dans les logs, mais pas dans la page jeedom du résumé du sonoff.

Salut, je ne comprends pas de quelle page tu parles.
Le SSID est récupéré ou pas ?
Quand tu vas dans Commandes du Device, tu as l’info ?

Essaies de reformuler stp
a+

Bonsoir
sur l’ecran ci-dessous, l’info en face de SSID est vide:

Capture2

cela n’apparait pas non plus dans les infos de commande :Capture4

mais elle est bien présente quand on interroge l’équipement manuellement :

Capture3

Bonjour,

Je viens d’installer le plugin sur ma nouvelle installation sur un raspberry. Il fonctionne très bien.

Par contre j’ai aussi le soucis de SSID qui ne s’affiche pas. Il est pourtant bien présent au niveau du retour dans les logs. Est ce qu’il y a eu une solution sur le sujet ?

J’avais oublié cette question.
A quoi vous sert cette information ?

@chandler45 pas de nouvelle sur ma question, je me suis tout de même posé la question de cette remontée qui ne se fait pas et profité pour reprendre toute la gestion des remontées.
Grosse mise à jour postée

N’hésitez pas pour vos retours et SVP, cochez résolu aux sujets clos.

Bonjour

sur mon installation, en derniere version du plug-in Sonoff (et de jeedom et du reste), le SSID ne remonte toujours pas sur la page de plug-in des equipements DIY.
cordialement

@Sly78N bonjour, quand tu dis dernière version, c’est bien la beta ?
Tu peux me faire une copie d’ecran de tes commandes et le l’endroit ou cela ne remonte pas.
J’avoue ne pas avoir compris à quoi servait cette remontée mais si vous êtes plusieurs à le demander c’ets qu’il doit bien y avoir une raison.