Sonde de température Xiaomi Mijia LYWSD03MMC _ Suite

Tags: #<Tag:0x00007f384e96e230>

Bonjour à tous,
Salut @HoM3r17 @Remyg83 @Darkeyes @timcrouzet en particulier qui ont bien contribués au fil précédent
Je fais suite à ce fil qui a été fermé le 09/09 : Sonde de température Xiaomi Mijia LYWSD03MMC

J’ai tenté de mettre en place la procédure mais je bloque dès la récupération du fichier pairing.txt car il n’existe pas sous mon répertoire /vevs/logs :frowning:
Pourtant j’ai supprimé mes capteurs de l’application Mihome officielle, puis désinstaller celle-ci puis installer la version moddée trouvée sur le site www.kapibara.ru par contre c’est la version 5.8.22 alors que vous utilisiez une version précédente 5.8.16
J’ai associé deux capteurs sur l’appli MiHomeMoodée, mais aucun fichier pairing n’apparait dans mon répertoire logs que j’ai créé avec l’application Solid Explorer. J’ai cette arborescence sous /Memoire de stockageinterne
arbo
Et aucun fichier pairing dans les autres sous répertoires bien sur.

J’ai essayé sur deux téléphones distincts et j’ai le même résultat.

Avez vous une idée?
Quelqu’un pourrais me pousser le fichier .apk de la version 5.8.16?

Merci d’avance

Après déconnexion de l’application MiHomeMoodé, le fichier pairing.txt apparait :slight_smile: il se trouve dorénavant sous /vevs/logs/misc
J’ai supprimé le fichier lywsd03.py et je l’ai remplacé par celui fait par Tim
J’ai bien mise à jour le début de ce m^me fichier avec les deux mac et les deux bindkey associées :

J’ai fait l’installation de la dépendance qui semble s’être bien passée, hormis le pip version qui n’est pas bon mais ça ne devrait pas poser problème non?

user@PI-balloneauchaude:~$ sudo pip3 install pycryptodomex
[sudo] Mot de passe de user : 
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting pycryptodomex
  Downloading https://www.piwheels.org/simple/pycryptodomex/pycryptodomex-3.9.8-cp37-cp37m-linux_armv7l.whl (13.7MB)
     |████████████████████████████████| 13.7MB 35kB/s
Installing collected packages: pycryptodomex
Successfully installed pycryptodomex-3.9.8
WARNING: You are using pip version 19.3.1; however, version 20.2.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

J’ai bien décoché le refresh forcé dans chacun des deux équipements que j’avais intégré à jeedom il y a 2 jours.

J’ai fait un stop-start sur le démon de ma seule antenne BLEA qui n’est pas sur mon jeedom smart mais elle est sur un PI3b+ qui me sert à autre chose (du coup, mon démon principale BLEA ne fonctionne pas car je n’ai pas de clef usb sur ma smart, est ce le problème?)

Mais pas de remontée de température-humidité malgré ça.

Merci de votre aide

Un petit up pour un petit peu d’aide , svp :slight_smile:
Merci d’avance

La présence des capteurs remonte bien, ainsi que la valeur rssi en dbm, mais que dalle en température et humidité :frowning:

Est ce que le fait d’être sur une antenne déportée peut être la cause? Car le fichier lwsd03.py se trouve sur mon jeedom alors que l’antenne blea se trouve sur un autre rpi?

salut, moi j’ai ajouté une antenne blea après avoir fait la modif en local, et la modif était effective également sur l’antenne sans manip, donc le souci ne doit pas venir de la…
Tu peux vérifier le fichier lwsd03.py directement sur ton rpi en te connectant en ssh…hésites pas si t’as besoin d’aide

Salut @Remyg83

Je n’ai pas encore d’antenne BLEA en local, j’attends mon dongle usb qui ne devrait pas tarder :slight_smile:Je regarde ce soir en direct sur le rpi déporté BLEA, car je n’ai pas la main à distance sur ce rpi depuis l’extérieur.

Merci de ton aide :slight_smile:

Ok @lr3674 tiens nous au courant, tjs pas de remontée de température sur le capteur ?

Je reviens sur une question posée plus haut, pas d’incidence de n’avoir qu’une antenne Blea et pas de local mais par contre il faut bien modifier le fichier sur l’antenne, il faut donc te connecter en SSH et vérifier le fichier lwsd03.py sur ton RPI

Salut à tous, salut @Remyg83
oui j’ai bien le fichier sous /blead/resources/blead/devices, et j’ai bien les 4 mac des capteurs avec leurs clefs.
Je viens d’installer un dongle usb BT en local sur ma jeedom smart pour ajouter une antenne BLEA. Je vais supprimer mes capteurs et refaire la procédure, qui sait.

Voici la copie de mon fichier ldsw03.py dans ma jeedom smart :
fichier_jeedom

J’ai laissé l’ancien fichier que j’ai renommé ldsw03.py.old c’est bon normalement?

Oui logiquement c’est tout bon, ça remonte les températures dans jeedom? Vérifié également sur ton RPI (antenne Blea déporté ) que le fichier est bien le même)

Salut

Ca remonte pour 3 sur 4. Mais la fréquence de refresh n’est pas top du tout :frowning: Une fois par heure et encore pas tout le temps.
Je vais refaire l’association du 4ème avec l’appli MiHome rootée des fois que la clef est changée.
Je te tiens au jus.

Merci

Ok tiens nous informé…

Yo,

Pas mieux, j’en ai 2 qui remontent de temps en temps, et d’autres jamais :frowning:
Il y a un truc qui cloche chez moi mais quoi???

remet en copie ton fichier lywsd03 (en entier) et les logs stp…
pour info voila l’historique de mes 4 capteurs ( dont 1 chute à l’ouverture de la fenetre, donc tu peux voir la réactivité)…
chart

et as tu bien suivi ces étapes :

  • Ajouter la dépendance sur la librairie de décryptage : sudo pip3 install pycryptodomex
  • Décochez le ‹ refresh forcé › pour chaque device de ce type dans la page ‹ Paramètres ›
  • Redémarrer le démon BLEA

bonjour à tous !

Comment faites vous pour mettre à jour le fichier lywsd03.py ?
Via WINSCP ? j’ai une erreur permission denied…
pourtant, je me connecte en ssh avec le login : pi
Merci de votre aide…

via putty pour l’acces ssh
et tu edites avec la commande « sudo nano lywsd03.py »

Salut

Voici le fichier sur mon jeedom, j’ai changé l’extension en .txt au lieu de .py pour l’uploader sur le forum :
lywsd03.txt (3,9 Ko)

J’ai bien mon ancien fichier d’origine en .py.old :
Capture

Voici les deux logs en local et déporté, j’ai changé les apikey en mettant des xxxxxxxxxxxxxxxxx :
logs-blea_BLEA_BUANDERIE.txt (64,7 Ko) logs-blea_Local.txt (50,4 Ko)

La fréquence de remontée des 4 capteurs, il y a seulement le capteur séjour qui semble en vie régulièrement :
remontée température

Merci

Bon ya un souci, je serai à ta place je repars de zéro, réinstall du plugin blea, suppression des capteurs, recommencer la procédure d’extraction de clé etc… ya un truc qui a du foirer mais j’arrive pas à mettre le doigt dessus…désolé de pas pouvoir plus t’aider

Ce n’est pas grave, déjà tu as pris du temps pour me répondre :slight_smile:

Je vais recevoir un pi0W d’ici 15 jours pour faire une antenne déportée supplémentaire. Je vais tout purger à ce moment là. Par contre, si je supprime le plugin BLEA, est ce que cela va détruire tous les fichiers qui ont été mis sur mon antenne déportée actuelle en pi3b+?

Merci