[Shelly] Utiliser les Custom prefix mqtt avec les "announce"

Tags: #<Tag:0x00007f3854749b48>

Salut Jeandhom,

Il y a un truc qui m’échappe dans les announce, tu sauras sans doute m’eclairer : depuis que j’utilise le custom prefix mqtt (tres pratique question lisibilité pour identifier les correspondances ID / devices) , les announce ne sont « disponibles » qu’une seule fois : lors du changement de ce fameux prefix dans le shelly, mais ensuite (lendemain par exemple) la commande me retourne du vide… Une idée ?

Merci

Salut antar,

Je n’utilise pas le custom prefix (que je viens de découvrir grâce à toi).

Pour une commande announce tu dois mettre dans « topic » : shellies/shelly1-AABBCC/announce.
Je suppose qu’avec ton custom prefix : « monCustomPrefix », tu as du modifier dans « topic » : shellies/monCustomPrefix/announce ?

Oui j’avais bien modifié les topic en fonction de mes custom prefix mais rien a faire…

Edit : je viens de faire le test de désactivation / ré-activation de ce custom prefix : l’announce recoit bien les infos du shelly (mais pour combien de temps ?)

Et que donne l’ancienne notation : shellies/shelly1-AABBCC/announce ?

Pardon j’avais édité mon message pendant que tu étais en train de répondre je crois pour info.

Cette commande a un topic incompatible puisque je l’ai indiqué sous la forme : shellies/customprefix/#

Tu es tout à fait clair.
Je viens de faire un essai avec un custom prefix et je fais le même constat que toi, ma commande action announce ne fonctionne plus.
Cela doit être un bug dans le firmware du shelly.

Merci d’avoir fait ce constat avec moi, je vais patienter une MAJ du firmware (que je surveillerai à l’ancienne du coup :wink: )

PS : désolé je crois que j’édite trop mes messages !

j’ai créé un ticket (T-20021266) chez shelly sur le sujet

1 J'aime

Les mises à jour des firmwares semblent bizarre en ce moment.

Les shelly1 sont en v1.6.2
Les shelly1PM sont en v1.6.1

Ouep et les shelly 2.5 en 1.6.0… :face_with_raised_eyebrow:

[#T-20021269] Support Ticket Opened

With shelly1 with firmware 1.6.2, announce don’t work with Custom MQTT prefix.
Without Custom MQTT prefix : shellies/shelly1-AABBCC/announce work.
With Custom MQTT prefix : shellies/myCustomPrefix/announce don’t work.
Best Regards.

ça m’arrange pas trop ca :unamused:

même pas un signe d’espoir pour une future maj en +

Pourquoi, c’est un ticket que je viens d’ouvrir pour appuyer le tien.

Merci !

J’ai cru que c’était leur réponse pardon

Réponse de shelly :

Please contact developers@shelly.cloud on the matter.

Mail envoyé, affaire à suivre …

Réponse ce matin de developers@shelly.cloud

We are looking into this and will let you know as soon as we've
confirmed the issue.

Tu as été plus rapide que moi :wink:

Je viens d’avoir leur réponse.

Hello again,

We are unable to confirm the issue. Announces work well for us both with
and without custom MQTT topic prefix.

If the issue persists for you, please send us the contents of
`/settings` over HTTP, and any additional information which may help us
to reproduce the problem.

Best,

J’ai refait des essais et finalement ça fonctionne bien aussi chez moi.

Il faut que tu regardes ta config dans #plugin-jmqtt.

Merci de ton retour, je ne comprends pas le coté aléatoire chez moi, sur install toute neuve (zero restore) d’un v4.

Je ne vois pas bien ce que tu veux dire par regarder ma config mais je vais cesser de polluer ce passionnant post d’automatisation de MAJ firmware et creuser un peu ailleurs :face_with_head_bandage:

see ya Jeandhom :raised_hand_with_fingers_splayed:

Nous pouvons demander à @Salvialf, si il veut bien scinder ce sujet depuis le début de ton intervention, soit ici :

https://community.jeedom.com/t/tuto-shelly-jmqtt-automatisation-de-la-maj-du-firmware-des-shellies-avec-jmqtt/17166/8?u=jeandhom