Sauvegarde SAMBA Timeout client SMB

Tags: #<Tag:0x00007f38523985c8>

Page : index.php?v=d&p=backup
Jeedom_version : 4.0.49
Uname : Linux Maugrey 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l GNU/Linux


Message :
Bonjour,
Lors d’une sauvegarde sur un partage SAMBA hébergé sur un NAS le smbclient se ferme après quelques secondes avec le message : cli_push returned NT_STATUS_IO_TIMEOUT, la sauvegarde ne fait que quelques Mo et n’est pas complète.
Après analyse des logs et recherche il s’avère qu’il y a un timeout par défaut de 20 secondes sur le client SMB : https://www.samba.org/samba/docs/current/man-html/smbclient.1.html
En exécutant smbclient manuellement en ligne de commande en augmentant le timeout à 120 secondes avec l’option « -t 120 » la sauvegarde s’effectue correctement.
Serait-il possible de modifier l’appel à smbclient avec cette option lors de la sauvegarde, SVP ?
Pour information, il existe quelques posts sur le forum à ce sujet sans solution.
Cordialement

.

Bonjour,
J’ai eu le même problème de timeout lors de la copie en SMB sur mon NAS.

Vous pouvez éditer le fichier suivant : /var/www/html/core/repo/samba.repo.php
Chercher la ligne :
return system::getCmdSudo() . ‹ smbclient ’ . config::byKey(‹ samba:: › . $_type . ‹ ::share ›) . ’ -U " › . config::byKey(‹ samba:: › . $_type . ‹ ::username ›) . ‹ % › . config::byKey(‹ samba:: › . $_type . ‹ ::password ›) . ‹ " -I ’ . config::byKey(‹ samba:: › . $_type . ‹ ::ip ›) . ’ -c " › . $_cmd . ‹ " ›;

Changer en :
return system::getCmdSudo() . ‹ smbclient -t 120 ’ . config::byKey(‹ samba:: › . $_type . ‹ ::share ›) . ’ -U " › . config::byKey(‹ samba:: › . $_type . ‹ ::username ›) . ‹ % › . config::byKey(‹ samba:: › . $_type . ‹ ::password ›) . ‹ " -I ’ . config::byKey(‹ samba:: › . $_type . ‹ ::ip ›) . ’ -c " › . $_cmd . ‹ " ›;

PS : je suis en v3.3.39 donc ce fichier n’est peut-être pas le même.

1 J'aime