Reprise du Plugin Nissan Leaf Connect

Tags: #<Tag:0x00007fa7a6bf0f40>

Bonjour a tous.

J’ai changé ma leaf pour une Leaf 2019… et le protocole n’est malheureusement plus le même !
Quelqu’un veut reprendre le plugin ?

merci

Bonjour,

je suis preneur s’il y a quelque chose :wink:
Merci,

Salut,
je viens de corriger en local les problème de dépendances et de class que j’ai rencontré.
Concernant le protocole, j’ai cru voir un update 2019 sur le github du dev. Je vais y jeter un oeil prochainement. Je n’ai pas encore ma leaf ni mes accès donc impossible de tester.
Je vous tiens au courant si tout fonctionne…

PS : je suis nouveau sur jeedom, je ne pense pas pouvoir update le plugin avec les correctifs…

Salut,
(Je suis en train d’utiliser Google Traduction)

Je ne peux pas installer les dépendances:

une solution quelconque?

********************************************************
*             Installation des dépendances             *
********************************************************
Obj:1 http://security.debian.org/debian-security buster/updates InRelease
Obj:2 https://deb.nodesource.com/node_10.x buster InRelease
Des:3 http://ftp.es.debian.org/debian buster InRelease [121 kB]
Des:4 http://ftp.es.debian.org/debian buster-updates InRelease [51,9 kB]
Descargados 173 kB en 15s (11,7 kB/s)
Leyendo lista de paquetes...
Leyendo lista de paquetes...
Creando árbol de dependencias...
Leyendo la información de estado...
E: No se ha podido localizar el paquete php5-mcrypt
********************************************************
*             Installation terminée                    *
********************************************************

Bonjour,

J’ai exactement le même problème que pirracas77
Au moment d’installer les dépendances j’ai moi aussi ce message d’erreur.

A noter qu’hier le plugin fonctionnait parfaitement mais suite a une restauration avec ma sauvegarde d’avant hier, je ne peut plus installer les dépendances.
J’ai relancé ma sauvegarde 3 fois et réinstallé Jeedom complet 2 fois mais toujours pareil.
J’ai également tenté avec plusieurs autre sauvegarde


  •         Installation des dépendances             *
    

Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:2 https://deb.nodesource.com/node_12.x stretch InRelease
Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists…
Reading package lists…
Building dependency tree…
Reading state information…
Package php5-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‹ php5-mcrypt › has no installation candidate


  •         Installation terminée                    *
    

De l’aide svp

2 J'aimes

Pour ce qui ont le meme problème que moi…
Je me suis déconnecté de l’application mobile Nissan ev puis reconnecter et la miracle les infos de la leaf sont mis a jour dans Jeedom et le plugin fonctionne normalement alors que les dépendances ne sont pas installée

Ça ne marche toujours pas pour moi

Salut,
Moi non plus les dépendances ne sont pas installé mais ça fonctionne quand meme, essai de te déconnecter sur ton smartphone de l’application Nissan ev et te reconnecter…

Je ne pense pas que ce soit ça.
J’ai cette erreur dans le plugin.

Class 'object' not found

As-tu regardé ici :

https://community.jeedom.com/search?q=jeeobject

Je vous remercie!!
Maintenant, j’ai ce problème:

Request for 'UserLoginRequest.php' failed. Response received: {"status":"-2010","message":"INVALID PARAMS","resultKey":""}

Que dois-je utiliser ** NissanConnect.class.php **? Quelle est la plus récente?

salut,
avant tout est ce que tu arrive lancer la charge ou la clim depuis l’application nissan ev ?

Oui, je peux faire n’importe quelle action depuis l’application Nissan.

Quelqu’un peut aider? Je n’arrive pas à faire fonctionner le plugin

Bonjour, nouveau sur jeedom, je suis un peu perdu sur l’installation de ce plugin. J’ai une leaf 2.0 de 2018.
J’ai installé le plugin sur le market mais après je ne sais pas quoi faire.

Quelqu’un pourrait il m’aiguiller ?

merci

Bonjour, je viens de passer de la version du core de jeedom 4.0.62 à 4.1.17. Et malheureusement les dépendance ne se lancec plus :


  •         Installation des dépendances             *
    

Atteint :1 http://security.debian.org/debian-security buster/updates InRelease
Atteint :2 http://ftp.fr.debian.org/debian buster InRelease
Atteint :3 https://deb.nodesource.com/node_12.x buster InRelease
Atteint :4 http://ftp.fr.debian.org/debian buster-updates InRelease
Lecture des listes de paquets…
Lecture des listes de paquets…
Construction de l’arbre des dépendances…
Lecture des informations d’état…
E: Impossible de trouver le paquet php5-mcrypt


  •         Installation terminée                    *
    

J’ai une leaf 2018 et utilise ce plugin depuis les version 3 de jeedom.

Merci d’avance de votre aide

Bonjour,

est ce que ce plugin est encore fonctionnel ?
je l utilisait bcp avec ma Leaf24 … et là je viens de racheter une leaf40 mais j ai un doute .

déja , impossible de lancer les dépendances …
il faut modifier le fichier /var/www/html/plugins/nissan_leaf_connect/ressources/install.sh

changer les lignes 14 et 15 par : ( dé-commenter la premiere et commentez la fin puis la seconde )

sudo apt-get -y install php-mcrypt #(for php7 only)
#sudo apt-get -y install php5-mcrypt

ensuite j ai un message d erreur

Class ‹ object › not found

en éditant /var/www/html/plugins/nissan_leaf_connect/desktop/php/nissan_leaf_connect.php
ligne 119 , remplacer ‹ object › par ‹ jeeObject ›

(edit):
le plugin semble compatible Jeedom4 … il me remonte bien les infos de ma voiture , pas testé encore clim/charge , mais pas de raisons
je ne pensais pas, mais il est donc compatible connect EV ( en plus de carwings ) …
je pense au moins jusqu’aux modeles 2019 ( Nissan ayant changé ses API pour la Leaf 62 )

Salut,

Je vais essayer de publier tes modifs. mais le mieux c’est des PR dans github

J’ai mis tes modifs en beta.

Il faudrait porter cela en fait… https://gitlab.com/tobiaswkjeldsen/dartnissanconnect