Python 2 ou python 3

Intéressant, merci @akenad .
Et donc, la conclusion/recommandation c’est quoi ? Laisser faire les choses lors de l’installation des plugins sans se prendre la tête ? Respecter un ordre d’installation (d’abord ceux en python2, puis ceux en python3) ?
Perso, ayant deCONZ et Zwave, tout fonctionne bien sans que je me sois jamais posé de question au sujet de python. Peut-être ai-je eu la chance d’installer Zwave avant deCONZ ?

Les 2 mon capitaine !!

Et donc, la conclusion/recommandation c’est quoi ?

=> Le sujet est abordé aussi ici :

Ma conclusion/recommandation est d’éviter de lancer des commandes trouvées sur internet sans maîtriser la conséquence,
(en particulier ici mise à jour de pip et python alternatif)

Laisser faire les choses lors de l’installation des plugins sans se prendre la tête ?

=> Oui, moins on bricole le système soi-même et mieux ça passe.

Respecter un ordre d’installation (d’abord ceux en python2, puis ceux en python3) ?

=> Non, pas nécessaire.

Perso, ayant deCONZ et Zwave, tout fonctionne bien sans que je me sois jamais posé de question au sujet de python. Peut-être ai-je eu la chance d’installer Zwave avant deCONZ ?

=> Non pas nécessaire. Actuellement Z-Wave utilise python2 et deCONZ python3.
Il peut arriver que des évolutions de versions de modules de python (indépendant de la volonté de Jeedom ou des Devs) puissent poser un problème à un plugin alors qu’il n’y en avait pas auparavant.

Actuellement c’est EnOcean (sur Pi, et le module soupsieve nécessitant python3) qui a un problème, mais à une époque BLEA, deCONZ et Z-Wave on eu leur tour et ça à été rapidement rétabli (encore une fois si on ne « bricole » pas).

akenad :slight_smile:

Crystal-clear !
Merci :slight_smile:

Bonjour,

tant que tous les plugins conçus en Python2 n’auront pas migrés en python3, il convient de conserver python2.

Comme je l’ai expliqué plus haut, si on n’a pas « bricolé » le système, pip et python pointent encore actuellement par défaut sur python2.
autrement dit on doit avoir en particulier :

$ python --version
Python 2.7.x

De part l’évolution (de version) de certains modules Python depuis début Janvier 2020, l’installation des dépendances de certains plugins conçus en Python2 est devenu NOK.

Pour y remédier pour l’instant, dans l’attente d’une modification des scripts d’installation des dépendances (dans les plugins ou dans le core) :

  • Plugin XiaomiHome :

$ sudo python -m pip install future

  • Plugin OpenEnOcean :

$ sudo python -m pip install soupsieve==1.8

Puis relancer l’installation des dépendances.

akenad :slight_smile:

3 J'aimes