Problème Deamon

Tags: #<Tag:0x00007f28378d4198>

Bonjour,

J’ai hésité a placer ça ici ou dans “plugins”, mais comme cela ne touche que les possesseurs de Delta, j’ai placé ça ici.

Les 3 équipements : Home Adaptaters, Disque et Système ne fonctionnent pas car ils ne trouvent pas la méthode FreeboxAPI::deamon_stop().

Il faut dire qu’en parallèle j’ai aussi un problème avec le deamon :

Attention je pense qu’il y a un soucis avec le démon que j’ai relancé plus de 3 fois consecutivement

Voici 3 traces :

[Thu Oct 10 11:11:40.469672 2019] [php7:error] [pid 3770] [client xxxxxx] PHP Fatal error:  Uncaught Error: Call to undefined method FreeboxAPI::deamon_stop() in /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php:107
Stack trace:
#0 /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php(233): FreeboxAPI->fetch('/api/v3/system/')
#1 /var/www/html/plugins/Freebox_OS/core/class/Freebox_OS.class.php(636): FreeboxAPI->system()
#2 /var/www/html/core/class/cmd.class.php(1093): Freebox_OSCmd->execute(Array)
#3 /var/www/html/core/ajax/cmd.ajax.php(88): cmd->execCmd(Array)
#4 {main}
thrown in /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php on line 107, referer: http://xxxxxxxxx/index.php?v=d&p=dashboard
warning: commands will be executed using /bin/sh
job 7 at Thu Oct 10 14:43:00 2019
Thu Oct 10 09:55:34.325020 2019] [php7:error] [pid 3768] [client xxxxxx] PHP Fatal error:  Uncaught Error: Call to undefined method FreeboxAPI::deamon_stop() in /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php:107
Stack trace:
#0 /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php(172): FreeboxAPI->fetch('/api/v3/storage...')
#1 /var/www/html/plugins/Freebox_OS/core/ajax/Freebox_OS.ajax.php(31): FreeboxAPI->disques()
#2 {main}
thrown in /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php on line 107, referer: http://xxxxx/index.php?v=d&m=Freebox_OS&p=Freebox_OS&id=3
[Thu Oct 10 16:20:54.368737 2019] [php7:error] [pid 28917] [client XXXXXXXX] PHP Fatal error:  Uncaught Error: Call to undefined method FreeboxAPI::deamon_stop() in /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php:107
Stack trace:
#0 /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php(296): FreeboxAPI->fetch('/api/v6/home/ad...')
#1 /var/www/html/plugins/Freebox_OS/core/class/Freebox_OS.class.php(105): FreeboxAPI->getHomeAdapters()
#2 /var/www/html/plugins/Freebox_OS/core/ajax/Freebox_OS.ajax.php(23): Freebox_OS::addHomeAdapters()
#3 {main}
thrown in /var/www/html/plugins/Freebox_OS/core/class/FreeboxAPI.class.php on line 107, referer: http://XXXXXX/index.php?v=d&m=Freebox_OS&p=Freebox_OS&id=1

o1ivier

La réponse est donnée par IronmanLM >> ici (problèmes de droits sur la Freebox)

Encore merci à lui

o1ivier

Il faut plutôt tague le plugin.

Je vais regarder si je peux pas ajouter un message d’erreur

Hello,

C’est moi au la redirection du sujet, ne parle pas de la solution par IronmanLM ?

Non, le lien est effectivement pas bon…
Quelqu’un a la solution ?

Bonjour
Depuis la maj d’hier soir j’ai le même problème avec ma box mini 4k
J’ai vérifié les droits, reappairé la box avec le plugin, rien n’y a fait.
A chaque fois que je relance le démon, ça passe rapidement du vert au rouge et un message d’erreur apparaît (expliquant que le plugin n’arrive pas à lancer le demon)
Je n’ai pas trouvé de log et pour éviter de recevoir de multiples messages d’erreur, j’ai devalidé le plugin dans l’attente d’une maj.
Avec la version précédente, tout fonctionnait.

Toujours pas de tag a se sujet ce qui ne m’alerte pas et donc pas de reponse

le bug FreeboxAPI::deamon_stop() . doit etre corrigé sur les derniere version du plugin
Verifié bien.

Le bug etait present dupuis un moment mais les deniere mise a jours les font remonté plus car il y a plus de demon

Si quelqu’un est a jours (j’ai poussé une mise a jours ce midi) avec le bug qui apparait toujours est il possible de m’envoyé par mp un connexion a leur jeedom pour que j’annalyse de plus pres le probleme

Bonjour et merci Mika,

Fonctionnement redevenu normal avec la version du 15/11

bonjour, depuis la derniere mise a jour stable, d’aujourd’hui, mon demon est Out, si je le relance il retombe de suite

Apres arrêt de l’ état du plugin et relance de celui-ci le démon semble reste actif

Y a quelques chose dans les log?

Apres arrêt de l’ état du plugin et relance de celui-ci le démon semble reste actif

dans la toute dernière version que tu viens de sortir, ou celle juste avant je ne sais pas, tous mes équipements ont été désactivés

bonjour,
merci pour ton travail déjà!
le deamon ne se lance pas chez moi non plus voici les logs (j’ai modifié les sessions et IP)

[2019-12-10 15:42:22][DEBUG] : [FreeboxPassword]{“success”:true,“result”:{“logged_in”:false,“challenge”:“ZF+sdfsdvsdv$M0+V6ATfVC”,“password_salt”:“azgffgdsvsdvsdvsdvsdvsdvsdvsdvV”,“password_set”:true}}
[2019-12-10 15:42:22][DEBUG] : [FreeboxOpenSession]{“result”:{“session_token”:“sdsdvszdvvsdvsdv”,“challenge”:“sdvsdvsdvsdvsdvsdv”,“password_salt”:“sdvsdvsdvvvvvvvvvvvvvvvvvvvv”,“permissions”:{“parental”:true,“explorer”:true,“contacts”:true,“tv”:true,“downloader”:true,“player”:true,“settings”:true,“calls”:true,“home”:true,“pvr”:true,“vm”:true,“camera”:true},“password_set”:true},“success”:true}
[2019-12-10 15:42:22][DEBUG] : [FreeboxRequest] Connexion GET sur la l’adresse 192.168.0.254/api/v3/connection/([])
[2019-12-10 15:42:22][DEBUG] : [FreeboxRequest] {“success”:true,“result”:{“type”:“ethernet”,“rate_down”:5410,“bytes_up”:6619126494,“ipv4_port_range”:[0,65535],“rate_up”:250730,“bandwidth_up”:600000000,“ipv6”:“XXXXXXXXX”,“bandwidth_down”:10000000000,“media”:“ftth”,“state”:“up”,“bytes_down”:489176589,“ipv4”:"X.X.X.X
[2019-12-10 15:42:22][DEBUG] : [FreeboxRequest] Connexion GET sur la l’adresse X.X.X.X/api/v3/connection/xdsl/([])
[2019-12-10 15:42:22][DEBUG] : [FreeboxRequest] {“msg”:“Impossible de récupérer l’état de la connexion: Ce service n’est pas disponible actuellement”,“success”:false,“error_code”:“service_down”}
[2019-12-10 15:42:22][DEBUG] : closing session :{“uid”:“qscqscqsc”,“success”:false,“msg”:“Vous devez vous connecter pour accéder à cette fonction”,“result”:{“password_salt”:“qscqscqscqsc”,“challenge”:“qscqscqscqscqscqscqsc”},“error_code”:“invalid_session”}

Idem chez moi avec le même type de logs.

Idem chez moi , daemon arrêté

Hello,
Même problème avec la dernière mise à jour, mais les log suivants (idem, les xx, c’est pour masquer):
[2019-12-10 19:16:36][DEBUG] : [FreeboxPassword]{“success”:true,“result”:{“logged_in”:false,“challenge”:“xxxxxxxx”,“password_salt”:“xxxxxxxxxxxx”,“password_set”:true}}
[2019-12-10 19:16:37][DEBUG] : [FreeboxOpenSession]{“result”:{“session_token”:“xxxxxxxxxxxxx”,“challenge”:“xxxxxxxxxxx”,“password_salt”:“xxxxxxxxxxx”,“permissions”:{“parental”:true,“explorer”:true,“contacts”:true,“tv”:true,“downloader”:true,“player”:true,“settings”:true,“calls”:true,“home”:true,“pvr”:true,“vm”:true,“camera”:true},“password_set”:true},“success”:true}
[2019-12-10 19:16:37][DEBUG] : [FreeboxRequest] Connexion GET sur la l’adresse mafreebox.free.fr/api/v3/connection/([])
[2019-12-10 19:16:37][DEBUG] : [FreeboxRequest] {“success”:true,“result”:{“type”:“ethernet”,“rate_down”:31510,“bytes_up”:231789665533,“ipv4_port_range”:[0,65535],“rate_up”:18920,“bandwidth_up”:21940000,“ipv6”:“xx::xx:xx:xx:xx”,“bandwidth_down”:67360000,“media”:“xdsl”,“state”:“up”,“bytes_down”:259495647907,“ipv4”:“xx:xx:xx:xx”}}
[2019-12-10 19:16:37][DEBUG] : [FreeboxRequest] Connexion GET sur la l’adresse mafreebox.free.fr/api/v3/connection/xdsl/([])
[2019-12-10 19:16:37][DEBUG] : [FreeboxRequest] {“success”:true,“result”:{“status”:{“status”:“showtime”,“protocol”:“vdsl2_17a”,“uptime”:928013,“modulation”:“vdsl”},“down”:{“es”:251760,“rtx_c”:149443722,“attn”:18,“snr”:8,“nitro”:false,“attn_10”:187,“hec”:0,“rxmt_uncorr”:0,“ses”:3120,“maxrate”:83870,“phyr”:false,“leftrs”:210197,“rxmt_corr”:0,“ginp”:true,“err_free_bits”:1002814095,“snr_10”:88,“crc”:682235,“min_eftr”:65516,“rtx_uc”:2525887,“rtx_tx”:287791785,“rate”:67367,“fec”:342671243,“rxmt”:0},“up”:{“es”:0,“rtx_c”:372,“attn”:0,“snr”:5,“nitro”:false,“attn_10”:0,“hec”:0,“rxmt_uncorr”:0,“ses”:0,“maxrate”:22480,“phyr”:false,“leftrs”:0,“rxmt_corr”:0,“ginp”:true,“err_free_bits”:309954565,“snr_10”:55,“crc”:0,“min_eftr”:21940,“rtx_uc”:0,“rtx_tx”:79239,“rate”:21947,“fec”:738,“rxmt”:0}}}
[2019-12-10 19:16:37][DEBUG] : [FreeboxRequest] Connexion GET sur la l’adresse mafreebox.free.fr/api/v3/storage/disk/5000([])
[2019-12-10 19:16:37][DEBUG] : [FreeboxRequest] {“msg”:“Impossible de récupérer la liste des disques : Pas de disque ou de partition avec cet identifiant”,“success”:false,“error_code”:“not_found”}
[2019-12-10 19:16:37][DEBUG] : closing session :{“uid”:“xxxxxxxxxxx”,“success”:false,“msg”:“Vous devez vous connecter pour accéder à cette fonction”,“result”:{“password_salt”:“xxxxxxxxx”,“challenge”:“xxxxxxxx”},“error_code”:“invalid_session”}

Si j’essaie de cliquer sur le bouton "Paramètre de la Freebox, la fenêtre incrustée qui s’affiche reste vide :frowning:

Merci d’avance

Précision: toutes les cases sont bien cochée dans la gestion des applications sur ma box

Idem chez moi depuis application de la MàJ ce matin.
J’ai refait l’appairage et vérifier les droits d’accès OK
J’ai mis en debug les logs et j’ai comme Soyann :

[2019-12-10 19:16:37][DEBUG] : closing session :{“uid”:“xxxxxxxxxxx”,“success”:false,“msg”:“Vous devez vous connecter pour accéder à cette fonction”,“result”:{“password_salt”:“xxxxxxxxx”,“challenge”:“xxxxxxxx”},“error_code”:“invalid_session”}

Merci pour l’aide !

Même souci de mon côté.

Merci pour l’aide !

Bonjour

Les problèmes de démon sur la stable sont normalement corrigé grâce a la connexions sur le jeedom de @UweVonB .

Sur ca machine, il avait des équipement réseau sur jeedom qui ne doivent plus exister sur la freebox et qui envoyé une erreur.
Une erreur déconnectait jeedom de la box et donc plus d’acce et un demon NOK.

Pouvez vous confirmé la résolution chez vous?

1 J'aime