Pour ceux qui utilisent un RPI3 ou 4 avec SSD sans SD

salut il faire un sudo quoi apres pour modifie le fichier config.txt

Bonsoir,

sudo nano /boot/config.txt

une fois la modification effectuée, faire :
ctrl + o pour sauver
ctrl + z pour quitter

sudo reboot

merci on vas voir si la charge diminue

ça fonctionne, j’ai confirmé en plaçant des graphes avant / après (voir plus haut ici même).

J’en ai profité pour mettre à jour mon tutoriel pour installer Raspbian et Jeedom sur un Raspberry PI 3B+ sur SSD (mais il se suit aussi pour une installation sur une carte MicroSD).

https://community.jeedom.com/t/installation-de-raspbian-buster-lite-et-jeedom-sur-pi3b-sur-un-disque-ssd-msata/14650

il est ou le tuto?

Ici…

Très bon tuto :slight_smile:
Philippe

j’ai effectivement constaté sur mon PI (sans carte SD) une activité de la Led (SD)
j’ai donc suivi les indications de Fabrice (merci à lui !) généralement…ça marche sauf que (j’y connais pas grand chose en ligne de commande !) ça marchait pas !

ce ne serait pas plutôt ?
sudo nano /boot/config.txt

bon, c’est surtout pour ceux qui comme moi…copie bêtement avant de réfléchir ! et surtout sans remonter quelques messages plus haut !
et je confirme…ma Led (SD) ne clignote plus !

Merci, c’est corrigé.
En plus de ne plus clignoter, cela fait baisser la charge et au final, la température de la CPU.

=> Rendons à César se qui lui appartient, c’est une astuce de @Kerdale

Bonsoir,

Quelqu’un a t’il essayé sur un PI4?

Bonsoir.

A voir ici :

Bonsoir @Fabrice, merci pour ce lien.

Au premier regard, je vois que cela ne fonctionne pas " sdtweak poll_once doesn’t work on Pi 4" et plus loin je lis : "I’ve pushed updated .dts files to rpi-4.19.y that add sd_poll_once dtparams to all downstream .dtbs. Use with dtparam=sd_poll_once".

Du coup, je comprends plus?

Le détail ici :
https://raw.githubusercontent.com/raspberrypi/firmware/master/boot/overlays/README

Je comprends qu’il faut l’utiliser pour désactiver la détection de carte sd pour le boot en réseau.
Comme pour le moment il n’est pas possible de faire booter un pi 4 sur SSD sans carte micro SD, ce paramètre n’a pas de raison d’exister :crazy_face:

1 J'aime

Ca me rappel, un Asterix « La maison qui rend fou »
Bonne soirée

Je reviens sur cette modif, juste pour constater que depuis mon jeedom ne plante pu.
avant la modif, tous les 15 jours (environ et variable) mon jeedom était inaccessible je devais couper l’alim et il repartait (après avoir remis l’alim bien sur !)
mais depuis que j’ai fait cette manip, 40 jours sans plantage ! et je n’ai quasiment rien changé, même pas fait la dernière mis à jour (je suis en 3.3.39) .

Bonjour

ayant un 3B+ ainsi qu’un SSD , j’ai fait la modification ci dessus , et en effet je confirme le meilleur fonctionnement global du raspberry et de Jeedom , celui ci est plus reactif , le changement est visible avec le plugin monitoring , c’est limpide…

j’en ai aussi profiter pour modifier le swap

vm.swappiness = 10
CONF_SWAPSIZE=1024

Tout vas pour le mieux… , merci à tous !

Merci pour le tuyau, je viens de vérifier la charge de mon RPI3B+, ça fait une grosse différence!
image

Hello. Super intéressant tout cela. Disposant de 4 rpi3 B+ j’ai fait cette manip simple en plus sur 3 d’entre eux. Pas assez de recul après 10mn pour me rendre compte d’une réactivité accrue ou sur le niveau de température potentiel. En tout cas c’est top comme info.
Merci @Kerdale

pour confirmation meme si pas nécessaire versus les autres retours : charge CPU 15mn d’un de mes rpi3 :
chartCPU15

et température (bon avec la vague de chaud des 3 derniers jours c moins évident :slight_smile: ) :
chartTemp

Je n’ai pris qu’un exemple sur un de mes rpi3 mais sur les 3 autres le constat est le même

Pour moi, sur Rpi 4, c’est la ligne

dtparam=sd_poll_once

qui a fonctionné. L’autre (dtoverlay=sdtweak,poll_once) ne donne rien
Le résultat est assez impressionnant au niveau des indices de charge, et de la température (même si actuellement, le Rpi est encore « à nu » car j’attends toujours mon boitier alu Akasa)

1 J'aime

Merci à toi @Snoopy pour cette info, je viens de tester sur ma PI4 et SSD en USB je suis passé de 0,8 de load average à 0,05 sur 15min !

J’était justement en train de chercher d’où pouvait venir cette valeur élevée alors que j’étais à beaucoup moins sur ma PI3b+ précédente.

La charge est devenue tellement faible que la fréquence CPU baisse vers les 600MHz et remonte toute seule au besoin. C’est top ça pour la conso et la thermique.