Plugin SmartLife / Tuya - Discussion générale

Tags: #<Tag:0x00007f242e4c41a0> #<Tag:0x00007f242e4c3d18>

Bonsoir @BroLee

Je trouve cela ou ? dans l’appli Tuya?

Par exemple ou l’endroit où tu l’as acheter. Sur le carton ?

A l’ensemble de la communauté , bonjour,
J’ai une ou deux questions sur le fonctionnement de vos volets avec interrupteur Tuya.
Désormais tout fonctionne .
Depuis mon scenario Jeedom ils descendent : Ok
Mais qd je regarde sur l’appli : J’ai encore “closing” …
Et ca ne part pas .
Avez vous la meme situation ?

Pour le faire partir, j’ai créé une scene qui s’execute depuis Jeedom qui Stoppe le volet.

L’autre question concerne plus l’appli Smart Life :
Pour les volets j’ai un parametre “Strip Time”
Ca correspond à quoi ?
Temps de déplacement ?
Par défaut il est à 10s

Mais globalement très satisfait
Merci @sabinus52 : Good Job !

Hello @BroLee,

Alors c’est une LSC Smart Ceiling Light de chez Action qui fonctionne ou sous l’application Tuya ou SmartLife, ça ne fait que du blanc chaud ou froid.

https://www.action.com/fr-fr/p/plafonnier-intelligent-lsc-smart-connect-2/

1 J'aime

J’ai aussi le même soucis “500: internal server error”, une idée ? J’ai bien rentré le bon Utilisateur/mot de passe. Jeedom est sur un raspberry PI3. Une idée ?

Bonjour Merci tout d’abord @sabinus52 pour ce plugin,

Par contre je rencontre également un problème lors de la configuration.
Lorsque j’entre mon numéro de téléphone (avec ou sans 0) ou l’adresse mail j’ai le message d’erreur suivant :

cURL error 28: Resolving timed out after 2511 milliseconds (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)

Voir la log : http://gofile.me/6AvA6/7jrANnxg7

Sur mon téléphone dans l’application Smart Life tout fonctionne correctement et l’état de ma prise connectée remonte et fonctionne bien.

J’ai fait le test de connexion curl depuis le raspberry avec mon adresse mail cela fonctionne bien :

root@JeedomPI:~# curl -X POST -k -H 'Content-Type: application/x-www-form-urlencoded' -i 'https://px1.tuyaus.com/homeassistant/auth.do' --data 'userName=mon@adresse.mail&password=Mon_mot_de_passe&countryCode=33&bizType=smart_life&from=tuya'
HTTP/2 200
date: Sun, 17 Nov 2019 20:52:23 GMT
content-type: application/json;charset=ISO-8859-1
content-length: 146
server: Apache-Coyote/1.1

{"access_token":"xxxxxxxxxxxx","refresh_token":"xxxxxxxxxxxxxx","token_type":"bearer","expires_in":864000}

A noter : Je ne sais pas si cela peut avoir un impact mais mon jeedom n’est pas accessible depuis l’extérieur ( redirection de port impossible à cause d’un bug dans la SFR Box 4K). Mais tout fonctionne bien en interne. Mon installation est sur un raspberry Pi 3.

Merci d’avance de votre aide,

1 J'aime

Bonjour,

Merci beaucoup pour ce plugin.

J’ai acheté des prise connecté avec relevé de la consommation électrique. Mais dans jeedom, je n’ai que l’état qui remonte.

Est ce possible d’avoir également la consommation ?

Merci

2 J'aimes

Moi aussi je viens de commander 4 blitzwolf que je recevrais dans la semaine je pense. En espérant que cela remontera dans jeedom. Au pire je tenterai un flash de ma prise si je trouve facilement la procédure. Jattend vos retours

@iPapy
Merci pour les logs, je vais voir ce que je peux faire même sans avoir ce type d’équipement pour tester. Si quelqu’un pourrait tester mes corrections avant déploiement, je suis preneur.

@Romelie
En mode Cloud, Tuya ne retourne pas les informations de conso des prises connectées. Donc pas moyen de les afficher.

1 J'aime

Bonjour @sabinus52,

Moi je peux si tu veux sabinus52.

@sabinus52

je viens d’installer ton plugin sur mon Jeedom avec un Ruban LED J’ai un message d’erreur “Param was not an HSL array” qui engendre rien de spécial

[JEEDOM][2019-11-26 18:48:25][INFO] : REFRESH bfad602c01177ad4depkzz : Lit Erwan
[JEEDOM][2019-11-26 18:48:25][DEBUG] : REFRESH bfad602c01177ad4depkzz : Sabinus\TuyaCloudApi\Device\LightDevice Object (     [id:protected] => bfad602c01177ad4depkzz     [type:protected] => light     [name:protected] => Lumary rgb tunable white led strip     [icon:protected] => https://images.tuyaeu.com/smart/icon/1550731461layccp344m_0.jpg     [data:protected] => Array         (             [brightness] => 1000             [color_mode] => white             [online] => 1             [state] => true             [color_temp] => 24506         )  )
[JEEDOM][2019-11-26 18:48:25][DEBUG] : REFRESH : tentative 1
[JEEDOM][2019-11-26 18:48:26][DEBUG] : UPDATE bfad602c01177ad4depkzz : checkAndUpdateCmd STATE = true
[JEEDOM][2019-11-26 18:48:26][DEBUG] : UPDATE bfad602c01177ad4depkzz : checkAndUpdateCmd BRIGHTNESS = 392
[JEEDOM][2019-11-26 18:48:26][DEBUG] : UPDATE bfad602c01177ad4depkzz : checkAndUpdateCmd TEMPERATURE = 24506
[JEEDOM][2019-11-26 18:48:26][ERROR] : Erreur exécution de la commande [Chambre Erwan][Lit Erwan][Blanc] : Param was not an HSL array

Un grand merci pour ce plugins que j’attends depuis un moment. J’avais un problème pour tester la connexion mais une fois réalisée tout mes appareils ont été retrouvé ainsi que mes scènes.
40 appareils et 12 scènes, avec prises, multiprises, lampes, interrupteurs et 4 boitiers Infra Rouge sur SmartLife.

Bonjour,
Merci pour ce plugin qui est au top. J’ai aussi le problème " Param was not an HSL array" avec 2 ampoules RGB venant de wish…
Que je selectionne “allumer” ou definir la couleur j’ai toujours le message “Param was not an HSL array”.
Je suposse que ça vient du fait que chez tuya quoique qu’on demande (allumer, changer la couleur,…) le serveur de tuya cherche toujours le paramétre couleur et ce avec la norme HSL.
Hors quand je veux spécifier une couleur dans une action sur jeedom à chaque fois ça me demande le paramètre avec la norme HEX.
Du coup jeedom envoi le code couleur en HEX à Tuya qui lui veut du HSL…
S’il y a moyen de corriger ça ce serait le top !
Et encore merci au concepteur !

Bonjour,
je suis un nouvel utilisateur jeedom …
Le but 1er (pour moi) étant de centraliser tous mes divers équipements (netatmo, ewelink, tuya, ikea, …) dans une seule et même interface.
Pour l’instant j’y arrive pas trop mal.
Je rencontre le même soucis que certains ici (Param was not an HSL array)
Et j’aurais besoin que l’état de mes équipements se mettent à jour (dans jeedom) lorsque je les utilisent via l’application Tuya.
Quelqu’un pourrais m’aider et me mettre sur la voie ?

Merci par avance

Hello, j’ai le même problème avec le plafonnier LSC smart Connect de chez Action. J’en ai installé 4 dans mes caves et je reçois le même type d’erreur que décrite pas @iPapy. A chaque commande ça fonctionne mais avec une erreur dans le log.(Param was not an HSL array)

1 J'aime

J’ai apporté quelques modifications au sujet de l’erreur :

Param was not an HSL array

Comme je n’ai pas ce type de matériel, il m’est impossible de vérifier le bon fonctionnement.
Donc cette modif est disponible depuis mon dépôt Github sur la branche develop ou bien en version beta sur le Market.
Au préalable, il est OBLIGATOIRE de supprimer votre équipement qui pose problème et relancer une Découverte

1 J'aime

Super, ça à l’air de fonctionner chez moi pour mes plafonniers LSC, je n’ai plus l’erreur.
Bon, toutes les fonctions ne vont pas mais c’est déjà bien.
Merci!

Idem pour moi tout est ok aussi tout comme @Kiyeko, juste deux trois truc à ne pas activer afin que ce soit en rapport avec ce plafonnier qui ne fait que du blanc.

Encore merci à toi @sabinus52

Bonjour,
Idem,
J’ai les ampoules “Actions” qui marchent bien avec l’application mobile, et avec Alexa et google mini mais rien a faire avec Jeedom, j’ai également ce message : Get accesstoken failed. Username or password error!
J’ai mis mon 06, essayé sans le 0, tenté mon email, mon compte utilisateur : même message, et pas d’erreur sur le mot de passe, car je l’ai rentré également pour Alexa et GoogleHome.
J’active les logs pour essayer d’en savoir plus

@iPapy @Kiyeko
Quelles sont ces fonctions qui ne vont pas ?