Plugin Jeedouino

Tags: #<Tag:0x00007fbdad2c1588>

Bonjour,

Pour faire suite à la migration vers ce nouveau forum, j’ouvre ici le sujet pour le plugin Jeedouino.

Description

Ce plugin vous permet de contrôler de différentes manières les pins entrées/sorties des cartes suivantes :

  • Arduinos (différents modèles) branchés en USB sur Raspberry PI .
  • Arduinos (différents modèles) branchés avec un shield Ethernet (W5100, W5500, ENC28J60) sur votre réseau.
  • les ESP8266 (wifi) ex:
    NodeMCU , Wemos, etc.
    Sonoff 4ch & Pow, Electrodragon 2ch.
  • les GPIO du Raspberry PI .
  • les cartes PiFace v1 (et piRack) sur Raspberry PI .
  • les cartes IO PiPlus et les MCP23017 sur Raspberry PI .

Avec le support de différents composants tels que DHT11/22, DS18B20, WS2811, BMP085/180, BME/P280*, BME680*, etc…

Il fonctionne en local ou en déporté (jeedouinoExt) sur votre réseau.

Lien vers le plugin : https://www.jeedom.com/market/index.php?v=d&p=market&type=plugin&plugin_id=2064
Lien vers la documentation : https://revlysj.github.io/jeedouino/fr_FR/
(*)Beta:
Lien vers le changelog : https://github.com/revlysJ/jeedouino/blob/beta/docs/fr_FR/changelog.md
Lien Github : https://github.com/revlysJ/jeedouino/archive/beta.zip

Bonne journée à tous.

Salut, il faut que je me penche sur ton plugin, j ai des arduino mega avec de shield ethernet

Bonjour,
J’utilise un Jeedouino pour le comptage d’impulsions provenant d’un compteur d’eau.
J’ai provisoirement débranché le module et décoché la case “activé?” dans le panneau de configuration de l’équipement et je m’aperçois que je reçois un message d’erreur indiquant “2019-10-05 16:35:12 networks Echec du ping sur : [RESEAU][JDNO_CptEau_Buanderie]”. Le plugin semble toujours essayer de communiquer avec le module alors qu’il est désactivé. Est-ce un comportement normal ?

Bon … quand on a pas de tête on écrit n’importe quoi …
Désole du dérangement, en fait j’avais oublié que j’avais installé le plugin NETWORK et que c’était lui qui faisait des ping sur le Jeedouino et pas le plugin.

image
bonjour lorsque je sauvegarde la confi de mes GPIO sur mon raspberry j’ai ce message, je suis en V4

Bonjour,

@artpol, c’est normal si tu est sur la stable du plugin et en jeedom v4. Il te faut passer sur la beta.
Si tu as déjà la beta, il me faut alors tous les logs du plugin.

Bonne journée à tous.

Effectivement, je suis sur le plugin stable

Bonjour @revlys

C’est tout nouveau pour moi tout ça… Et les premières recherches n’ont pas donné grand chose.

J’ai un message “Class ‘object’ not found” quand je clique sur “plugins” - protocoles domotique - Jeedouino; auriez-vous une piste pour m’aider à utiliser votre plugin qui à juste l’air excellent?

Version : 4.0.21
Source : default
Branche : V4-stable
Système : RPI 3 B

Sur l’ancien forum, dans le thread de ce plugin; il me semble avoir lu qu’à un moment j’avais la mauvaise version de Raspbian… (buster si je ne dis pas de connerie)
J’ai dans un premier temps essayé de modifier deux fichiers sans succès.
Le downgrade de l’OS semblait rapide, j’ai donc fait un backup de jeedom et j’ai réinstallé raspbian avec la version recommandée pour Jeedom.
La réinjection du backup de jeedom n’a pas fonctionné; j’ai donc re-re installé tout depuis le début.

Pas de bol, maintenant ça ne fonctionne pas mieux ^^

Merci d’avance pour votre aide! :slight_smile:
Sans%20titre

Bonsoir à tous,

@Kyn69,

Oui c’est un problème de compatibilité de la version stable actuelle.
Techniquement, ce n’est pas vraiment buster qui pose problème, mais la version de php qui a engendrée un besoin de modifications.

Plusieurs solutions :

Bonne soirée.

@revlys Merci beaucoup ça marche! :smiley:

Bonne soirée!

Dites, je n’y connais rien en arduino et de toute évidence je ne suis vraiment pas doué dans ce domaine…

Je me heurte à la faible mémoire de la carte (une Ks0304, mix de Uno et de w5500 et de carte micro-sd)…
Tout ce que j’ai besoin, c’est de récupérer les valeurs d’un BME280 en i2C.
Après une bonne dizaine d’essais j’ai systématiquement des erreurs, quelqu’un pour m’aider à alléger le code svp? :slight_smile:

J’ai le message suivant après moult efforts:

Le croquis utilise 27336 octets (84%) de l’espace de stockage de programmes. Le maximum est de 32256 octets.
Les variables globales utilisent 2085 octets (101%) de mémoire dynamique, ce qui laisse -37 octets pour les variables locales. Le maximum est de 2048 octets.
Mémore insuffisante ; consulter la page http://www.arduino.cc/en/Guide/Troubleshooting#size pour obtenir des astuces sur comment le réduire.
Erreur de compilation pour la carte Arduino/Genuino Uno

Si je comprends bien ce sont les 101% qui posent problème?
Comme je débute, je ne vois pas comment je peux réduire les variables globales…

De plus dans l’idée, j’aimerais pouvoir lire deux capteurs BME280 par carte et rien d’autre, c’est possible?

Ci dessous ce que j’ai réussi tant bien que mal à garder sans planter le code (enfin j’espère).

Ici il y avait un copier/coller du sketch arduino, c’était pas beau à voir sur le forum alors je l’ai enlevé pour préserver la lisibilité de la page. :wink:

Bonjour à tous,

@Kyn69,
Ne copie/colle pas le code comme ça, c’est peu lisible, met le plutôt en fichier joint.
Concernant ta carte, effectivement elle est courte en ram et la lib bme280 en demande beaucoup, il vaut mieux une mega.
Si ton capteur est un vrai bme280 (pas une copie chinoise dont je ne sais si ça marchera), remplace:

#if (UseBME280 == 1)
#include <Wire.h>
#include <farmerkeith_BMP280.h>
bme280 bme280;
#endif

par:

#if (UseBME280 == 1)
#include <Adafruit_Sensor.h>
#include <Adafruit_BME280.h>
Adafruit_BME280 bme280;
#endif

Si tu n’as pas la lib de dispo dans ton arduino-ide, regarde ici:

Cette lib prends moins de ressources, mais n’est pas compatible avec tous les bme280, donc a essayer.

Dernière chose, pour l’instant, tu n’auras qu’un seul capteur de disponible par carte.

Bonne journée.

Bonjour tout et monde, et merci @revlys!

Effectivement j’étais moyennement fier de mon copier/coller, c’est bien noté pour la prochaine fois! :sweat_smile:

Comme tu l’avais pressenti je n’ai pas de capteur original mais une pâle copie qui ne fonctionne forcément pas avec la librairie d’Adafruit…

Je viens donc de commander cette fois deux BME680 qui semblent eux originaux, ainsi que deux mega + 2 shields w5100…

Si jamais quelqu’un arrive à ne laisser que la gestion des BME280 dans le sketch malgré tout ça me rendrait vraiment bien service; j’en ai 6 qui n’auraient plus d’utilité si pas utilisables avec mes cartes ks0304 et ce sketch…

Merci à tous, au plaisir de vous lire :grin:

@Kyn69, oui je m’en doutais un peu.

Avec la modif que je t’ai donnée précédemment, essaie de modifier le :

#if (UseBME280 == 1)
bme280.begin();
#endif

par :

#if (UseBME280 == 1)
bme280.begin(0x76);
#endif

De mon coté, je ne peux essayer car je n’ai pas de bme.

Bonsoir, J’ai le même problème que toi.

Quel solution à marché pour toi sachant que j’utilise la dernière version de jeedouino et que la version beta n’ai pas disponible dans le market?

Quelle est la marche à suivre pour modifier le code php?

Merci d’avance,

Bonne soirée.

Bonjour @Baptiste_Perrin, pour avoir accès à la version Beta du plugin, il faut aller sur le market https://www.jeedom.com/market/index.php?v=d&p=profils
D’ici, dans les options de ton profil, sélectionner “Activer l’accès aux plugins beta”
Ensuite, retourner dans l’onglet “plugins” de jeedom, puis market, et après recherche de Jeedouino, installer la version Beta. Après ça devrait mieux fonctionner :wink:
Cdt

Bonjour @revlys!

Bon, j’ai reçu des BME680 originaux (enfin j’espère)!
Ils fonctionnent parfaitement avec les librairies Adafruit en local, mais depuis Jeedouino je n’arrive à récuperer que la température et la pression, rien ne remonte concernant l’hygrométrie et les COV…
Aurais-tu une idée de vers quoi il faut que je cherche s’il te plait?

Pour ta solution donnée un peu plus haut, j’ai reçu des arduino mega, j’attends le shield qui va avec et je te dirai ce qu’il en est :wink:

Bonne journée! :slight_smile:

Bonjour à tous,
@Baptiste_Perrin, je valide la réponse de Kyn69 :wink:.

@Kyn69,

Tu as bien les commandes id_bme680_h et id_bme680_g qui se sont créées ?

  • Si oui, avec la carte en marche et connectée, refait un sauver / générer, cela devrait renvoyer les bons paramètres à la carte.
    Patiente au moins 5 minutes, et si toujours rien, il me faudra les logs debug.
  • Si non, tu as du oublier de mettre à jour la pin dans pin/gpio.

Pour tes bme280, installe la dernière beta, j’y ai apporté les modifs vues plus haut, notamment la lib Adafruit.
J’aurais voulu savoir si c’est bon avec tes cartes hybrides Ks0304

Bonne journée.

Hey @revlys, quelle réactivité! :smiley:
Pour la modif, ça me sort à la ligne 200:

conflicting declaration ‘Adafruit_BME280 bme280’

Ai-je loupé un truc? (on ne peut exporter que des fichiers image et pdf sur le forum?)

Sinon, pour le couple BME680 - Ks0304 qui ne remonte que la température et la pression, j’ai essayé ta manip’ mais ça n’a rien changé… voici un screenshot.

Jeedouino%20ks0304%20BME680