Plantage du système home

Tags: #<Tag:0x00007f7536c789d8>

Bonjour
Hier Free a sortie en bêta sur Androïd et aujourd’hui sur iOS l’application Freebox Home permettant d’accéder aux objets « home » plus facilement.
Certes c’est en bêta, mais comme par hasard, depuis l’annonce de leur sortie le système home de ma box plante encore plus rapidement alors que je n’avais pas encore téléchargé les applications.
Avant l’annonce, m’a box tenez 2 jours mais depuis hier (loins de 24h), je l’ai redémarrer déjà 2 fois.
Est-ce une coïncidence ?
Pour info, j’ai éteint mon Jeedom pour voir si en utilisant leur application j’arrivais à faire planter le système, pour l’instant non hormis une lenteur à l’exécution d’une action fermer tous les volets.
Si quelqu’un a une idée où si je peux aider à trouver le problème qui dure depuis longtemps, je suis disponible

Hello
Surtout qu il y a un moment que je n ai pas fait de mise a jour
Ils vont peut être améliorer leur systeme on croise les doigts :crossed_fingers:t4:

1 J'aime

J’espère également
D’ailleurs dans leur nouvelle application on trouve des boutons « ouvrir » « fermer » qui fonctionne même avec plusieurs appuis, ça va peut-être vous permettre de corriger le problème du double appuis

Bon je crains bien que Jeedom ou le plugin soient au moins un peut en cause
Cela fait un peut plus de 15h que j’ai désactiver Jeedom et redémarrer ma box et mes volets fonctionnent toujours via les applications Home alors que j’ai fait plusieurs commandes d’essais donc des groupés pour commander tous mes volets.

J’attends les 24h de fonctionnement avant de relancer Jeedom, mais je crains bien que mon constat soit le même.

Oui peut être mais là difficile de savoir ce qui bug car pas de modif depuis des mois
Et sans log je ne pourrais rien faire

Je m’en doutes
Je vous tiens au courant après redémarrage de mon Jeedom

Hormis de s’assurer que le mode Debug du plugin soit activé, y a t’il autre chose à faire pour avoir le maximum d’info dans les logs ?

Bon, comme évoqué, j’ai redémarrer Jeedom hier (10/09/2021) vers 18h25 après 24h sans plantage de la box juste en utilisant les applications Home de Free.
J’ai essayé à plusieurs reprises les commandes dans la soirée et juste avant de me coucher vers les 2h du mat, les volets étaient encore pilotable.
Ce matin au réveil vers les 9h, impossible de les piloter.
voici les logs récupéré vers 10h
Freebox_OS-log 21-09-11–10h.txt (459,8 Ko)
Malheureusement, il y a rien durant la nuit au moment du plantage.
J’ai redémarré ma box vers les 13h30 aujourd’hui, la pendant que j’écris mes volets sont pilotables, mais jusqu’à quand !

Qu’est-ce que je peux vous communiquer de plus pour vous aider à résoudre ces problème de plantage ?

Malheureusement dans les logs on ne voit pas d action on voit juste la récupéreration des données

Si le plantage est constaté, il faudrait vider les logs et faire une action sur un élément de la domotique. Par exemple activer l alarme :rotating_light: et après un volet
Pour voir quel élément plante
Car je suppose si plantage si on demande d arrêter et redémarrer le wifi cela fonctionne ?
Le cron global pour la domotique est il actif ?
Si oui désactiver le et voir ?

Voici les logs de la nuit où le système Home à encore planté
Freebox_OS-log 21-09-12–9h.txt (9,2 Mo)
J’ai fait prolonger les logs mais pas encore assez pour avoir toute la nuit

Je n’ai pas le système d’alarme, je pilote uniquement des volets roulants Somfy IO
Avant que je redémarre la box j’ai fait une demande d’action sur un volet (Chambre P) à :
[2021-09-12 09:09:25][DEBUG]

Je ne comprend pas que vient faire le Wifi pour ce problème.

Il est désactivé
image

Je veux savoir si toute les commandes bug sur la Freebox ou uniquement la partie home

Pour moi je ne vois pas de plantage à chaque fois la Freebox renvoi true
Mais par contre je ne voix pas d action de type ouverture d un volet. Ce serait cette partie du log qu il faudrait

Uniquement la partie Home, en tous cas la gestion des volets car je n’ai pas le kit de sécurité

Ayant redémarré ma box ce matin, j’espère qu’elle va planter dans la journée pour pouvoir vous restreindre le créneau horaire pour la recherche du plantage.

bon, 6h après le redémarrage, la partie Home de la Freebox a plantée.
Malheureusement les logs sont vide, je suppose que les 20k de ligne a enregistrer n’ont pas été apprécié.
Je redémarre l’ensemble et vous tiens au courant au prochain plantage

Mais voici tout de même les logs après le redémarrage de Jeedom uniquement et une demande de manœuvre de mon volet « bureau » qui ne c’est pas exécuté vu que la home de la box était planté
Freebox_OS-log 21-09-12–15h.txt (187,4 Ko)

Cela va faire prêt de 24h sans plantage, très étonnant mais tant mieux.
Je transmettrais les logs lors du prochain plantage du système home

Je continu a vous tenir au courant, ça fait 2 jours et 16h que je n’ai pas redémarré ma box pour remettre en route le système « Home ».
Je suis très étonné de ce changement de comportement alors que juste avant le système à planté de nombreuse fois dans un délais relativement court.
Je n’ai fait aucune modification sur les paramètres et il n’y a pas eu de mise à jour de la box.

A bientôt pour la suite

Ce qui m étonné cela fait quelques mois que je n’ai rien touché
Donc c’est FREE qui a fait des modifs mais quoi :no_mouth:

C’est ce qui semblerait, mais ce qui est étonnant c’est qu’il n’y a même pas de mise à jour de leur part

Bon ça n’a pas duré, le système a planté cette nuit entre 2h et 7h (soit avant 3 jour et 16h de fonctionnement), si ça pouvez ne jamais planter, ça serait nettement mieux
Voici les logs
Freebox_OS-log 21-09-16–7h.txt (9,2 Mo)

J’ai essayé des actions de consignes d’ouverture, elles sont à 7h10

Hello
Pour moi l’action est bien envoyé meme si la Freebox est planté et elle répond true donc ok

[2021-09-16 07:11:11][DEBUG] : ********************  Action pour l'action : Stop(1) de l'équipement : Chambre P
[2021-09-16 07:11:11][DEBUG] : │ [Freebox Request Connexion] : PUT sur la l'adresse mafreebox.freebox.fr/api/v8/home/endpoints/9/1/({"value_type":"bool","value":true})
[2021-09-16 07:11:11][DEBUG] : │ [Freebox Request Result] : {   "success" : true }
[2021-09-16 07:11:11][DEBUG] : │ [Freebox Request Connexion] : GET sur la l'adresse mafreebox.freebox.fr/api/v8/home/tileset/9(null)
[2021-09-16 07:11:11][DEBUG] : │ [Freebox Request Result] : {   "result" : [       {         "action" : "store_slider",         "data" : [             {               "ep_id" : 3,               "label" : "Consigne d'ouverture",               "name" : "position",               "refresh" : 2000,               "signal_id" : 4,               "slot_id" : 3,               "ui" : {                   "access" : "rw",                   "display" : "icon",                   "icon_range" : [                       0,                       11,                       22,                       33,                       44,                       55,                       66,                       77,                       88,                       95                     ],                   "icon_url" : "/resources/images/home/pictos/volet_%.png",                   "unit" : "%"                 },               "value" : 100,               "value_type" : "int"             },             {               "ep_id" : 1,               "label" : "Stop",               "name" : "stop",               "slot_id" : 1,               "ui" : {                   "access" : "w",                   "display" : "button"                 },               "value" : null,               "value_type" : "void"             }           ],         "group" : {             "label" : "Garage"           },         "label" : "Chambre P",         "node_id" : 9,         "type" : "info"       }     ],   "success" : true }

Pour moi c’est la box qui réagit mal, mais vous fetes quand meme pas mal de requête sur la box. je ne pense pas que se soit nécessaire d’actualiser tout comme ca.

si j’avais un message, je pourrais étudier mais là je n’ai rien qui me dit que la Freebox est planté

2 J'aimes

Comment ça ?

Je n’ai rien changé à la configuration

Comment limiter les requêtes ?

Pour info, pour ne pas avoir le problème du double appui sur les boutons, j’ai créé un virtuel pour toutes mes commandes

Bonjour,
Mon système Home a de nouveau planté
à 9h02 ce matin ainsi que vers 9h15, il a bien fonctionné.
Par contre, je viens seulement de m’apercevoir qu’il est HS du coup, je n’ai pas de créneau plus restreint. mais j’ai les logs de l’ensemble de la journée, les voici
Freebox_OS 21-09-18–16h30.txt (9,0 Mo)
Je reste à disposition pour des essais