[OFFICIEL][BETA] Plugin Enedis Linky

Tags: #<Tag:0x00007f3852f227b8>

Bonjour,

Nous venons de mettre à disposition sur le market un nouveau plugin permettant de récupérer les informations du compteur communiquant Linky à partir du compte-client Enedis :
https://market.jeedom.com/index.php?v=d&p=market_display&id=4036

Ce plugin est actuellement en beta et n’a pu être testé qu’avec 2 comptes-client différents pour le moment. Nous l’avons mis à disposition au plus vite afin d’être en mesure de confirmer son bon fonctionnement avec l’ensemble des comptes Enedis avant passage en stable (ce que nous espérons sincèrement).
N’hésitez donc pas à faire savoir si cette version fonctionne chez vous en réponse à ce sujet.

Sur la page de l’équipement renseignez l’identifiant ainsi que le mot de passe de votre compte-client Enedis puis cliquez sur le bouton Sauvegarder.

Le plugin va alors vérifier la bonne connexion au site Enedis et récupérer et insérer en historique :

  • puissance soutirée : les 48 valeurs de la veille (1 valeur par demi-heure),

La courbe de consommation (ou puissance soutirée) restitue la puissance appelée par tous vos appareils électriques en moyenne sur une demi-heure.

  • consommation journalière : les 30 derniers jours,
  • consommation mensuelle : les 12 derniers mois,
  • consommation annuelle : les 3 dernières années.

Edit: Si vous n’avez pas de remontée pour la commande puissance soutirée c’est probablement du au fait que vous n’avez pas activé la collecte et l’enregistrement de la consommation horaire dans votre compte-client Enedis.

Le plugin se connecte à la partie professionnels du site Enedis, il est donc nécessaire de pouvoir y accéder avec vos identifiant et mot de passe. Il semble que les comptes-client créés récemment (moins de 2 mois ?) ne puisse y accéder, le plugin ne fonctionnera donc pas chez ces personnes.

8 J'aimes

Cela fonctionne impeccable :slight_smile: (je suis sur une jeedom smart en v4)

merci

Jeedom V 3.3.39 sur VM Strech Proxmox impeccable !

Fonctionne très bien (Jeedom 4.0.61 sur PI3)
Merci pour ce plugin :grinning:

Génial, maintenant il va falloir que enedis regle mon problème de récupération des info compteur…

Ca marche (VM Debian et Jeedom 4.0.61) !! Merci beaucoup.
GV

Bonjour, pour ma part, j’ai systématiquement une erreur d’authentification.
Et ceci, avec mon mot de passe initial, puis après l’avoir changé (au cas où…).
Je suis sur RPI et Jeedom v3.3.52

Bonjour,

Il faudrait passer les logs du plugin en debug sur la page de configuration du plugin (Menu plugins -> Enedis Linky) :
image

Bien penser à cliquer sur le bouton sauvegarder.

Ensuite tu peux sauvegarder à nouveau ton équipement dans le plugin pour lancer la collecte des données et consulter les logs pour voir à quel moment ça bloque.

Bonjour,
Pareil pour moi :

Erreur d'authentification : vérifier la validité de l'identifiant et du mot de passe

Logs

[2020-08-14 11:20:14][INFO] : [Maison][Compteur] 1ère étape d'authentification Enedis - Récupération du token
[2020-08-14 11:20:14][DEBUG] : [Maison][Compteur] Echec d'authentification - identifiant ou mot de passe erroné
[2020-08-14 11:21:00][INFO] : [Maison][Compteur] 1ère étape d'authentification Enedis - Récupération du token
[2020-08-14 11:21:00][DEBUG] : [Maison][Compteur] Echec d'authentification - identifiant ou mot de passe erroné
[2020-08-14 11:21:03][INFO] : [Maison][Compteur] 1ère étape d'authentification Enedis - Récupération du token
[2020-08-14 11:21:03][DEBUG] : [Maison][Compteur] Echec d'authentification - identifiant ou mot de passe erroné
[2020-08-14 11:22:30][INFO] : [Maison][Compteur] 1ère étape d'authentification Enedis - Récupération du token
[2020-08-14 11:22:31][DEBUG] : [Maison][Compteur] Echec d'authentification - identifiant ou mot de passe erroné

Mon mot de passe comporte des caractères spéciaux :thinking: peut être au cas ou :wink:

y’a un arobase (@) dans mon mot de passe et l’authentification fonctionne…

Tu as essayé de bien renseigner l’identifiant et le mot de passe sans passer par un copier/coller pour être sûr qu’il n’y a pas d’espaces ? ça me fait penser qu’il faut que je supprime les espaces indésirables directement depuis le code du plugin.

Tu te connectes à Enedis à partir de quel site habituellement ?

Je me connecte sur https://mon-compte-client.enedis.fr/ en tant que particulier

Je renseigne manuellement le mot de passe (pas de copier coller)

Moi j’ai (!) dans mon mot de passe

Je suis sur un jeedom :
Version : 4.0.61
Source : default
Branche : V4-stable
Système : diy

@Aurelien tres bon travail cela fonctionne parafaitement.

Tu pourrais ajouter les génériques sur tes 4 commandes (puissance et consommation) dans ta prochaine version

En mode debug, j’ai exactement les mêmes traces que sbafs.
Mon mot de passe comporte des caractères spéciaux : « ; » « ) » et « > ».
Et je me connecte sur le site Enedis via https://mon-compte-client.enedis.fr/ également en tant que particulier

Effectivement j’ai juste mis les types génériques info par défaut sur toutes les commandes.

ça sera dispo dès demain

Pour info j’ai un @ dans mon mot de passe et cela fonctionne mais peut être que tous les caractères spéciaux ne passent pas…

Super boulot, déja mis en place sur mon design smartphone

image

J’ai essayé de changer de mot de passe mais cela ne change rien donc la piste des mot de passe n’est pas forcément la bonne

Pour ma part j’étais resté sur la connexion en tant que « professionnel » mais la personne chez qui j’ai testé le plugin se connectait depuis le choix « particulier ».

Est-ce que d’autres utilisateurs peuvent confirmer qu’ils se connectent au site « en tant que particulier » et que le plugin fonctionne pour vérifier que ça ne vienne pas de là ?

@olcg et @sbafs, si vous essayez de vous connecter « en tant que professionnel » vous arrivez à vous loguer et à voir les données ? La personne chez qui j’ai fait l’essai y arrivait…

Bonjour @Aurelien,

J’ai une smart en V4.0.62, le plugin fonctionne parfaitement. Pour info je me connecte en tant que particulier

Cordialement,

Non en tant que professionnel avec mes identifiants j’ai un message d’erreur :
L’authentification a échoué !