Mode Repeater Enocean

Est il obligatoire de passer l’équipement en mode apprentissage (en local sur l’équipement) avant d’envoyer la commande repeter Level 1 ou Level 2, pour que l’équipement la prenne en compte.

Personnellement, je pense que OUI mais si nous ne passons pas l’équipement en mode apprentissage, et que nous envoyons la commande repeter via Jeedom, Jeedom conserve cette information (comme si cela a été ris en compte) et pour autant il n’a pas eu la confirmation du passage en mode repeter de l’équipement.
Ceci est il normal ?

Quelle est la bonne procédure de passage d’un équipement en mode Repeter LEVEL 1 ou LEVEL2 ?

Si l’équipement est déjà appairé avec Jeedom, il n’est pas nécessaire de passer l’équipement en mode apprentissage pour qu’il prenne en compte la configuration de la répétition depuis Jeedom.
Qu’est-ce qui vous fait dire que Jeedom n’a pas eu la confirmation du passage en mode répéteur ?

J’ai essayé de mettre en mode repeter, via Jeedom des modules Advisen fil pilote, et je constate pas de message répété.
J’ai essayé de mettre en mode repeter, via Jeedom, des modules NODON éclairage (S/N-2-2-01 mais avec version HW2 et FW2.4.5), et je constate pas de message répété.

J’ai enfin mis des modules NODON de store en mode repeater directement sur le module et là je vois des trames répétées

Bizarre cette histoire. J’ai configuré la fonction répétition de mes modules Nodon volet roulant sans soucis. Le seul soucis que j’ai remarqué, c’est que le module perd sa configuration après une coupure d’électricité. Est-ce que ça peut être ton cas ?

Les modules NODON volet roulant sont beaucoup plus récents. J’en ai moi aussi plusieurs et j’ai fait le paramétrage directement sur le module et je peux voir les trames répétées dans Jeedom

Concernant les modules NODON éclairage que j’utilise (S/N-2-2-01 mais avec version HW2 et FW2.4.5), ils sont bien plus anciens. C’est au début de NODON. Ils datent de 2017
Manifestement le mode repeater en Jeedom ne va pas. Mais ceci n’est pas réellement un problème

. @ChristopheHD quand tu as configuré la fonction répétition sur tes modules, as tu mis au préalable le module en mode apprentissage puis la fonction répétition OU as tu simplement activé la fonction répétition (sans mode apprentissage) ?
. Tu dis que tu perd la configuration après une coupure de courant, Comment tu gères cela pour réactiver la fonction ?

Lorsque je passe en mode répéteur LEVEL 1 par exemple sur le module volet (en local et pas à partir de Jeedom), Jeedom annonce qu’il est sans fonction répéteur. C’est pour cela que je peux annoncer sans risque d’erreur de l’information du paramétrage reptétition n’est pas bidirectionnelle.

Sur les modules Advisen Fil pilote, je suis passé en mode répétition via Jeedom (sans le passage apprentissage) et aunune trame répété n’a été émise. Il y a surement un problème sur cette fonction. Est ce quelqu’un a réussit à mette un module Advisen fil pilote avec le mode répétition ?

Sans mode apprentissage. Pour réactiver la fonction, je vais simplement revalider la configuration de répétition du module sous Jeedom.

Il y avait un bug sur la fonction répétition jusqu’à fin 2019. Ton plugin est bien à jour ?

Sinon, tu peux toujours ouvrir un rapport de bug en joignant les logs debug. Cela aidera peut-être l’équipe Jeedom à résoudre ton problème.

Le problème est que nous ne pouvons pas être à proximité quand il y a une coupure de courant. Cela implique donc que plusieurs trames ne passeront pas entre le moment de la coupure de courant et le reparamétrage du mode répétiteur et cela si on se rend compte qu’il y a eu une coupure de courant

Je suis en contact avec le support de NODON.
Ils confirment, je cite :

"Une fois que le module est appairé à Dolphin View, vous pouvez le piloter quand vous le souhaitez et activer le répéteur à tout moment (l’appairage est effectif pour toujours).

2- En effet, sur le Module Volet Roulant, vous pouvez activer la fonction avec le double appui. Jeedom ne reçoit aucune information quand à l’activation du répéteur, c’est pourquoi la config ne bouge pas dans JEEDOM.

En effet le répéteur se désactive après une coupure d’alimentation. Ce n’est pas le cas du module éclairage lorsque vous envoyez la commande avec Dolphin View. Lorsque vous l’activez avec le double appui, il ne reste pas dans la mémoire dure du produit. C’est pourquoi il se désactive après la coupure de courant. Avec Dolphin, vous activez la fonction en dur."

Pour moi cela était pas complétement clair, j’ai donc directement appelé mon interlocuteur NODON (qui a été extrêmement compétent et sympathique). La conclusion est :
. La fonction répéteur ne se conserve pas dans un relai volet (via Jeedom ou en local). Ceci sera corrigé dans les nouvelles versions en cours de fabrication
. La fonction répéteur, sur un module éclairage est volatile (perte du paramétrage sur coupure de courant) sur le paramétrage à partir du module (appuie 2 fois) MAIS est permanente à partir de Dolphin OU jeedom

Pour les produits NODON, il faut donc activer la fonction répéteur sur les produits éclairage à partir de JEEDOM ( et pas à partir du module local)

1 « J'aime »

Bonjour Snoopyfb,

As tu finallement reussi à activer la fonction repeteur des modules Avidsen fil pilote ?
Car j’ai la meme problematique.
J’ai beau essayer d’activer l’option dans Jeedom, aucun message n’est repeté et le parametre reste à 0 dans la configuration du module et dans l’etat du reseau enocean.

Cordialement,

Albino2025

Bonjour
Non je n’ai pas réussit à activer la fonction repeater sur le module Advisen.
Possible sur le module volet de NODON (ou evology), directement sur le module mais désactivation de la fonction sur coupure de courant.
Possible sur les relais éclairage NODON (ou evology) via la jeedon et sans problème.

Problème de fonction répéteur résolu sur les modules de store NODON (evology) sur le firmware 1.4.0

Peut-on mettre à jour le firmware d’un module ?

non malheureusement. Ceci n’est pas mis à notre disposition

De mon coté, j’ai essayé de contacter la hotline avidsen.

J’ai eu comme reponse :
« Le principe même du protocole En OCEAN est cette fonction de maillage qui permet de faire communiquer les récepteurs entre eux.
En ce sens, il n’existe pas de réglage permettant de désactiver cette fonction. »

Sauf que (si je ne me trompe pas) le reseau EnOcean n’est pas un reseau maillé à la difference du Zwave.
La reponse n’est donc pas du tout approprié.
Je leur ai fait remarquer et depuis…plus de reponse :slight_smile:

Tu ne te trompes pas :slight_smile:

Bonjour,

Cette discussion m’intéresse car je suis confronté au problème.

J’ai installé Dolphin View sur mon PC, mais impossible d’appairer mes modules Evology pour volets roulants. Donc s’il y a une coupure de courant, je dois démonter mes modules !

Actuellement, j’utilise Domoticz sur un Raspberry, et je n’utilise pour le moment que Enocean via un USB300 (à la portée bien pourrie) pour ne piloter que des volets (à venir, piloter la VMC, peut-être des luminaires, et ajout de capteur de luminosité extérieure). Ce qui me fait venir ici est que je veux avoir le retour d’info de mes volets, et j’ai l’impression que c’est le cas avec Jeedom. J’aimerais aussi pouvoir fermer partiellement mes volets et j’espère que c’est le cas aussi.

Et je tombe par hasard sur cette discussion où on parle du mode répéteur dans Jeedom, formidable !

Et ma question est : comment connaître la version firmware des modules ?

PS : je découvre le monde de la domotique, de la programmation, bref, ne vous étonnez pas si j’ai des questions de débutant !

La version du firmware est inscrite sur le module Enocean, sur la face arrière

La bonne version est toute récente

image

Je verrai la prochaine fois que je les démonte. Je les ai acheté entre février pour les premiers et avril de cette année pour les deniers.

J’ai démonté un de mes modules acheté il y deux mois et il est en 1.3.0.

Et grâce à toi (voir l’autre sujet), j’ai enfin appairé mon module dans DolphinView :grinning: :v:

Donc mon soucis était de pouvoir garder en mémoire l’état de répétition qu’on perd en cas de coupure de courant. Un test facile, c’est de le mettre en répéteur de niveau 1. Si on appuie deux fois sur le bouton du module, il doit clignoter 3 fois pour passer en niveau 2. Si on coupe le courant, et qu’on appuie deux fois sur le bouton, il ne reclignotera pas 3 fois. Or si on le fait avec DolphinView, c’est le cas ! Donc ça va avec ce que tu dis au-dessus, à savoir que si le paramétrage est envoyé via DolphinView, le mode répétition est gardé en mémoire même en cas de coupure de courant :+1: Et pourtant sur un module volet roulant Evology 1.3.0.

Pour en avoir le coeur net, je démonterai les trois autres modules à ma disposition pour les inclure dans DolphinView et faire des tests sur le volet qui ne reçoit pas les infos de mon USB300 sans les répétitions des autres volets.

Je vous tiens au courant, mais j’avance là :muscle: Merci beaucoup !

Bonjour @snoopyfb @albino2025
J’avais le même problème que vous et je viens de résoudre enfin ce problème de mode répéteur sur mes modules Avidsen fil pilote !

La solution se trouve ici :

Q22 : d’expérience, il faut parfois faire plusieurs fois la manip d’activation du mode répéteur pour que celui-ci soit pris en compte. Pour s’assurer que c’est bien pris en compte, le niveau de répétition doit être indiqué dans la page santé Enocean, sur la ligne du module concerné.

Je viens de tester et ça marche :relaxed: :
image