Migration RPI3B Jeedom V3, vers RPI4B 64bits Jeedom V4

Tags: #<Tag:0x00007f385124a230>

Bonjour,

Je viens d’acquérir un PI4B 8go, je souhaite migrer mon jeedom qui est en V3 vers le RPI4B et le passer en V4 en 64 bits.

Est ce que le firmware pour booter sur SSD est stable? Oui dois je attendre encore un peu ne pas avoir a changer la conf de FIRMWARE_RELEASE_STATUS=« critical » à FIRMWARE_RELEASE_STATUS=« stable »?
Merci d’avance,
C.

Salut.

  • Coté firmware, stable ou pas, c’est pareil. Le point important c’est plutot le chipset usb de ton ssd.
  • A noter que l’OS 64b (raspios) est en beta, mais de toute façon, tu n’auras pas vraiment le choix si tu veux profiter des 8Go de mémoire, c’est le seul dispo.

Coté procédure, rien de difficile : installation OS, installation Jeedom (V4 très probablement). Restauration backup qui te remet en V3 et remigration V4 de jeedom…
A voir cependant s’il n’est pas plus intéressant de faire une migration jeedom V3 => V4 sur le PI3, de corriger les différents trucs et de restaurer ensuite sur le PI4

justement j’avais pensé l’inverse a savoir migrer jeedom sur le RPI4 regarder ce qui va pas tranquillement et en cas de pb j’aurai juste à rebrancher le RPI3

Alors pour le 8GB pour le boot sur USB il est en beta. du coup je ne sais pas quoi faire…

C.

Les 2 se valent… C’est juste un choix personnel/resenti

Si ça fonctionne (donc que ça boote), tu peux repasser en stable

De ce que j’ai lu le boot par usb ne fonctionne qu’en beta pour la version 8Go.

Du coup je ne sais pas ce qui est le mieux:

Firmware BETA ou non, OS en 32 ou 64 bits?
C’est pour cela que je demande conseil. Un grand merci en tout cas pour l’aide.
C.

Fonctionnement différent entre le 4go et le 8go ? J’ai rien vu de tel, mais je ne me suis pas non plus penché plus que ça sur ce sujet. Le test est facile à faire de toute façon, tant que jeedom n’est pas encore installé

Si tu passes en 32 bits, tu sera limité à 4Go d’utilisation de mémoire… Fonctionner avec 1/2 pi ça me ferai mal par contre

Quand je regarde le post de akenad :

J’ai fait ces commandes pour maj l’eeprom, j’ai donc modifié le fichier et il n’a rien trouvé comme firmware.
Et lorsque je chercher un peu pour l’insant de ce que j’ai trouvé, pour la version 8GB le firmware est en BETA.

C.

ça date du 21 mai, soit avant la version stable du boot USB qui date du 15 juin… la version actuelle est datée du 15 juillet…Pas que les infos soient forcément toutes fausses, mais c’est pas les plus fraîches.

Les question sont donc :

  • tu bootes déjà en USB ? Si oui => quelle version et quelle date…

Si c’est plus récent que le 15 juin, te prends pas la tête, firmware beta ou stable après cette date, ça doit pouvoir booter

Pour info, ici

 sudo rpi-eeprom-update
BCM2711 detected
Dedicated VL805 EEPROM detected
BOOTLOADER: up-to-date
CURRENT: Thu 16 Jul 15:15:46 UTC 2020 (1594912546)
 LATEST: Thu 16 Apr 17:11:26 UTC 2020 (1587057086)
 FW DIR: /lib/firmware/raspberrypi/bootloader/critical
VL805: up-to-date
CURRENT: 000138a1
 LATEST: 000137ad

Bonjour,

Autrement il y a aussi un vidéo faite par @guipom membre de la communauté aussi, tu la trouvera ici qui explique la procédure à suivre en détail

1 J'aime

Voici la version de mon RPI:

BCM2711 detected
VL805 firmware in bootloader EEPROM
BOOTLOADER: up-to-date
CURRENT: vendredi 31 juillet 2020, 13:43:39 (UTC+0000) (1596203019)
 LATEST: vendredi 31 juillet 2020, 13:43:39 (UTC+0000) (1596203019)
 FW DIR: /lib/firmware/raspberrypi/bootloader/stable
VL805: up-to-date
CURRENT: 000138a1
 LATEST: 000138a1

Je vais tester de booter en usb
C.

Je viens de mettre à jour à distance le mien en 138a1 et il boote …

je viens de faire le test, il ne boot pas sur l’usb. il me demande un sd card.
Quand je fais un
Je vais chercher voir si je trouve quelque chose.
EDIT quand je lance la commande vgencmmd bootloader_config:

[all]
BOOT_UART=0
WAKE_ON_GPIO=1
POWER_OFF_ON_HALT=0
DHCP_TIMEOUT=45000
DHCP_REQ_TIMEOUT=4000
TFTP_FILE_TIMEOUT=30000
TFTP_IP=
TFTP_PREFIX=0
BOOT_ORDER=0x1
SD_BOOT_MAX_RETRIES=3
NET_BOOT_MAX_RETRIES=5
[none]
FREEZE_VERSION=0

De ce que j’ai pu trouvé il faut que le boot_order soit à 0f41 et noi il est resté à 0x1
C.

ta du raté quelque chose sur le tuto
il faut effectivement avoir 41 pour que ça tente de booter sur l’usb …

repart sur le tuto @akenad suis le au pied de la lettre exception faite des dates et nom de fichier qui serait plus ressent.

Je viens de reflasher le firmware et maintenant il a la bonne info et ca boot par usb. Maintenant conf de la version 64bits

Un grand merci
C.

Bon be ça c’est une bonne nouvelle … :+1: :+1: :+1:

1 J'aime

Au cas ou tu a même un utilitaire pour copier l’ensemble de ta SD sur le disque …
C’est dans accessoires / SD Card Copier
tu indique la SD en source et ton device disk … START
Youpi

Oui j’ai vu mais j’ai préféré partir sur une fresh install pour éviter les problèmes. JE suis en train de faire les maj. Ensuite je ferai l’installl de jeedom en V4 je restaure le backup V3 et je migre n V4.

un beau programme…
c.

je parlais pas de jeedom …
simplement de la SD avec un OS64 que tu a du faire avant pour remettre tout sur le SSD …

arf… oui trop tard…

Encore merci pour votre aide.
C.

Bonjour @naboleo,

Mon post date du 21 mai dans sa version initiale mais comme la plupart de mes posts je les mets à jour lorsque nécessaire. Il prend bien en compte la version stable du 15 juin.

akenad :slight_smile: