Migration de jeedom 3.3.32 vers la dernière version 4.0.20

Tags: #<Tag:0x00007f385634d6a0>

Bonjour!

J’ai actuellement un jeedom 3.3.32 en cours de fonctionnement et tout configuré.
Je suis en train de me monter un nouveau serveur avec la dernière version de jeedom (4.0.20) qui va remplacer mon ancien serveur.

Je dois donc reprendre toute la configuration d’un serveur à l’autre.
Je viens de tester de faire un backup complet de l’ancienne version vers la nouvelle, mais lors de la restauration, toute mon installation du nouveau jeedom est cassé (je ne vois même plus les menus apparaitre en haut au rechargement de la page).

Est-ce qu’il est possible de récupérer facilement et de faire une migration?

Merci pour votre aide.
Guillaume.

Bonjour,
Il faudrait donner un peu plus de details, comme la version de l’os cible et source, si ya des erreurs dans la restoration, le log http.error aussi par exemple

Jeedom 3.3.32 est sur une debian 8.
Jeedom 4.0.20 est sur une debian 10.

Peut-on vraiment lancer une restauration from scratch avec un backup 3.3.32 sur 4.0.20?

Rien de neuf dans mon error.log de apache.
Je remarque quand même un “Can not copy /var/www/html/jeedom/install/…/core/config/common.config.php”

[START RESTORE]
Début de la restauration de Jeedom 2019-10-08 10:51:43
Envoi l’évènement de début de restauration…OK
Vérification des droits…
OK
Fichier utilisé pour la restauration : /var/www/html/jeedom/core/class/…/…/backup/backup-Jeedom-3.2.11-2019-10-03-14h22.tar.gz
Backup database access configuration…Can not copy /var/www/html/jeedom/install/…/core/config/common.config.php
OK
Disable all task OK
Disable all scenario OK
Décompression de la sauvegarde…
OK
Supprimer la table de la sauvegardeDésactive les contraintes…OK
Supprimer la table : cmd …OK
Supprimer la table : config …OK
Supprimer la table : cron …OK
Supprimer la table : dataStore …OK
Supprimer la table : eqLogic …OK
Supprimer la table : eqReal …OK
Supprimer la table : history …OK
Supprimer la table : historyArch …OK
Supprimer la table : interactDef …OK
Supprimer la table : interactQuery …OK
Supprimer la table : listener …OK
Supprimer la table : message …OK
Supprimer la table : note …OK
Supprimer la table : object …OK
Supprimer la table : plan …OK
Supprimer la table : plan3d …OK
Supprimer la table : plan3dHeader …OK
Supprimer la table : planHeader …OK
Supprimer la table : scenario …OK
Supprimer la table : scenarioElement …OK
Supprimer la table : scenarioExpression …OK
Supprimer la table : scenarioSubElement …OK
Supprimer la table : update …OK
Supprimer la table : user …OK
Supprimer la table : view …OK
Supprimer la table : viewData …OK
Supprimer la table : viewZone …OK
Supprimer la table : widgets …OK
Restauration de la base de données…
OK
Active les contraintes…OK
Restauration du cache…OK
Check jeedom consistency…[START CONSISTENCY]
Suppression de : weather::pull() car il n’y a pas de lancement prévu
Vérifiez les droits sur les fichiers…OK

2019-10-08_10h54_19

Hello,

Question bête, mais as-tu vider ton cache après la MAJ?

La v3 n’est pas compatible debian buster… Il faut être en v4. Mais sinon oui une restoration d’une v3 sur une v4 ca marche

Merci pour vos retours!

Alors pour y arriver finalement, j’ai mis à jour le core automatiquement dans ma version ancienne, j’ai refait un backup que j’ai remis sur la V4 et cela a fonctionné!

Toutefois, je vois que suite à cette migration de backup d’une 3.3.33 dans une 4.0.20 => le système m’indique que mon core est en 3.3.33…

Je ne comprends pas bien, est-ce que cela veut dire que ma version a été downgradé? Je ne peux pas avoir une version 4 avec un backup de la 3? Est-ce que cela va poser problème sous debian 10?

La restoration est complete si tu restore une v3 sur une v4 tu te retrouve en v3 c’est logique…

Ok, en effet, elle est vraiment très complète cette restauration ^^

Je n’ai pas l’air d’avoir un problème pour le moment. Est-ce qu’il faut que je m’attende à avoir un soucis à cause de ma version debian?

Bonjour @gothico,

Pour un besoin de migration JeedomV3 (à partir de 3.3.24) vers Buster/JeedomV4, je recommanderai :

  1. Sauvegarde JeedomV3
  2. Installation Buster
  3. Installation JeedomV3
  4. Restauration JeedomV3
  5. Mise à jour JeedomV4

Voir ici : https://community.jeedom.com/t/2510

akenad :slight_smile:

Huuuumm merci mais du coup, je peux aussi rester en v3.3 ou pas?

Je viens de tenter une bascule en V4 et voilà le résultat :

2019-10-08_12h10_51

Oups :expressionless:

Voir ici : [RTEX] RPi4B - Raspbian Buster Lite - USB SSD

akenad :slight_smile:

J’ai eu le problème, J’ai une VM pour Jeedom Prod et une VM pour Jeedom Dev.
En essayant sur la Dev, comme toi je l’ai cassé plusieurs fois => restauration image VM, retest, rebelote…

Le plus simple (ce que j’ai finalement fait), j’ai détruit ma Jeedom Dev (car je pense avoir corrompu la database en passant vers la V4), et j’ai recréé une Jeedom Dev sur une image de ma VM Jeedom Prod (2 à 3 min maxi)
J’ai ensuite basculé sur le Jeedom Dev et activé la version V4 RC, effectué la mise à jour, updaté les widgets correspondant… et zou, je tourne en V4 sur mon Jeedom DEV depuis quelques jours (v4.021)

Bonjour,
J’ai fait la maj également vers la V4, et je me retrouve avec le même soucis que toi… Est il possible de restaurer l’ancienne version?
Par contre quand je suis sur mon tel, j’arrive à accéder quand même à quelque chose… Mais les plugins n’ont plus l’air de fonctionner… Screenshot_20191027-170625__01
Merci

Bonjour,

Tu ne dis pas quelles versions Debian tu utilises sur tes VMs.
As-tu profité de passer en Buster sur ta nouvelle Jeedom Dev avant de la passer en V4 RC ?

Salut Patdec,

Je suis en Débian 9.7.0
Depuis mon dernier message, RAS, tout fonctionne parfaitement.
JE suis en train de refondre complètement mon Design sans problème particulier

Bonjour,

Quelques nouvelles, j’ai vu faire la mise à jour, mais il a fallu d’abord mettre à jour ma version 3.3 vers 3.3.38 avant de basculer à la V4.

Bonjour,

je suis sous Jeedom 3.3.38 sur un rpi3b+. Je peux passer en V4 sans soucis ?
Si oui, je lance à partir de l’onglet “Core et plugins” ?

Pour info:

A la réception de ma Smart fournie en V 4.0.56 elle était sous debian 10 ( buster )
Après restauration de mon backup en 3.3.39 je suis sous debian 9.4. ( stretch )
Je précise que je n’ai pas downgradé moi même.

Bonjour,

Je suis actuellement en jeedom V3.3.52 avec une smart (zwave-RfxCom et dongle pour BLEA)
Est ce qu’il y a maintenant une possibilité de migration facile vers Jeedom V4 ou faut il encore attendre un peu ?

Re @glenan :wink: ,

A priori une procédure de migration ‹ facile › sera mise en place une fois que la V4 sera officiellement annoncée en stable.

ça ne devrait plus tarder, une communication a été faite envers les devs annonçant une mise à disposition de la V4 en stable en septembre 2020.

2 J'aimes