Lancement d'une radio

Tags: #<Tag:0x00007f282eb2d380>

Bonjour,

Je continue mes mises au propre de mes routines et designs.
Ce matin j’ai constaté un truc bizarre que je n’avais jamais constaté auparavant : si j’exécute une commande pour lancer une radio sur un player, j’ai d’abord une diffusion très courte de la radio, puis une coupure puis la radio démarre correctement.
Cela génère une erreur :
"

alexaamazonmusic Erreur exécution de la commande [Players][ECHO CUISINE Player][Ecouter une radio] : Echec de la requête HTTP : http://192.168.31.51:3456/radio?station=s50486&device=G0911B0592440NUF cURL error : Operation timed out after 3001 milliseconds with 0 bytes received

Citation

Par contre la radio fonctionne.

De quoi cela peut-il provenir ?

Ha ? je vais tester.

Tu as une cURL error et tout de suite derrière la même commande qui fonctionne ? (dans ton log)

Non je lance une seule fois la commande et ca me fait ca

Pardon, je me suis mal exprimé, dans le log, t’as pas deux lignes identiques ? le plugin doit détecter l’échec et renvoyer la commande.

Ah ok, je viens de tester, donc non une seule ligne :

------------------------------------
[2020-04-09 20:44:57][SCENARIO] Start : Scenario lance manuellement.
[2020-04-09 20:44:57][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-04-09 20:44:57][SCENARIO] Exécution de la commande [Players][ECHO CUISINE Player][Ecouter une radio] avec comme option(s) : {"background":"0","select":"s50486"}
[2020-04-09 20:45:07][SCENARIO] Echec de la requête HTTP : http://192.168.31.51:3456/radio?station=s50486&device=G0911B0592440NUF cURL error : Operation timed out after 3000 milliseconds with 0 bytes received
[2020-04-09 20:45:07][SCENARIO] Fin correcte du scénario

La radio se met bien en diffusion par contre après une première micro diffusion.

@Arnaud_Massart
Je n’arrive pas à reproduire ton souci.
Comment lance tu la radio ?
Je lance par le widget et je n’ai aucune erreur.

@sigalou je viens d’essayer, plusieurs méthodes de lancement (scénarios, widget, dashboard, …), plusieurs radios, plusieurs players, j’ai toujours le même phénomène.

J’ai isolé le log, je ne sais pas si çà aidera plus :

[2020-04-11 11:47:18][INFO] : ----Command:*radio* Request:{"select":"s6617","utid":"1586531713341"}
[2020-04-11 11:47:18][INFO] : Request : http://192.168.31.51:3456/radio?station=s6617&device=G090QU06819603KN
[2020-04-11 11:47:28][ERROR] : Erreur exécution de la commande [Players][ECHO SALON Player][Ecouter une radio] : Echec de la requête HTTP : http://192.168.31.51:3456/radio?station=s6617&device=G090QU06819603KN cURL error : Operation timed out after 3001 milliseconds with 0 bytes received
[2020-04-11 11:47:39][INFO] : ----Command:*command* Request:{"utid":"1586531713341"}
[2020-04-11 11:47:39][INFO] : Request : http://192.168.31.51:3456/command?command=pause&device=G090QU06819603KN

Ça, ça n’a rien à voir, c’est que tu as appuyé sur Pause.

http://192.168.31.51:3456/radio?station=s6617
Ca c’est la bonne commande qui lance la radio. Et je ne comprends pas pourquoi tu as une réponse " cURL error" ?! Comme si le serveur n’avait jamais eu la commande mais la radio se lance.

Je vais vérifier s’il n’y a pas un souci d’accusé de réception sur la commande radio. Ca si elle fonctionne, je ne m’en suis peut etre pas rendu compte.

Lance http://192.168.31.51:3456/radio?station=s6617&device=G090QU06819603KN dans ton navigateur pour voir si t’as une réponse stp ?!

J’ai testé, j’ai bien un OK avec mon ip et mon device :

image

J’ai bien le ok également depuis le navigateur.

Alors c’est que tu as bien un accusé de réception, je ne comprends vraiment pas, surtout je n’arrive pas à reproduire l’erreur.

Je suis arrivé à avoir l’erreur en lançant un groupe (et non un device)

[2020-04-11 18:39:35][INFO] : Request : http://192.168.0.21:3456/radio?station=s2960&device=e8c0d0d753744383bf0af603b49bc154
[2020-04-11 18:39:45][ERROR] : Erreur exécution de la commande [Musique][Tous les appareils Player][Ecouter une radio] : Echec de la requête HTTP : http://192.168.0.21:3456/radio?station=s2960&device=e8c0d0d753744383bf0af603b49bc154 cURL error : Operation timed out after 3001 milliseconds with 0 bytes received

1 J'aime

Effectivement j’ai d’abord constaté sur un groupe mais ça me fait la même chose sur un player isolé.

@Arnaud_Massart @sigalou

Hello, j’ai exactement le même soucis lorsque je lance une radio sur un player, en revanche je n’ai jamais testé avec un groupe.
Je suis en Jeedom V3 à jour et Plugin Alexa-Api à jour (beta)

@+

T’es en V3 ou en V4 ? peut-être une piste

Je suis en V4

ha zut, donc indépendant de la version, je cherche dès que je peux

1 J'aime

Salut, ce problème est toujours existant chez moi, malgré les reinstallations et les nouvelles versions.

@Ricardo et chez toi ?

J’ai poussé les dernières mises à jour et corrigé mille trucs qu’a amélioré Amazon et du coup qu’il fallait que je reprenne. C’est fait, beta validée et stable poussée.

Je peux m’intéresser à ton souci, tu me fais un résumé ? à la rigueur sous forme de déroulé (faire ceci, cliquer là, puis ici…) à tester pour voir ce que ça fait chez moi. Si je constate un souci, cela vient du plugin et pas de chez toi.