Installation de Raspberry Pi OS et Jeedom sur Pi 3B+ sur un disque SSD mSata

Tags: #<Tag:0x00007f242fe871a0> #<Tag:0x00007f242fe870d8>

5 messages ont été scindés en un nouveau sujet : Erreur dans un scénario avec Kodi

Attention en modifiant gpu_mem !

Si vous utilisez le codec h264_omx avec ffmpeg, il faut au moins gpu_mem=128

(Par exemple avec homebridge_camera_ffmpeg)

1 J'aime

Bonjour,

Bonne remarque, je vais modifier le tutoriel pour cela.

  • Question : même s’il n’y a pas d’écran ?

Oui le gpu est utilisé pour le transcodage :slight_smile:

Bonjour,

Merci pour ce super tutoriel, simple et efficace.
Si je souhaite utiliser le port GPIO pour brancher une carte EnOcean TCM310… Doit on rajouter quelque chose.
Je suis sur RPi3B (mais pas +) avec Buster lite sur SSD…et Jeedom V4.
Installation nouvelle en suivant le tutoriel mais difficultés parès avec l’utilisation du plugin EnOcean.
En d’autres termes comment savoir si ma carte est correctement branchée et opérationnelle…

Merci d’avance.

1 J'aime

Merci Fabrice pour ce tuto parfait qui m’a été fort utile ! Et quelle simplicité avec Raspberry Pi Imager …

1 J'aime

Bonjour.

Il faut certainement désactiver le bluetooth interne du Raspberry pi pour utiliser l’uart du Gpio.

2 messages ont été scindés en un nouveau sujet : Impossible de lancer le Deamon du plugin

bonjour pour le SSD sur pi 3b je le formate en exfat ou ntfs
merci

Salut,
Pas besoin de le formater si tu mets une image neuve dessus qui va donc te refaire le partitionnement (et le formatage).

2 J'aimes

Petite question si vous avez une idée.
Ça fonctionne sur le SSd en USB.
Par contre j’ai un hub USB avec alimentation sur lequel je branche ma clef zwave, si celui-ci est connecté impossible de booter, je dois le débrancher le temps que le boot se fasse puis je peux alors le débrancher et tout fonctionne.

Bonsoir,

Il faut tester ce qui suit :
Formatez une carte MicroSD en FAT et placez y dessus le fichier : bootcode.bin

Cette carte MicroSD doit être présente dans le Pi pour le boot.

1 J'aime

Ça fonctionne impec merci !

Bonjour à tous et merci pour le tuto !

Je l’ai suivi pour passer d’une installation qui avait un peu plus d’un an sur un rpi 3b+ sous une ancienne version de raspbian (Stretch) et en V3.

Pour passer sur un SSD en Msata, sur une installation « propre » de Buster + Jeedom V4

J’ai bien suivi le tuto (et donc, je pensais installer Jeedom V4)

Au lancement de Jeedom, j’ai changé le mot de passe admin comme demandé, renseigné mes id du market, puis j’ai tout de suite envoyé et restaurer ma sauvegarde Jeedom.

J’ai rebooter, installé les dépendances zwave etc… et tout fonctionne bien.

MAIS je vois que Jeedom est en V3 (3.3.53)

Du coup je ne sais pas si j’ai mal compris ou raté un truc :

En suivant le tuto je pensais installer la V4, puis restaurer mes objets, scénarios etc depuis ma sauvegarde V3 (sur cette nouvelle V4), ce n’est pas le cas ?

Du coup je ne sais pas ce qui fait que je sois en V3, est-ce à l’installation ? (pourtant j’ai l’impression que le script https://raw.githubusercontent.com/jeedom/core/master/install/install.sh installe la V4)

Ou est-ce que c’est la restauration de mon backup qui restaure également la version de Jeedom ?

Si c’est le cas, je n’avais pas compris le principe, et je me pose la question de comment restaurer tout le reste sauf ça ?

Bonjour,

Votre message est un peu hors sujet ici.

Comme vous l’avez constaté, une installation de Jeedom est nativement réalisée dans la branche « Stable » (ou Master) et aujourd’hui, c’est bien la version v4.0.61.
Mais, si vous restaurez, vous restaurez dans la version de la sauvegarde (c’est ce que l’on attend d’une sauvegarde, sinon cela n’en est pas une…)

Une restauration de Jeedom est intègre, c’est à dire que la restauration de Jeedom repasse Jeedom dans la version incluse dans la sauvegarde (mais Jeedom (le programme) ne touche pas à la partie OS).

Donc, ce qui vous arrive est normal mais surtout logique.

Pour passer en v4 maintenant, il faut migrer votre version de Jeedom en v4.

1 J'aime

Bonjour

Et c’est très bien comme ça !

salut je profite de ce tuto pour poser ma question je viens d’installer jeedom sur un pi 4 raspbian pi os buster connecté en ethernet , j’ai axx au ssh sur la bonne ip mais quand j’essaye de joindre jeedom sur cette ip dans mon navigateur il semble que la page soit inexistante .

auriez vous des idées ? jeedom doit il obligatoirement etre en wifi ?

Bonjour,
Ce tuto a été utilisé pas de nombreuses personnes sans problème.
Si tu as accès à ton RPI en ssh, c’est probablement que ta Jeedom est mal installée.
Je te conseille de refaire l’installation complète en la suivant scrupuleusement.
Bonne journée.

Je confirme.
Je viens de terminer le tuto et c’est OK pour moi.

Bonjour,

C’est un peu hors sujet ici :
Et nul par il est écrit que le WIFI est obligatoire. Ce qui est obligatoire, c’est d’avoir une connexion à l’Internet pour réussir l’installation de Jeedom.
Donc soit une connexion en Ethernet (plus fiable), soit une connexion Wifi.