Google Home Local Installation dépendances NOK

Tags: #<Tag:0x00007fa7a6e69510>

Bonjour
J’ai acheté le plugin Google Devices mais n’arrive pas à l’installer. Les dépendances sont en échec avec un status NOK:

Début de l'installation
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
adb est déjà la version la plus récente (1:8.1.0+r23-5).
golang-go est déjà la version la plus récente (2:1.11~1).
jq est déjà la version la plus récente (1.5+dfsg-2+b1).
python3-pip est déjà la version la plus récente (18.1-5).
python3-dev est déjà la version la plus récente (3.7.3-1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
python3-asn1crypto python3-cffi-backend python3-entrypoints
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 34 non mis à jour.
Requirement already satisfied: gpsoauth in /usr/local/lib/python3.7/dist-packages (0.4.3)
Requirement already satisfied: requests in /usr/local/lib/python3.7/dist-packages/requests-2.25.1-py3.7.egg (from gpsoauth) (2.25.1)
Requirement already satisfied: pycryptodomex>=3.0 in /usr/local/lib/python3.7/dist-packages (from gpsoauth) (3.10.1)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests->gpsoauth) (2018.8.24)
Requirement already satisfied: chardet<5,>=3.0.2 in /usr/lib/python3/dist-packages (from requests->gpsoauth) (3.0.4)
Requirement already satisfied: idna<3,>=2.5 in /usr/lib/python3/dist-packages (from requests->gpsoauth) (2.6)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/lib/python3/dist-packages (from requests->gpsoauth) (1.24.1)
Requirement already satisfied: gTTS in /usr/local/lib/python3.7/dist-packages (2.2.2)
Requirement already satisfied: requests in /usr/local/lib/python3.7/dist-packages/requests-2.25.1-py3.7.egg (from gTTS) (2.25.1)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from gTTS) (1.12.0)
Requirement already satisfied: click in /usr/local/lib/python3.7/dist-packages (from gTTS) (7.1.2)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests->gTTS) (2018.8.24)
Requirement already satisfied: chardet<5,>=3.0.2 in /usr/lib/python3/dist-packages (from requests->gTTS) (3.0.4)
Requirement already satisfied: idna<3,>=2.5 in /usr/lib/python3/dist-packages (from requests->gTTS) (2.6)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/lib/python3/dist-packages (from requests->gTTS) (1.24.1)
running install
running bdist_egg
running egg_info
writing catt.egg-info/PKG-INFO
writing dependency_links to catt.egg-info/dependency_links.txt
writing entry points to catt.egg-info/entry_points.txt
writing requirements to catt.egg-info/requires.txt
writing top-level names to catt.egg-info/top_level.txt
reading manifest file 'catt.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no files found matching 'HISTORY.rst'
warning: no previously-included files matching '__pycache__' found under directory '*'
warning: no previously-included files matching '*.py[co]' found under directory '*'
warning: no files found matching '*.rst' under directory 'docs'
warning: no files found matching 'conf.py' under directory 'docs'
warning: no files found matching 'Makefile' under directory 'docs'
warning: no files found matching 'make.bat' under directory 'docs'
warning: no files found matching '*.jpg' under directory 'docs'
warning: no files found matching '*.png' under directory 'docs'
warning: no files found matching '*.gif' under directory 'docs'
writing manifest file 'catt.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build/bdist.linux-x86_64/egg
creating build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/cli.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/error.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/subs_info.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/util.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/controllers.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/__init__.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/api.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/http_server.py -> build/bdist.linux-x86_64/egg/catt
copying build/lib/catt/stream_info.py -> build/bdist.linux-x86_64/egg/catt
byte-compiling build/bdist.linux-x86_64/egg/catt/cli.py to cli.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/error.py to error.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/subs_info.py to subs_info.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/util.py to util.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/controllers.py to controllers.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/__init__.py to __init__.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/api.py to api.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/http_server.py to http_server.cpython-37.pyc
byte-compiling build/bdist.linux-x86_64/egg/catt/stream_info.py to stream_info.cpython-37.pyc
creating build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/entry_points.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/not-zip-safe -> build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/requires.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying catt.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
creating 'dist/catt-0.11.3-py3.7.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing catt-0.11.3-py3.7.egg
removing '/usr/local/lib/python3.7/dist-packages/catt-0.11.3-py3.7.egg' (and everything under it)
creating /usr/local/lib/python3.7/dist-packages/catt-0.11.3-py3.7.egg
Extracting catt-0.11.3-py3.7.egg to /usr/local/lib/python3.7/dist-packages
catt 0.11.3 is already the active version in easy-install.pth
Installing catt script to /usr/local/bin
Installed /usr/local/lib/python3.7/dist-packages/catt-0.11.3-py3.7.egg
Processing dependencies for catt==0.11.3
Searching for requests==2.25.1
Best match: requests 2.25.1
Processing requests-2.25.1-py3.7.egg
requests 2.25.1 is already the active version in easy-install.pth
Using /usr/local/lib/python3.7/dist-packages/requests-2.25.1-py3.7.egg
Searching for ifaddr==0.1.7
Best match: ifaddr 0.1.7
Adding ifaddr 0.1.7 to easy-install.pth file
Using /usr/local/lib/python3.7/dist-packages
Searching for click==7.1.2
Best match: click 7.1.2
Adding click 7.1.2 to easy-install.pth file
Using /usr/local/lib/python3.7/dist-packages
Searching for PyChromecast==6.0.0
Best match: PyChromecast 6.0.0
Processing PyChromecast-6.0.0-py3.7.egg
PyChromecast 6.0.0 is already the active version in easy-install.pth
Using /usr/local/lib/python3.7/dist-packages/PyChromecast-6.0.0-py3.7.egg
Searching for youtube-dl==2021.3.14
Best match: youtube-dl 2021.3.14
Processing youtube_dl-2021.3.14-py3.7.egg
youtube-dl 2021.3.14 is already the active version in easy-install.pth
Installing youtube-dl script to /usr/local/bin
Using /usr/local/lib/python3.7/dist-packages/youtube_dl-2021.3.14-py3.7.egg
Searching for urllib3==1.24.1
Best match: urllib3 1.24.1
Adding urllib3 1.24.1 to easy-install.pth file
Using /usr/lib/python3/dist-packages
Searching for idna==2.6
Best match: idna 2.6
Adding idna 2.6 to easy-install.pth file
Using /usr/lib/python3/dist-packages
Searching for chardet==3.0.4
Best match: chardet 3.0.4
Adding chardet 3.0.4 to easy-install.pth file
Installing chardetect script to /usr/local/bin
Using /usr/lib/python3/dist-packages
Searching for certifi==2018.8.24
Best match: certifi 2018.8.24
Adding certifi 2018.8.24 to easy-install.pth file
Using /usr/lib/python3/dist-packages
Searching for zeroconf==0.28.8
Best match: zeroconf 0.28.8
Adding zeroconf 0.28.8 to easy-install.pth file
Using /usr/local/lib/python3.7/dist-packages
Searching for protobuf==3.14.0
Best match: protobuf 3.14.0
Adding protobuf 3.14.0 to easy-install.pth file
Using /usr/local/lib/python3.7/dist-packages
Searching for casttube==0.2.1
Best match: casttube 0.2.1
Adding casttube 0.2.1 to easy-install.pth file
Using /usr/local/lib/python3.7/dist-packages
Searching for six==1.12.0
Best match: six 1.12.0
Adding six 1.12.0 to easy-install.pth file
Using /usr/lib/python3/dist-packages
Finished processing dependencies for catt==0.11.3
# google.golang.org/grpc/xds
/root/go/src/google.golang.org/grpc/xds/server.go:207:10: undefined: strings.ReplaceAll
# google.golang.org/grpc/xds
/root/go/src/google.golang.org/grpc/xds/server.go:207:10: undefined: strings.ReplaceAll
Fin de l'installation

Je ne comprends pas ce qu’il ne fonctionne pas.

Pour information mon jeedom est en 4.1.20 il tourne sur un Debian 10x64 en VM esxi. Le plugin est en 2021-03-14 01:03:09

Pouvez vous m’aider svp ? je n’ai pas trouvé de solution dans ma recherche de cas similaires sur le forum.

Mercii

Bonjour

Je me permets de faire remonter ce problème.

Quelqu’un peut il m’aider ?

Cordialement,

Bonjour

Ce plugin Payant est il mort ? si c’est le cas, c’est frauduleux de le vendre, sinon comment avoir un support ?

Sur un plugin gratuit je dis rien, mais en général quand on paye on est en droit d’avoir son produit non ?

Payant ou gratuit, un plugin non maintenu est tout aussi frauduleux.
Belle mentalité que de se croire en droit de réclamer de l’aide parcequ’on a payer meme pas le prix d’un kebab.

Si pas de réponse => chercher ce qu’il manque au lieu de faire +1, +1 avec menaces, + ticket en mode pleurs

Bonjour

Comme je l’ai écrit, je n’ai pas trouvé de réponse à ce problème sur le forum, sinon j’en serais pas là.

Cdt.

T’as pas trouvé de réponses ? T’as peut être mal cherché, parceque déjà si tu cherches vraiment sur le forum tu y trouves que tu ments en disant que le plugin n’est pas maintenu et ne fonctionne pas.

Alors : as-tu vraiment chercher ? ou mens-tu en pleine conscience ?

Pareil, t’as pas du allez bien loin dans l’usage du plugin, les dépendances servent à une fonctionnalité uniquement sur tout l’ensemble.
C’est un peu comme dire qu’une voiture ne fonctionne pas parceque tu n’arrives pas à ouvrir le toit ouvrant.

Bref, forum communautaire, la démarche de cracher sur les efforts des devs avec la menace du payant n’apporte rien. Pas plus que les +1 sans essayer de fournir plus d’infos (source première de l’absence de réponse)

PS : je suis sur Debian X86 et je me sers quotidiennement du plugin, donc il marche. Et je suis pas le seul.

Tout est dit :frowning_face:

Bonjour,

Je vais tenter de vous aider, mais je n’ai pas ce plugin
- En 1er, s’il y a une mise à jour du plugin, installez-là.

Relancez de nouveau les dépendances et mettez de nouveau le log de celle-ci ici.

Quand je vois le même constat que vous sur le forum, c’est aussi des utilisateurs qui sont en 64 bits. Je ne pense pas qu’il y a un lien.

Avez-vous aussi le journal de log du plugin, en mode debug (des utilisateurs semble avoir eu des problèmes de token (login/mdp incorrect).

Voir Ghlocal PLUGIN Dépendances NOK

1 J'aime

Merci @Fabrice et @jpty . Je vais suivre ce post.