Fil de discussion du [TUTO] Utiliser Valetudo RE et le contrôler via MQTT

Très intéressant merci :+1:

CAR, je ne supporte plus la rotation de la carte sur le v1 et l’influence que cela a sur mes zones prédéfinis…

Tu confirmes que l’on peut fixer cette carte et donc les zones ?
Que ce passe t’il en cas d’erreur de nettoyage du robot ? La carte est réinitialisée ?

Wow merci pour le tuto
j’ai un roborock v1 et le fait de me passer du cloud me trotte la tete depuis un moment.

Bon il faut que je trouve un pc sous linux (et du temps) pour me lancer
vivement la suite du tuto

Merci pour vos réponses, c’est encourageant, j’essaie de commencer la suite du tuto dans la journée, mais je ne connait pas encore parfaitement MQTT, alors j’y vais a taton :wink:

@Theking31 Pour l’instant j’utilise Valetudo depuis seulement 2 jours, alors pour le coup je ne peux pas te dire pour la rotation de la carte, ce que je sais par contre c’est que les zones sont très faciles a gérer, et même a modifier, si vraiment il devait y avoir une rotation de ta carte il faut moins de 5 minutes pour remettre toutes tes zones en place, pas besoin de chercher les coordonnées etc :wink:
Pour le reste le firmware de base est la dernière version officielle (1886) donc le robot va agir de la même manière, que ce soit pour la navigation, les erreurs éventuelles etc, d’ailleurs en bidouillant avec les infos qu’il m’envoie en mqtt j’ai remarqué un topic “errorDescription”, donc je vais gratter un peu pour voir si il peut détailler l’erreur (Problème de capteur laser, brosse principale bloquée, roues bloquées etc … je veux voir si il envoie des infos différentes dans ces cas précis)
Donc en cas d’erreur comme avant il attend sur place que tu le débloques, et une fois débloqué il reprend son travail … ce que je n’ai pas testé c’est la batterie faible pour savoir si il allait se charger avant de reprendre ou il en était, mais encore une fois la base du firmware étant la même il n’y a pas de raison :slight_smile:
Pour finir sur la réinitialisation de la carte ce que j’ai essayé en Valetudo 0.4.0 c’est de le mettre dans une pièce qu’il n’avait pas encore découverte et le lancer, il a créé une nouvelle carte, et quand je l’ai remis dans son environnement habituel il a retrouvé la carte … a voir si on peut le reproduire ou si c’etait un coup de chance, dans tous les cas le fork Valetudo RE propose lui de sauvegarder plusieurs cartes si besoin …

@Neji Merci :slight_smile: un vieux PC portable avec une carte wifi et un USB live (je ne sais pas si ça se fait encore mais Ubuntu proposait de démarrer directement sur la clé sans installer l’OS il me semble) et c’est parti :wink:

Je suis trop fan merci beaucoup pour ce tuto je ne connaissais même pas l’existence de ce firmware, aussitôt lu aussitôt installé.
Par contre je suis particulièrement friant pour le mqtt j’attends avec impatiente ton tuto là dessus j’ai réussi a l’inclure dans jmqtt par contre je ne connais pas les commande pour faire appel au nettoyages de zones.

@TiTom_59 Merci du retour, désolé pas eu le temps de continuer le tuto du coup, mais si tu as réussi a le faire remonter dans jmqtt voilà comment avoir les commandes de zones et go_to :

Topic :
valetudo/rockrobo/custom_command

“Valeur” pour la commande de zone, ou de zones multiples :
{"command":"zoned_cleanup","zone_ids":["Nom de la zone dans valetudo","nom de la seconde zone si besoin","5 zones max"]}

Valeur pour la commande Go To : {"command":"go_to","spot_id":"Nom du point Goto dans valetudo"}

T’es au top merci beaucoup.

Édit: tu a modifié de quelle manière le fichier du robot car c’est surtout préconfigurés pour Home assistant.

@TiTom_59 J’ai utilisé l’editeur de texte nano en ssh pour modifier config.json comme suit :

nano /mnt/data/valetudo/config.json

  "mqtt": {
    "enabled": true,
    "identifier": "rockrobo",
    "topicPrefix": "valetudo",
    "autoconfPrefix": "jeedom",
    "broker_url": "mqtt://192.168.1.28",
    "provideMapData": true,
    "mapSettings": {
      "drawPath": true,
      "drawCharger": true,
      "drawRobot": true,
      "border": 2,
      "scale": 4
    }
  },
  "dummycloud": {
    "spoofedIP": "203.0.113.1",
    "bindIP": "127.0.0.1"
  },
  "httpAuth": {
    "enabled": false,
    "username": "valetudo",
    "password": "valetudo"
  },
  "allowSSHKeyUpload": true,
  "map_upload_host": "http://127.0.0.1"
}

Pour le broker URL change le bien pour ton broker, ou si tu n’en a pas pour l’URL de ton jeedom et crée un broker sous JMQTT

Ctrl+x pour sauvegarder, et Y pour valider il me semble

Attention par contre si tu as déjà créé des zones et des points go to ils sont aussi présents dans ce fichier, si tu les supprimes il faudra recommencer :slight_smile:

Après avoir modifié le fichier j’ai lancé une commande reboot mais je ne suis pas certain que ce soit nécessaire

Encore une fois je ne suis pas développeur, j’ai modifié le fichier config a taton parce que je n’y connait rien, ça fonctionne parfaitement chez moi, mais il se peut que ce ne soit pas le plus optimisé du monde, si il y a mieux n’hésitez pas a partager :wink:

Oui c’est bien ce que j’ai fait donc j’ai eu la même logique en faite je te demande surtout parce sous jmqtt ça me créer plusieurs topic, et dans l’équipement quand je veux afficher le json la roue cranté tourne sans cesse je vais revoir mon config.json du robot merci encore .

Désolé pas mal de boulot ces derniers jours je devrais avoir le temps de terminer tout ca Lundi ou Mardi :wink:

1 J'aime

Pour info j’ai tenté le fork valetudo RE je le trouve plus complet et en français, je trouve ça fun aussi de pouvoir le gérer avec telegram.
A bon entendeur

Très intéressant et très bien détaillé :slight_smile:

Good job!

merci pour le tuto
je l’ai enfin installé, c’est top !

par contre, bien que j’ai modifié le config.json je n’arrive pas à l’inclure ds jmqtt :frowning:

edit : je me rend compte qu’a chaque reboot et modif des paramètres, mon config.json réinitialise le paramètre mqtt :weary:

edit 2 : c’est bon j’ai lancé la commande service valetudo restart :slight_smile:

1 J'aime

J’arrive à avoir les infos via mqtt
lancer les commande de bases
mais j’aimerai bien avoir ton tuto mqtt pour en savoir plus et aller plus loin :slight_smile:

Oui je suis vraiment désolé je ne me suis pas penché dessus depuis la première partie du tuto, du coup même chez moi je n’ai pas terminé la configuration, mais avec ces 2 semaines de confinement a la maison je devrais trouver le temps (et le courage :innocent:) nécessaire pour terminer tout ça :wink: c’est pas compliqué c’est juste un peu chiant a mettre en place :slight_smile:

Je te remercie, et finalement en cherchant, j’ai trouvé les commandes pour lancer l’aspi !
Vraiment au top ce Valetudo ! merci pour la découverte.

Sais tu si via MQTT, il y a moyen de récupérer la map ?

Dommage que cela soit sous LInux :frowning:

j’ai utilisé un live usb débian sur mon pc portable :slight_smile:

Tu as un lien stp que je regarde ce que c’est ? Merci :slight_smile:

bon j’ai la poisse, impossible de flasher ce p***** de fwm .

J’ai tout (fwm, token, …) mais quand lance l’update j’ai ça

Going to update from /home/pi/roborock/v11_003468.pkg
INFO:miio.updater:Serving on 0.0.0.0:34501, timeout 10
INFO:miio.updater:Using local /home/pi/roborock/v11_003468.pkg (md5: 6201ff1d70e3a9bb34764c8f92ad3b4a)
Hosting file at http://192.168.8.233:34501/v11_003468.pkg
Update started!
  0%|                                                                                                                             | 0/100 [00:05<?, ?it/s]
ERROR:miio.updater:No request was made..

ça cause chinois mais ça reste à 0

ça m’énerve !

Avec le recule, as tu observé la rotation de carte ?