Diagnostique jeedom figé tres lent sur rpi4

Tags: #<Tag:0x00007f282d720bf8>

Bonjour,
J’ai une install jeedom assez recente (2 mois) et assez peu chargée en plugin / scenario. rien d’exotique.
Il est lent, jusqu’à se figer (grosse roue dentée sur fond gris). je ne sais pas si c’est un pb de charge (1 scénario qui boucle ?) ou si ce n’est pas qu’un pb l’affichage des pages.
Quels sont les diag qui permettent d’isoler ce type de pb?
je joins déjà une capture de « santé » (tt au vert)
Merci d’avance pour votre aide
Annotation 2020-06-21 082855

En complément: pendant que l’interface est figée (ca peut durer plusieurs minutes) les scénario fonctionnent toujours (j’ai pu le vérifier avec un interrupteur en 433Mhz qui allume une ampoule pilotée par un inter z-wave)

Bonjour @jflycee,

Alors déjà dans la page santé il serait bon de réduire ton swapiness et d’augmenter ton swap disponible.

Pour configurer le swapiness connecte toi en ssh et tape les commandes suivante:

sudo nano /etc/sysctl.conf
Ajouter la ligne et sauvegarder:
vm.swappiness = 10 

Pour configurer le swap toujours en ssh:

sudo nano /etc/dphys-swapfile
Trouvez la ligne avec le paramètre :
CONF_SWAPSIZE=100
Et changez la valeur de CONF_SWAPSIZE à 1024
Sauvegarder

Enfin pour finir toujours en ssh:

sudo swapoff -a && swapon -a
sudo reboot

Cela devrait déjà dans un primer temps améliorer les choses.

Dernière question tu es sur quel type de support ? (microSD, SSD, autre ?)

Merci pour cette piste que je vais explorer tt de suite.
J’avais bien pensé au swap parce qu’au moment de l’Install il était en rouge mais cette alerte avait disparue. Je sais ce qu’est le swap sur windows mais sur le rpi je ne comprend pas bien, cette architecture reste encore assez occulte pr moi…
Bon we

1 J'aime

Mon install est sur ssd

OK, une fois les modif fini tiens nous informé :wink:

J’ai fait les modif… toujours des blocages…
D’autres constatations qui pourraient donner d’autres pistes: j’ai l’impression (pas facile d’etre certain parce que le blocage n’est pas reproductible) que je n’ai pas ces blocages en connexion locale mais uniquement en passant par le dns.jeedom… mais ce n’est pas un pb de mon reseau local parceque j’ai un autre jeedom (sur smart celui la) qui fonctionne normalement…
je vais essayer sur le 2e dns (eu.jeedom.link)

Annotation 2020-06-21 105202

Ca ne serait pas soit ton navigateur ou un autre soft sur ton ordi qui ralenti (jusqu’à bloquer) l’interface de jeedom?
Vérifie anti-virus, extension…

1 J'aime

Les symptômes m’ont également fait penser à un probleme du navigateur… mais aucun pb avec mon autre jeedom (sur smart).
Mes derniers essais, en me connectant en local ou en passant sur le 2e DNS (eu.jeedom.link), semblent ok… est il possible que le probleme vienne du dns.jeedom.com ?

Ce n’est pas impossible mais pas assez d’info pour des conclusions.
Tu peux aussi regarder l’onglet réseau dans les outils dev (f12) et vérifier si certaines requêtes prennent du temps où ne répondent pas.

Hello,
Rien de compliqué dans le principe, le swap est la partition de ton disque dur ou ton système écrit ce qu’il n’a plus la place de mettre en RAM.
Quand ta RAM est pleine il écrit dans le swap (mais c’est plus lent forcement).
Swapiness est le niveau de RAM restante à partir duquel le système écrit dans le swap.
Swapiness=10% veut dire que tu n’écriras dans le swap que quand ta RAM restante sera tombée sous les 10%

oui, le swap en lui m je connais, je crois me rappeler ce type de manip sous dos… c’est linux mon handicap… je n’arrive pas à m’y mettre…les fichiers de config restent obscur, le système de droit m’agace…
Pour en revenir à mon probleme, mon soupçon se porte d e+ en + sur le DNS1.jeedom.com
Je n’ai pas observé de ralentissement ni en local ni en passant par le eu.jeedom.com
Quelqu’un a t il déjà observé ce pb? cela vaut il le coup d’initier une nouvelle discussion?

Salut,

L’idée de @Mips (F12 pour avoir les traces) est bonne dans ce cas là.
Tu fais la manip via le DNS et en local, il suffira de comparer les résultats

copie d’ecran (c’est ca que vous me conseillez ?) après avoir demandé l’affichage des logs dans jeedom… l’une connecté avec le DNS1 , autre avec le EU… ça semble confirmer que l’un est rapide, l’autre lent… (peu lisible pr moi ). Y a t il un moyen de corriger chez moi pu uniquement pb coté jeedom SA ?
Je peux simplement ne pas utiliser le DNS1 mais ca ne fait pas "avancer la sciencedns1 dnseu " :wink: