Démon Ewejee ne se lance pas

Tags: #<Tag:0x00007fcb9c9c9338>

Bonjour et bonne année et surtout bonne santé ! #phraseDeVieux :stuck_out_tongue_winking_eye:

Nouveau sur Jeedom depuis 2 semaines, je découvre …
Mon pb ? Le démon de Ewejee :thinking: il reste en NOK

Voila la config « matériel » :
Installation sur un NAS QNAP 653-A en virtualisation
(VM Debian 9 / 2 cores / 1Go RAM / Intel Core i7)

La config Jeedom :
Capture

La conf Ewejee :
Capture

  • Non et non ( accès interne bloqué et état binaire )

Logs :

[2021-01-06 15:07:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-06 15:07:53][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:07:55][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:08:03][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:08:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-06 15:09:03][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:09:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-06 15:10:05][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:10:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-06 15:10:06][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-06 15:10:06][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-06 15:10:06][INFO] : Lancement du démon.
[2021-01-06 15:11:03][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:11:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-06 15:11:36][DEBUG] : Demon LAN nok, server =
[2021-01-06 15:11:38][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
======================================================================
== 06/01/2021 11:29:04 == Installation des dépendances de ewejee
======================================================================
[  0% ] : Vérification des droits...
[  9% ] : Vérification des droits : [  OK  ]
[ 10% ] : Prérequis...
[ 19% ] : Prérequis : [  OK  ]
[ 20% ] : Mise à jour APT et installation des packages nécessaires...
[ 29% ] : Mise à jour APT et installation des packages nécessaires : [  OK  ]
[ 30% ] : Vérification de la version de NodeJS installée...
Version actuelle : v12.20.0
Ok, version suffisante
[ 49% ] : Vérification de la version de NodeJS installée : [  OK  ]
[ 50% ] : Nettoyage anciens modules...
[ 59% ] : Nettoyage anciens modules : [  OK  ]
[ 60% ] : Installation de ewejee, veuillez patienter svp, installation très longue...
[ 64% ] : Installation de ewejee, veuillez patienter svp, installation très longue : [  OK  ]
[ 65% ] : Installation des dépendances......
[ 89% ] : Installation des dépendances... : [  OK  ]
[ 90% ] : Nettoyage 1/2...
[ 94% ] : Nettoyage 1/2 : [  OK  ]
[ 95% ] : Nettoyage 2/2...
[ 99% ] : Nettoyage 2/2 : [  OK  ]
[100% ] : Terminé !
======================================================================
== OK == Installation Réussie
======================================================================
Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).
Création à
/var/www/html/plugins/ewejee/resources/lan
Suppression des fichier arp et deviceip
rm: cannot remove 'arp-table.json': No such file or directory
rm: cannot remove 'deviceip-table.json': No such file or directory
*************************** LS ***************************
getIP.sh
lan.sh
lanmode.txt
lib
working.txt
*************************** LS ***************************
Recherche d équipement sur le réseau local pendant 30 secondes ...
Si plusieurs reseaux :
192.168.1
Réseau utilisé par défaut :
192.168.1
Wake up devices...
192.168.1
Wait for devices to respond...
/var/www/html/plugins/ewejee/resources/lan
Recherche d équipement sur le réseau local terminé ...
Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).

Voila, jusque là, c’est le seul plugin qui me résiste et je n’ai rien trouvé sur le net ni ici ( désolé si c’est le cas ). Une piste ?

Merci
Guy

Bonsoir Guy,

Pense à migrer sous buster et abandonne stretch

https://blog.jeedom.com/5016-autour-de-jeedom-en-decembre-2020/

Hello,

Il me faudrait le seul log que tu n’a pas mis :rofl:

eWeJee_node

Je pourrais voir ce qui cloche

Ahhh désolé je suis en 10.7 oups, pb de VM, j’ai pas sélectionné la bonne pour sortir ça. Je vais de ce pas me rouler dans les orties :crazy_face:

Le fichier est vide … je recommence : désinstallation, reboot, instal, debug … à tout à l’heure

Voici les logs ( et les 4 cette fois ) en post install. je n’ai fait qu’installer le pluggin et lancer les dépendances. Je n’ai pas saisi mes ID Ewelink :

[2021-01-07 00:06:00][DEBUG] : Lancement de : /var/www/html/core/class/../../core/php/jeePlugin.php  plugin_id=ewejee function=install callInstallFunction=1
[2021-01-07 00:06:01][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 00:11:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 00:11:06][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:06][INFO] : Installation des dépendances
[2021-01-07 00:11:07][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:07][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:10][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:12][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:15][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:17][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:20][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:22][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:25][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:27][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:30][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:32][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:35][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:37][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:40][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:42][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:45][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:47][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:50][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:52][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:56][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:11:57][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:01][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:02][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 00:12:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 00:12:06][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:07][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:11][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:13][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:16][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:18][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:21][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:23][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:26][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:28][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:31][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:33][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:36][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:38][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:42][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:43][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:47][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:48][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:52][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:53][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:57][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:12:58][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:02][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:03][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 00:13:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 00:13:07][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:08][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:13][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:13][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:18][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:18][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:23][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:23][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:28][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:28][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:33][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:33][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:38][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:38][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:43][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:43][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:48][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:48][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:53][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:53][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:58][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:13:59][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:03][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:04][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 00:14:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 00:14:08][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:09][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:13][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:14][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:14:18][INFO] : jsfolder = /var/www/html/plugins/ewejee/core/js
[2021-01-07 00:15:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 00:15:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 00:15:06][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 00:15:06][INFO] : Lancement du démon.
[2021-01-07 00:15:06][INFO] : Démon ewejee lancé

---------------------------------------------------------------------------------------------------------------------------------------------------

======================================================================
== 07/01/2021 00:11:06 == Installation des dépendances de ewejee
======================================================================
[  0% ] : Vérification des droits...
[  9% ] : Vérification des droits : [  OK  ]
[ 10% ] : Prérequis...
[ 19% ] : Prérequis : [  OK  ]
[ 20% ] : Mise à jour APT et installation des packages nécessaires...
[ 29% ] : Mise à jour APT et installation des packages nécessaires : [  OK  ]
[ 30% ] : Vérification de la version de NodeJS installée...
Version actuelle : v12.20.0
Ok, version suffisante
[ 49% ] : Vérification de la version de NodeJS installée : [  OK  ]
[ 50% ] : Nettoyage anciens modules...
[ 59% ] : Nettoyage anciens modules : [  OK  ]
[ 60% ] : Installation de ewejee, veuillez patienter svp, installation très longue...
[ 64% ] : Installation de ewejee, veuillez patienter svp, installation très longue : [  OK  ]
[ 65% ] : Installation des dépendances......
[ 89% ] : Installation des dépendances... : [  OK  ]
[ 90% ] : Nettoyage 1/2...
[ 94% ] : Nettoyage 1/2 : [  OK  ]
[ 95% ] : Nettoyage 2/2...
[ 99% ] : Nettoyage 2/2 : [  OK  ]
[100% ] : Terminé !
======================================================================
== OK == Installation Réussie
======================================================================

---------------------------------------------------------------------------------------------------------------------------------------------------


Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).
Création à
/var/www/html/plugins/ewejee/resources/lan
Suppression des fichier arp et deviceip
rm: cannot remove 'arp-table.json': No such file or directory
rm: cannot remove 'deviceip-table.json': No such file or directory
*************************** LS ***************************
getIP.sh
lan.sh
lanmode.txt
lib
working.txt
*************************** LS ***************************
Recherche d équipement sur le réseau local pendant 30 secondes ...
Si plusieurs reseaux :
192.168.1
Réseau utilisé par défaut :
192.168.1
Wake up devices...
192.168.1
Wait for devices to respond...
/var/www/html/plugins/ewejee/resources/lan
Recherche d équipement sur le réseau local terminé ...
Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).
[cache.js]
/var/www/html/plugins/ewejee/core/js/cache.js:10
(
^
TypeError: console.log(...) is not a function
at Object.<anonymous> (/var/www/html/plugins/ewejee/core/js/cache.js:10:1)
at Module._compile (internal/modules/cjs/loader.js:999:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
at Module.load (internal/modules/cjs/loader.js:863:32)
at Function.Module._load (internal/modules/cjs/loader.js:708:14)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:60:12)
at internal/main/run_main_module.js:17:47
[cache.js]
/var/www/html/plugins/ewejee/core/js/cache.js:10
(
^
TypeError: console.log(...) is not a function
at Object.<anonymous> (/var/www/html/plugins/ewejee/core/js/cache.js:10:1)
at Module._compile (internal/modules/cjs/loader.js:999:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
at Module.load (internal/modules/cjs/loader.js:863:32)
at Function.Module._load (internal/modules/cjs/loader.js:708:14)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:60:12)
at internal/main/run_main_module.js:17:47

---------------------------------------------------------------------------------------------------------------------------------------------------

http://undefined:undefined SSL ? undefined
Serveur correctement lancé sur http://localhost:6005 Le Thu Jan 07 2021 00:10:09 GMT+0100 (GMT+01:00)
{"error":406,"sequence":"1609974607000"}
events.js:291
throw er; // Unhandled 'error' event
^
Error: getaddrinfo ENOTFOUND undefined
at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26)
Emitted 'error' event on Request instance at:
at Request.onRequestError (/var/www/html/plugins/ewejee/core/js/node_modules/request/request.js:877:8)
at ClientRequest.emit (events.js:314:20)
at Socket.socketErrorListener (_http_client.js:427:9)
at Socket.emit (events.js:314:20)
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
errno: 'ENOTFOUND',
code: 'ENOTFOUND',
syscall: 'getaddrinfo',
hostname: 'undefined'
}
http://undefined:non SSL ? undefined
Serveur correctement lancé sur http://localhost:6005 Le Thu Jan 07 2021 00:15:09 GMT+0100 (GMT+01:00)
{"error":406,"sequence":"1609974907000"}
events.js:291
throw er; // Unhandled 'error' event
^
Error: getaddrinfo ENOTFOUND undefined
at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:66:26)
Emitted 'error' event on Request instance at:
at Request.onRequestError (/var/www/html/plugins/ewejee/core/js/node_modules/request/request.js:877:8)
at ClientRequest.emit (events.js:314:20)
at Socket.socketErrorListener (_http_client.js:427:9)
at Socket.emit (events.js:314:20)
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
errno: 'ENOTFOUND',
code: 'ENOTFOUND',
syscall: 'getaddrinfo',
hostname: 'undefined'
}

---------------------------------------------------------------------------------------------------------------------------------------------------

Il faut entrer les id eWeLink.

Pas mieux …

Le log ewejee_node stp ?

Désolé, j’ai que cela :
Capture

[2021-01-07 08:40:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:40:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:40:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 08:40:06][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 08:40:06][INFO] : Lancement du démon.
[2021-01-07 08:41:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:41:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:41:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 08:42:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:42:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:43:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:43:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:44:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:44:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:45:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:45:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:45:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 08:45:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 08:45:06][INFO] : Lancement du démon.
[2021-01-07 08:46:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:46:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:46:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 08:47:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:47:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:48:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:48:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:49:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:49:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:50:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:50:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:50:06][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 08:50:06][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 08:50:06][INFO] : Lancement du démon.
[2021-01-07 08:51:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:51:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:51:38][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 08:52:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:52:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:53:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:53:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:54:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:54:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:55:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:55:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:55:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 08:55:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 08:55:05][INFO] : Lancement du démon.
[2021-01-07 08:56:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:56:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:56:36][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 08:57:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:57:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:58:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:58:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 08:59:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 08:59:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:00:05][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:00:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:00:08][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:00:08][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:00:09][INFO] : Lancement du démon.
[2021-01-07 09:01:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:01:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:01:40][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:02:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:02:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:03:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:03:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:04:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:04:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:05:05][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:05:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:05:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:05:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:05:05][INFO] : Lancement du démon.
[2021-01-07 09:06:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:06:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:06:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:07:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:07:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:08:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:08:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:09:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:09:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:10:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:10:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:10:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:10:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:10:05][INFO] : Lancement du démon.
[2021-01-07 09:11:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:11:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:11:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:12:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:12:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:13:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:13:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:14:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:14:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:15:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:15:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:15:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:15:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:15:06][INFO] : Lancement du démon.
[2021-01-07 09:16:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:16:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:16:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:17:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:17:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:18:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:18:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:19:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:19:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:20:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:20:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:20:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:20:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:20:05][INFO] : Lancement du démon.
[2021-01-07 09:21:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:21:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:21:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:22:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:22:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:23:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:23:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:24:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:24:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:25:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:25:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:25:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:25:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:25:05][INFO] : Lancement du démon.
[2021-01-07 09:26:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:26:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:26:36][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:27:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:27:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:28:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:28:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:29:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:29:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:30:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:30:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:30:06][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:30:07][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:30:07][INFO] : Lancement du démon.
[2021-01-07 09:31:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:31:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:31:39][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:32:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:32:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:33:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:33:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:34:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:34:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:35:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:35:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:35:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:35:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:35:05][INFO] : Lancement du démon.
[2021-01-07 09:36:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:36:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:36:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:37:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:37:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:38:03][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:38:03][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:39:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:39:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:40:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:40:05][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:40:05][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-07 09:40:05][DEBUG] : Port du localhost (Par défault = 80) = 80
[2021-01-07 09:40:06][INFO] : Lancement du démon.
[2021-01-07 09:40:28][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:40:31][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:40:49][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:40:52][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:40:53][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:41:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:41:04][INFO] : [cron()][check cloud sh] Server up
[2021-01-07 09:41:37][ERROR] : Impossible de lancer le démon. Avez vous choisis la configuration http/https dans la configuration du plugin ?
[2021-01-07 09:42:04][DEBUG] : Demon LAN nok, server =
[2021-01-07 09:42:04][INFO] : [cron()][check cloud sh] Server up

Bonjour,

Je rencontre le même problème que GuyD29, mon démon ne se lance pas. J’ai tenté de supprimer le pluging et j’ai relancé une installation complète. J’ai bien rentré mes identifiants eWeLink (qui fonctionnent, j’ai vérifié :slight_smile: )

Les logs ewejee_node me donnent :

Error: Cannot find module 'express'
Require stack:
- /var/www/html/plugins/ewejee/core/js/newserver.js
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:815:15)
at Function.Module._load (internal/modules/cjs/loader.js:667:27)
at Module.require (internal/modules/cjs/loader.js:887:19)
at require (internal/modules/cjs/helpers.js:74:18)
at Object.<anonymous> (/var/www/html/plugins/ewejee/core/js/newserver.js:6:15)
at Module._compile (internal/modules/cjs/loader.js:999:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1027:10)
at Module.load (internal/modules/cjs/loader.js:863:32)
at Function.Module._load (internal/modules/cjs/loader.js:708:14)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:60:12) {
code: 'MODULE_NOT_FOUND',
requireStack: [ '/var/www/html/plugins/ewejee/core/js/newserver.js' ]
}

Merci de votre aide

Hello,

Tu as le log des dépendances aussi ?
Ce message d’erreur indique une dépendance non installé.

Salut,

Ci joint le log des dépendances :

======================================================================
== 07/01/2021 20:10:12 == Installation des dépendances de ewejee
======================================================================
[  0% ] : Vérification des droits...
[  9% ] : Vérification des droits : [  OK  ]
[ 10% ] : Prérequis...
sudo: unable to resolve host raspberrypi: No address associated with hostname
[ 19% ] : Prérequis : [  OK  ]
[ 20% ] : Mise à jour APT et installation des packages nécessaires...
[ 29% ] : Mise à jour APT et installation des packages nécessaires : [  OK  ]
[ 30% ] : Vérification de la version de NodeJS installée...
Version actuelle :
[ 39% ] : Vérification de la version de NodeJS installée : [  OK  ]
[ 40% ] : Installation de NodeJS 12...
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Utilisation du dépot officiel
Version après install : v12.20.1
[ 49% ] : Installation de NodeJS 12 : [  OK  ]
[ 50% ] : Nettoyage anciens modules...
[ 59% ] : Nettoyage anciens modules : [  OK  ]
[ 60% ] : Installation de ewejee, veuillez patienter svp, installation très longue...
[ 64% ] : Installation de ewejee, veuillez patienter svp, installation très longue : [ERREUR]
[ 65% ] : Installation des dépendances......
[ 89% ] : Installation des dépendances... : [ERREUR]
[ 90% ] : Nettoyage 1/2...
[ 94% ] : Nettoyage 1/2 : [  OK  ]
[ 95% ] : Nettoyage 2/2...
[ 99% ] : Nettoyage 2/2 : [  OK  ]
[100% ] : Terminé !
======================================================================
== KO == Erreur d'Installation
======================================================================
== ANALYSE DES ERREURS...
== TROUVÉ 'EINTEGRITY' dans l'erreur, je lance une commande pour corriger, attendez 45sec et relancez les dépendances pour réessayer
sudo: unable to resolve host raspberrypi: No address associated with hostname
npm WARN using --force I sure hope you know what you are doing.

Merci

C’est un soucis différent, tu peux créer un nouveau post en me mentionnant ?

Tu as bien relancé le démon ?

Bonjour,
J’ai souvent ce problème après une panne de courant ou coupure, la seul solution que j’ai trouvé c’est de redémarrer jeedom via le menu réglages / système et cela refonctionne, plutôt étrange non ?

Hello,

Tu parle du souci du log qui ne reviens pas, ou du démon qui ne se lance pas ?

Du démon qui ne se lance pas.

Vous pouvez faire la dernière mise à jour (de cet après midi) puis relancer les dépendances et me dire si c’est ok ?

1 J'aime

Bonjour,

Tout fonctionne désormais pour moi !

Merci beaucoup !