Daemon BLEA NOK

Tags: #<Tag:0x00007fcba9f9ccf8>

Bonjour,

Depuis 1 mois mon demon bluetooth reste en NOK, j’ai tenté plusieurs choses :

  • réinstallation du plugin
    -MAJ du bluetooth du RPI en SSH.
    J’ai réussi que le démon fonctionne pendant 2-3 jours en faisant la MAJ du RPI mais depuis le demon est redevenu NOK et impossible de le relancer.

Merci pour votre aide.

Salut

Tu n’as rien dans les logs ?

[2021-01-12 11:45:28][INFO] : Lancement démon blea : sudo /usr/bin/python3 /var/www/html/plugins/blea/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname local --noseeninterval 4 --scaninterval 29 --scanmode passive --pid /tmp/jeedom/blea/deamon.pid
[2021-01-12 11:45:30][INFO] : Launching remotes ...
[2021-01-12 11:45:30][INFO] : Lancement du démon distant
[2021-01-12 11:45:30][INFO] : Arret du démon distant
[2021-01-12 11:45:30][INFO] : Antenna local alive sending known devices
[2021-01-12 11:45:30][INFO] : Sending ready to daemons
[2021-01-12 11:45:31][INFO] : Commande par SSH fuser -k 55008/tcp >> /dev/null 2>&1 & sur 192.168.1.51
[2021-01-12 11:45:36][INFO] : Lancement du démon distant /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.51/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname "Antenne" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 &
[2021-01-12 11:45:36][INFO] : Commande par SSH /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.51/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname "Antenne" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 & sur 192.168.1.51
[2021-01-12 11:45:39][INFO] : Antenna Antenne alive sending known devices
[2021-01-12 11:45:39][INFO] : Sending ready to daemons
[2021-01-12 11:46:33][INFO] : This is a heartbeat from antenna Antenne
[2021-01-12 11:47:29][INFO] : This is a heartbeat from antenna Antenne
[2021-01-12 11:48:25][INFO] : This is a heartbeat from antenna Antenne
[2021-01-12 11:49:21][INFO] : This is a heartbeat from antenna Antenne
[2021-01-12 11:50:04][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2021-01-12 11:50:06][INFO] : Lancement démon blea : sudo /usr/bin/python3 /var/www/html/plugins/blea/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost 127.0.0.1 --callback http://127.0.0.1:80/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname local --noseeninterval 4 --scaninterval 29 --scanmode passive --pid /tmp/jeedom/blea/deamon.pid
[2021-01-12 11:50:07][INFO] : Antenna local alive sending known devices
[2021-01-12 11:50:07][INFO] : Sending ready to daemons
[2021-01-12 11:50:08][INFO] : Launching remotes ...
[2021-01-12 11:50:08][INFO] : Lancement du démon distant
[2021-01-12 11:50:08][INFO] : Arret du démon distant
[2021-01-12 11:50:08][INFO] : Launching remotes ...
[2021-01-12 11:50:08][INFO] : Lancement du démon distant
[2021-01-12 11:50:08][INFO] : Arret du démon distant
[2021-01-12 11:50:08][INFO] : Commande par SSH fuser -k 55008/tcp >> /dev/null 2>&1 & sur 192.168.1.51
[2021-01-12 11:50:08][INFO] : Commande par SSH fuser -k 55008/tcp >> /dev/null 2>&1 & sur 192.168.1.51
[2021-01-12 11:50:09][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2021-01-12 11:50:04
[2021-01-12 11:50:13][INFO] : Lancement du démon distant /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.51/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname "Antenne" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 &
[2021-01-12 11:50:13][INFO] : Lancement du démon distant /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.51/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname "Antenne" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 &
[2021-01-12 11:50:14][INFO] : Commande par SSH /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.51/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname "Antenne" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 & sur 192.168.1.51
[2021-01-12 11:50:14][INFO] : Commande par SSH /usr/bin/python3 /home/pi/blead/resources/blead/blead.py --loglevel info --device hci0 --socketport 55008 --sockethost "" --callback http://192.168.1.51/plugins/blea/core/php/jeeBlea.php --apikey uWDpTk9ZqL4ltB3fTG7w4ssplfAeE4JC --daemonname "Antenne" --noseeninterval 4 --scaninterval 29 --scanmode passive >> /tmp/blea 2>&1 & sur 192.168.1.51
[2021-01-12 11:50:16][INFO] : Antenna Antenne alive sending known devices
[2021-01-12 11:50:16][INFO] : Sending ready to daemons

Bonjour,
J’avais le même problème avec Blea. Le seul moyen pour que tout refonctionne c’est de redémarrer le rpi… Et ça tenait 2-3 jours.
En faisant des recherches, j’ai lu que ça pouvait être dû au bluetooth interne du rpi3. J’ai branché une clé externe depuis plus de problème.
Si ça peut aider…

Bonjour,

Vous pouvez complétez votre profil pour savoir ce que vous avez comme plugin par exemple.
Mais aussi, version du RPi, version de l’OS du RPi ect…

@Fabrice, ca ressemble un peut a mon problème, quand je redémarre blea ça tien aussi environ 3 jour

Oui, c’est pour cela que je tente de suivre les 2 sujets.

Il faut aussi savoir, je ne sais pas si c’est votre cas à tous les 2, mais par le passé il y a eu ce problème chez les personnes ayant un Google Home à la maison. Et celui-ci se met à spammer le BT dès qu’il n’a plus de connexion vers Internet.

J’ai des google home chez moi depuis plus d’un ans chez moi. Et le problème a commencé depuis 2 mois environ, chez moi en tout cas.

Peux être, mais comme tout le monde n’a pas ce problème, il faut bien tenter de trouver des points communs à ceux (très peu nombreux) qui ont cette erreur !

Sinon, nous serions tous concerné.

Bonjour,

Un sujet similaire est traité ici Blea demon nok
Si dans votre configuration vous avez un bluetooth interne au RPI, il ne faut pas créer d’antenne mais utiliser la configuration local du plugin BLEA. Cela corrige le daemon NOK.

Cordialement,