Class wes_relai does not exist suite mise a jour 51

Tags: #<Tag:0x00007f2834dcd828>

Bonjour,

Je viens de faire la mise a jour de jeedom en 3.51, cependant maintenant j’ai l’erreur suivante :
Class wes_relai does not exist

Je pense que c’est due au pluing WES mais du coup je ne sais pas quoi faire ?

Merci

JE pense que c’est uniquement le plugin WES, car j’ai fait une restauration et apres juste mis a jour le WES, il ne fonctionne plus,
Il doit y avoir un bug, d’autre retour sur cette mise a jour ?

Merci

Salut j’ai le même problème, je viens de restaurer la sauvegarde et les infos du Wes sont ok.
C’est pas le plugin…
Edit : C’est sa maj d’aujourd’hui qui créer cette erreur, j’ai bloqué la maj et cela fonctionne bien en 3.3.51 et version plugin Wes du 11-05-2020 pour ma part

Du coup cela ne vient pas de chez moi

Tu n’a pas fait la mise a jour du WES du coup ?

Une solution ?
Je ne peux pas ouvrir de ticket jeedom moi car je suis utilisateur Gratuit… c’est bien dommage

Salut @Loic
J’ai fait la maj 3.3.51 et j’ai cette erreur
« Class wes_temperature does not exist » qui s’affiche.
J’ai relancé le démon du Wes. J’ai redémarré la Jeedom smart mais le problème est toujours là.
Avez-vous cette erreur vous aussi.

Bonjour,
À priori c’est un problème de ce plug-in, pas du core.
Re-install le.

Salut
Merci, j’avais pas vu

Salut,
Je l’ai réinstallé mais ça ne fonctionne pas.
J’ai restauré le backup 3.3.50 et ça remarche.
Edit : J’ai bloqué la maj du plugin Wes

Meme problème pour moi.
Plugin semble bien mis à jour mais mon wes a disparu.
Quand je veux le réinstaller, il me dit qu’il existe déja…
HELP, MERCI

Moi j’ai restauré la v3.3.50
Puis j’ai bloqué la maj du Wes, ne pas oublier de sauvegarder
Et j’ai fait la maj Jeedom 3.3.51 sans la maj du wes

bonne idée mais mon dernier BU date de mai… et comme cette mise à jour WES ne devait que mettre à jour la doc, je ne me suis pas tracassé… idiot…

Bonjour,

Le plugin a été mis à jour pour la V4, et par la même occasion, réécrit en mono class (ce qui explique que la class wes_relai n’existe plus. Il n’y a maintenant qu’une seule class « wes » avec des types différents pour chaque module) mais pas forcément finalisé. J’y ai fait quelques corrections en Beta mais je n’avais pas vu que la Beta avait été mergé avec la Master.

La réécriture en mono class va impliquer une recréation des équipements.
EDIT : => Une modification va être faite pour eviter cela. Un peu de patience et cela devrait rentrer dans l’ordre.

1 J'aime

Bonne nouvelle pour la V4, c’est le seul qui me manquait pour basculer en Jeedom V4.
Par contre est-ce qu’il est possible d’avoir facilement le changelog lorsque l’on appuie sur le bouton « changelog » du plugin svp ? Je sais que c’est chiant mais pour nous utilisateurs c’est important.

Merci d’avance

C’est la cas avec la nouvelle version du plugin.

Plugin WES change Log

Merci :grin:

je viens de faire la correction de ses soucis sur la beta il me faudrait un testeur pour valider que tout fonctionne de nouveau/

Salut
Question a 2 balles mais Jeedom ne remonte pas le bon numéro de compteur électrique sur la teleinfo, est-ce normal ?
@Alexandre je peux tester ce soir si tu veux, comment on fait ?

Juste installer le plugin en bêta :wink:

bonjour je veux bien tester

Salut
C’est ok de mon côté, il n’y a plus l’erreur.
Est-ce que tu peux voir, si tu veux bien, pour le numéro de compteur stp ?