Widget sur serveur jeedom invisible

Tags: #<Tag:0x00007f38505511c8> #<Tag:0x00007f3850551038>

Bonjour à tous,
mon 1er post ici, je débute depuis quelques semaines sur Jeedom installé fraichement sur une VM de Freebox Delta (version 4.0.61). L’installation et les paramétrages de base sont passé.
J’aimerais pouvoir commandé de manière plus modulable les volets roulants de la maison qui ont des commandes SONOFF non flashés (ça communique bien via le plugin EWEJEE).
J’ai commencé par créer un scénario très complet et complexe (sur le site de ladomotiquepratique.com : https://www.ladomopratique.com/volets-somfy-rts-avec-pseudo-retour-detat/ pour pouvoir 'l’appeler" ensuite depuis chaque volet roulant…sauf que je n’ai jamais réussi à l’appeler ! l’explication de cette partie est survolée…Arg.
Je me suis donc rabattu sur l’utilisation d’un Widget, réalisé par @Salvialf (superbe boulot au passage), je télécharge sur GitHub sa dernière version (maitre), je la décompresse en local, j’envoi cela dans le bon répertoire (html/data/custom template/dashboard) avec le plugin jeexplorer, mais après… je n’arrive pas à trouver trace de ce widget logiquement sur mon serveur.
J’essaye pourtant de lire beaucoup, je dois passer à côté de quelque chose de certainement très simple, mais je bloque et galère.
Une petite aide serait super sympa.
merci :slightly_smiling_face:

Bonjour @Krakenn

Alors pour appliquer un widget il faut te rendre sur l’équipement en question dans l’onglet commande puis les commandes en bout de ligne tu as un petit dessin de roue cranté, tu clique dessus puis dans affichage tu devrais voir les possibilités de widget possible.

une petite lecture de la doc c’est bien aussi :wink:

https://doc.jeedom.com/fr_FR

Salut,

J’ajouterais que le plugin widgets doit être désinstallé en V4 (vu que le plugin est tagué sur le sujet)

@Salvialf pas compris pourquoi ni comment le plugin widget doit être « désinstallé en v4 ». Aie. patapé.
@iPapy merci pour les infos, j’avance : j’ai réussi à mettre dans le dashboard ceci :
Capture d’écran 2020-08-21 à 19.31.13
l’esthétique n’est pas tip-top, mais je m’en occuperais plus tard : l’urgent est que ça fonctionne :sweat_smile:
Les boutons fonctionnent parfaitement…du moins sur l’écran… Il n’y a que le bouton monter qui agit sur le volet… Le reste sans action sur le volet.
J’ai essayé de connecter dans l’équipement (volet salon) les commandes appropriées pour chaque mouvement. Il y a un truc qui m’échappe : ça fonctionne pour monter mais pas pour le reste !
Voici une capture pour plus d’infos :
Capture d’écran 2020-08-21 à 19.31.50
Le scénario correspondant complet :(EDIT : pas pu le poster, je suis limité à 2 captures par poste)
Je pense que le problème doit venir d’une mauvaise connection entre le scénario et l’équipement, mais je ne vois pas comment et surtout où apporter une modification.

Capture d’écran 2020-08-21 à 19.33.15 Capture d’écran 2020-08-21 à 19.47.29

Voici comment je met la commande « Descendre volet » qui ne fonctionne pas :
Capture d’écran 2020-08-21 à 20.04.32

J’avance doucement :
Je créé un Widget que je nomme : Volet Salon WIDG et je le lie à la commande : « [Salon][Volet Salon][Volet] »
Capture d’écran 2020-08-22 à 16.55.56
Les commandes de test fonctionnent bien sur les images à droite, mais toujours pas sur le volet roulant.
Je retourne dans le Dashboard, je vais sur la commande en question qui s’affiche bien en cliquant dessus pour afficher la partie « Equipement » et « Commande ».
Je vais dans la partie « Commande » puis je clic sur la roue dentée en face de la ligne correspondant à l’action de « Monter » (il faut bien commencer par une commande).
Dans la partie informations, il n’y a pas d’équipement ou de commandes liées…et je n’arrive pas à en mettre.
Capture d’écran 2020-08-22 à 17.13.39
Dans la partie AFFICHAGE, ayant créé un Widget pour monter le volet, je clic sur la liste déroulante de la partie DASHBOARD, mais je ne vois aucun Widget que j’ai pu créer…
Capture d’écran 2020-08-22 à 17.16.06
Si quelqu’un peut m’aider.
Merci.

Le sous-type de ton widget est bien le même que celui de ta commande?

Merci @Poumi pour ta réponse,
Je pense que oui :
Sous type du widget : curseur :
Capture d’écran 2020-08-22 à 19.12.41
Sous type de la commande (lorsque je clique sur le lien en dessous de « Commandes Liées » : Slider (qui est curseur en Anglais) :
Capture d’écran 2020-08-22 à 19.14.18

EDIT : Par contre, lorsque je vais sur le DASHBOARD et que je clic pour éditer « Commande Salon TV », dans l’onglet COMMANDE, lorsque je clic sur la roue dentée en face de MONTER, je suis en sous-type OTHER.
Pas moyen de trouver où éditer cela … ARG (si c’est bien à modifier).
Capture d’écran 2020-08-22 à 19.20.48

J’ai trouvé une combine, mais cela fait agir le Widget sur l’équipement et non sur le scénario. Lorsque j’adapte le lien pour pointer sur le scénario, cela ne fonctionne pas.
La combine :
Capture d’écran 2020-08-22 à 23.11.11
j’ai toutefois l’impression d’être dans la bonne voie. Si quelqu’un peut m’apporter quelques éléments ça serait cool, j’épluche les docs, les tutos et les sites, je ne trouve rien de clair sur la connection d’un scénario au Dashboard. J’ai pas l’impression que ça soit automatique.

Bonjour,
J’ai essayé mais honnêtement je ne comprend pas grand chose au sujet ;

  • Post trop long, trop de blabla pas lié au sujet => on est noyé
  • le titre est widget invisible sur serveur jeedom et ensuite on parle de jeexplorer, de config de commande et d’afficher un scénario sur un dashboard => un sujet = une et une seule question.
  • on a le tag #plugin-widget et une installation v4; @Salvialf répond qu’il faut désinstaller le plug-in widget en v4 et que c’est normal que ce plug-in n’affiche plus aucun widget => c’est la réponse au sujet.

Merci de lire Comment nous aider à vous aider - ou Comment poser une bonne question? ou de le relire.

1 J'aime

Pareil que @Mips j’ai essayé de comprendre à quel niveau tu rencontrais des difficultés sans succès malgré de nombreuses lectures du sujet.

Je me demande si tu n’as pas un problème à cause du nom des commandes monter et descendre qui cacherait une des 2 commandes mais comme ça parle de scénario et de plein d’autres choses… tu peux essayer de nommer ces commandes différemment pour voir si c’est mieux ?

Merci pour vos réponses,
Je comprend qu’il doit y avoir une incompatibilité entre Jeedom V4 et le plugin WIDGET
Capture d’écran 2020-08-23 à 10.27.39
Je désinstalle donc ce plug-in comme conseillé.
@Salvialf : je reprend mon scénario et les commandes depuis le début en distinguant bien les noms.

Merci pour toutes les infos, cela fonctionne nickel. :grin: :+1:
Ce devait être soit un problème de noms (j’ai identifié convenablement les scénario « -SCEN » des virtuels « -VIRT » pour rendre cela plus clair), soit un blocage avec le plugin Widget que j’ai désinstallé.
Dans tous les cas, cela m’a permis de mieux comprendre les commandes et interactions entre Dashboard/Virtuel/Scénario.
Y’a encore du chemin pour tout bien maitriser, j’en suis conscient. :face_with_head_bandage: mais je ne vais pas lâcher l’affaire ! :sweat_smile:
Capture d’écran 2020-08-23 à 16.01.30

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.