Trop de session actives tous les 3J malgré le nettoyage des sessions

Bonjour,
Aujd 9h :

Trop de session, je ne peux pas lister : 280. Faire, pour les nettoyer : “sudo rm -rf /var/lib/php/sessions;mkdir /var/lib/php/sessions;chmod 777 /var/lib/php/sessions”

Aujd 9h15 : je nettoie correctement les sessions (plus de souci)

Aujd 19h :

Trop de session, je ne peux pas lister : 173. Faire, pour les nettoyer : “sudo rm -rf /var/lib/php/sessions;mkdir /var/lib/php/sessions;chmod 777 /var/lib/php/sessions”

Et j’ai de grosses lenteurs sur jeedom.
Que puis je faire ? Qu’est ce qui ne va pas ?
Merci

Bonsoir,
Peut-être te connecter en ssh à ta machine et taper ce qu’il te propose.

Je le fais tous les deux jours, c’est mon souci …

Quelle est ta machine?
Si tu as un support, je te conseille d’ouvrir un ticket.

C’est un Acute Angle AA - B4 DIY Mini PC :slight_smile:

Salut,

Et donc tu n’as pas de pack.
Ouvre quand même un ticket.
Pour ma part, je ne sais t’aider et j’en suis désolé.
Bonne chance

1 J'aime

Salut Salvialf,
Je l’ai fait y’a 10min, le souci c’est que demain soir j’aurais de nouveau 80 connexions en cours.

Tu les vois toutes ces sessions dans la configuration de jeedom? Elles correspondent à quoi?

J’ai toutes les sessions sur le même compte avec la même IP. Je suspecte que chaque refresh créé un nouvelle session et c’est pour ça que j’ai créé ce ticket. Je cherche la cause en fait …

T’as vérifié le log http.error ?

En effet j’ai des logs mais pas sûr de vers quoi ils mènent :

$ ls -l /var/www/html/log/http.error
-rwxrwxr-x 1 www-data www-data 38897 nov. 19 22:25 /var/www/html/log/http.error

$ tail /var/www/html/log/http.error
Device “veth65d3fe3@if25” does not exist.
Device “veth65d3fe3@if25” does not exist.
Device “veth9d5b503@if27” does not exist.
Device “veth9d5b503@if27” does not exist.
Device “veth19cbbcd@if29” does not exist.
Device “veth19cbbcd@if29” does not exist.
Device “veth4717a3b@if31” does not exist.
Device “veth4717a3b@if31” does not exist.
Device “vethffca50c@if33” does not exist.
Device “vethffca50c@if33” does not exist.

Ça correspond aux heures de connexions des sessions?

À voir le retour du ticket du coup…

Y’a pas d’heure dans les logs du coup je ne sais pas

Je dois attendre pour le ticket de retour car j’avais du donner accès à mon jeedom 2 fois pour le même sujet et ca m’a cramé les 2 tickets du mois … :frowning:

Une idée de debug que je peux activer ?

Tout au vert sur la page santé? T’es sous debian 9 ?
Si tu supprimes toutes les sessions et que tu n’enregistre que ton poste principal?
Version de jeedom? T’as essayé de faire une mise à jour forcée?

Tout vert : Oui tout sauf “Configuration réseau interne” et “Configuration réseau externe”
OS : Linux jeedom 4.9.0-11-amd64 #1 SMP Debian 4.9.189-3+deb9u1 (2019-09-20) x86_64
Nettoyage : c’est exactement mon cas, je n’utilise qu’un seul pc, pas de session cachée chrome rien
Jeedom : 3.3.37
MAJ forcée : jamais …

Ben déjà je commencerai au moins par être OK sur la config réseau interne !!

Tout est correctement rempli, je ne sais pas quoi faire de plus

Edit : j’ai réparé l’interne. Le souci c’est que mon certif https n’a pas de SAN sur l’IP et je n’ai pas la résolution DNS en interne du coup le certif est jugé invalide. J’ai mis sur HTTP et plus de souci.

Mon problème persiste malgré ce fix

Le retour, aujd 19h (soit 10h après avoir nettoyer les sessions)…

Trop de session, je ne peux pas lister : 173. Faire, pour les nettoyer : “sudo rm -rf /var/lib/php/sessions;mkdir /var/lib/php/sessions;chmod 777 /var/lib/php/sessions”

C’est vraiment bizarre toutes ces sessions de créées… Tu utilises Chrome comme navigateur ?

Onglet général de la config Jeedom tu as “24” à la ligne “Durée de vie des sessions (heure)” ?

Eventuellement désactiver scripts et plugins pour vérifier que ça ne vienne pas de là…