Scénario éclairage en fonction de l'heure

Tags: #<Tag:0x00007f38587ac0f0>

Bonjour à tous,

Je débute dans la domotique.
J’ai commencé simplement comme la plupart d’entre vous par l’éclairage.

J’ai réussi par le biais d’un scénario à paramétrer mon éclairage de cuisine pour que le matin la lumière soit tamisée et chaleureuse (entre 22h30 et 10h du matin) et qu’elle soit vive pour le reste de la journée. Ça fonctionne nickel malgré le petit temps de latence mais qui ne me dérange pas.

Là ou ça coince c’est que je ne peux plus régler la luminosité manuellement sans que le scénario force l’éclairage par rapport à l’heure.

Au niveau matos, je tourne sur jeedom sur rpi 3b+ (en RJ45) avec une pizigate. Les lumières sont des tradfri ikea que je pilote avec la passerelle ikéa et le plugin ikea. pour ce qui est de la détection tout marche nickel c’est vraiment niveau scénario ou je sèche. Pour l’allumage des ampoules je passe par mon interrupteur traditionnel (donc filaire sans module domotique). Pour le réglage de la luminosité en manu je passes par le petit module ikéa tradfri.

Je penses que c’est au niveau de mon déclencheur qui est le changement d’état de l’ampoule.

Pour moi il faudrait que je puisse intégrer une variable du genre si l’état de l’ampoule (allumé ou éteinte donc géré par 0= off : 1=on si je ne dis pas de bêtises) est identique à celui de la seconde précédente alors je ne lance pas le scénario.

Merci d’avance pour votre aide.

Salut nightangel80,

Si je ne dis pas trop de bêtise, tu n’auras jamais l’état 0 car tu coupe l’alimentation de ton ampoule pour l’éteindre.
Donc pas de changement d’état vu de la box domotique.
Au mieux tu auras l’info reachable (connais pas la zigate), mais en général ça prend beaucoup de temps à être mis à jour.

Pour info, tu as une option « jamais répéter » (dans la configuration des commandes) qui permet de ne pas envoyer une valeur répétée (donc si elle le matériel renvoi 2 fois 1 de suite). mais pas applicable pour toi ici à priori

Salut Bben,

Merci pour ta réponse.

Après vérification il semblerait que l’état zéro soit reconnu par la box mais il y a bien un délai.
Je penses comme tu l’as dit que c’est lié au fait que la box n’arrive plus à avoir le signal et par défaut met l’état à 0. Par contre je te confirme que ça prend beaucoup de temps.

Je viens d’essayer l’action répéter (il s’agit du logo en forme de boucle qui passe en interdit dans les blocs SI?

Fausse joie pour moi dans un premier temps je croyais que ça fonctionnait. J’arrive bien à changer ma luminosité sans que ça revienne au paramètres définis par le scénario. Le hic du coups c’est que même en éteignant et rallumant les lampes elle ne reprenne plus leur éclairage par défaut du scénario.

Je vais continuer de creuser un peu pour voir si c’est possible sans être obligé de modifier mes interrupteurs.