Ruban LED OSRAM Flex 3P Multicolor

Tags: #<Tag:0x00007f3853ad9ac0>

Bonsoir,

Je suis en train d’installer un ruban led OSRAM (zigbee) sous JMQTT, il est bien reconnu :

« {« type »:« pairing »,« message »:« interview_successful »,« meta »:{« friendly_name »:« 0x7cb03eaa0a0077dd »,« model »:« 4052899926110 »,« vendor »:« OSRAM »,« description »:« Flex RGBW »,« supported »:true}} »

J’arrive à l’allumer et l’éteindre sans trop de difficulté par contre y a t’il un moyen simple de choisir la couleur, j’ai bien consulté la page :

Mais ça ne m’aide pas beaucoup …

Merci.

bonjour. j’ai le meme ruban led osram smart+ flex 3P Multicolor, mais je rencontre un problème.
le topic MQTT publié est :
« MQTT publish: topic ‹ zigbee2mqtt/0x7cb03eaa0a0098aa ›, payload ‹ {« update_available »:false} › »
avez vous fait qqch de spécial pour avoir d’autre informations remontée?

Bonjour, je découvre les joies de zigbee2mqtt et de la clé CC2531.

Après pas mal de recherche, j’ai découvert cette page https://www.zigbee2mqtt.io/information/ota_updates.html
il y est décrit comment mettre à jour certain device.

J’ai téléchargé l’outil https://mqtt-explorer.com/ en version portable sur windows et en effet, j’ai pu envoyé une demande de mise à jour de mon ruban LED, c’est en cours au moment ou j’écris, il y en a pour environ 12 minutesjeedom

J’espère que ca va débloquer la situation chez vous comme chez moi

Merci d’avoir pris le temps de me répondre sed49

J’avais déja fait la MAJ OTA depuis le plugin MQTT de Jeedom

Je viens de réessayer via ton logiciel, et j’ai le meme résultat:
Update of ‹ 0x7cb03eaa0a0098aa › failed (No new image available)
zigbee2mqtt:info 2020-09-17 12:42:40: MQTT publish: topic ‹ zigbee2mqtt/bridge/log ›, payload ‹ {« type »:« ota_update »,« message »:« Update of ‹ 0x7cb03eaa0a0098aa › failed (No new image available) »,« meta »:{« status »:« update_failed »,« device »:« 0x7cb03eaa0a0098aa »}} ›

Je pense donc que mon Flex+ est bien a jour niveau Firmware
Ce que je ne comprends pas, c’est pourquoi je ne vois pas d’info publié par ce device.
tout ce que je vois est :
MQTT publish: topic ‹ zigbee2mqtt/0x7cb03eaa0a0098aa ›, payload ‹ {« update_available »:false} ›
Alors qu’avec d’autre device, comme un capteur de température aqara, j’ai un payload avec plien d’informations.

As tu fait qqch de spécial, comme mettre le flex+ en mode « association » en debranchant / rebranchant 5 fois de suite?
Je viens d’essayer et sa ne change rien. Je ne suis pas convaincu que ca ai marché, car le flex+ devrait clignoter, et ce n’est pas mon cas.

Bonjour,

Je n’ai pas tenté de le brancher/débrancher 5 fois.

J’avoue que ce n’est pas simple ce protocole mqtt. Je n’arrive pas encore à faire ce que je veux dans Jeedom.

En revanche j’arrive à allumer et éteindre le ruban de led avec le logiciel MQTT Explorer en mettant simplement {« state »:"on} dans la zone Publish (comme sur la capture au dessus meme si on ne voit pas grand chose).
Et quand je l’allume avec ce message, dans Jeedom, ou plutôt sur le raspberry en SSH, avec les log activé sudo journalctl -u zigbee2mqtt.service -f je vois un payload pour ce ruban

Ca commence à venir.

J’ai pu lui créer les commandes ON et OFF par contre pour la couleur, ca ne passe pas, dans les logs je voit « JSON Invalid » malgré plusieurs tentative donc certaines se solde a l’enregistrement par la perte de la valeur de couleur dans la zone de saisie !!!

Capture d’écran 2020-09-17 145007

Question idiote jbioman59 : 0x7cb03eaa0a0098aa c’est bien le ruban LED et pas un autre device ?

Sinon ce soir j’ai réussi a le piloter, y compris la couleur. Mais je suis passé au plugin jMQTT et avec un virtuel je peux éteindre / allumer / changer la couleur / changer l’intensité.

Je ne maitrisais pas assez les virtuels c’est en parti pour ça que j’ai galéré et le fait que le plugin MQTT me renvoyait une erreur JSON invalid quand je voulais manipuler les couleurs

je viens de me debloquer, meme si je ne sais pas trop pourquoi?

grace a ton commentaire, j’ai trouvé le bon parametre pour la couleur qui est : { « color »:{« rgb »:« 255,255,255 »}}
En envoyant la comande avec mqtt explorer, le ruban a bien changé de couleur
j’ai ensuite vu une update du topic mqtt, et je vois désormais bien les differentes infos

MQTT publish: topic ‹ zigbee2mqtt/0x7cb03eaa0a0098aa ›, payload ‹ {« update_available »:false,« state »:« ON »,« brightness »:254,« linkquality »:31,« color »:{« x »:0.1724,« y »:0.7468},« color_temp »:154} ›
flex
Reste a crée un virtuel avec les bonnes valeurs.

Ca avance !
En ajoutant des « commandes actions » sur le topic mqtt, j’arrive a un bouton ON, un bouton OFF et la luminosité fonctionelle

Par contre la valeur max du slider pour la luminositée est de 100, alors que le flex accepte jusque 255 a priori
De meme, les couleur ne fonctionnenet pas.

Une idée ?
flex

Bonjour,

Pour le min max c’est plutôt simple, au bout de la ligne de la commande tu peux renseigner un min et un max.

Pour les couleurs, regarde dans les logs avec la commande
sudo journalctl -u zigbee2mqtt.service -f
si c’est comme moi, tu verras INVALID JSON.
C’est pour ca que je suis passé à jMQTT, ca marche très bien