[RTEX] Debian 10 - Buster - netinst - amd64 - Jeedom V4

Tags: #<Tag:0x00007fcbb2a58298> #<Tag:0x00007fcbb557bba0>

bonjour Akenad,

Je tente d’installer Jeedom sur une VM (VMWare workstation player) et j’ai un soucis lors de l’installation de jeedom. J’ai suivi ton tuto, je lance l’installation de jeedom via ssh et l’installation stop avec ces derniers messages :

Commence l’étape 7 personnalisation de jeedom
mkdir: impossible de créer le répertoire « /etc/systemd/system/apache2.service.d »: Le fichier existe
Update php file /var/www/html/vendor/doctrine/cache/tests/travis/php.ini
Update php file /etc/php/7.3/cli/php.ini
Update php file /etc/php/7.3/apache2/php.ini
Module status already disabled
étape 7 personnalisation de jeedom réussie

commence l’étape 8 configuration de jeedom
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)
CNe peut exécuter CREATE USER ‘jeedom’@‘localhost’ IDENTIFIED BY ‘1fc7c15be69005f’; dans MySQL - Annulation
root@JeedomVM:~#

Comme je ne suis pas du tout un expert dans ce domaine :frowning:, pourrais tu m’aider sur la résolution de ce problème ?
Si tu as besoin de plus de détails, pas de soucis !
Merci pour ton aide,
Philippe

Bonjour @bibi31470,

Recommence depuis le début et suis exactement ce qui est indiqué, en particulier
$ su -

akenad :slight_smile:

@akenad,
Merci pour ta réponse super rapide !
Oui, j’avais bien utilisé cette commande ! mais j’ai tenté d’installer directement la V4 avec le lien :
wget https://raw.githubusercontent.com/jeedom/core/master/install/install.sh
Cela vient peut être de là.

Entre temps j’ai suivit la suite de ton tuto : j’ai recréé une nouvelle VM est tenté d’installer la V3.3.39…Et là nickel !! tout a bien fonctionné !!
Je n’ai pas encore tenté de passer en V4 comme tu l’explique plus haut, via jeedom. Cela devrait fonctionner !
Mais si j’ai bien compris, ce n’est pas nécessaire de le faire maintenant, car mon Jeedom en prod est actuellement en V3.3.39 et je voudrais l’installer sur cette VM via ma dernière sauvegarde afin de tester le passage en V4, par après.
Donc si j’étais maintenat en V4, le fait d’installer ma sauvegarde en V3.3.39, va automatiquement remettre ma VM en Ver V3.3.39. C’est seulement après cette installation qu’il faudra passer en V4 comme indiqué dans ton tuto. C’est bien cela ?

Merci pour ton aide !
Philippe

@akenad,
Je me réponds :par curiosité, j’ai recommencé depuis le début…Et là ça marche Jeedom en V4 sans problème ce cout ci…J’avais du faire une erreur lors de la première tentative…
Donc tout marche, merci pour ton super tuto !! :slight_smile:

A+
Philippe

Bonjour,

Je suis le topic pour ma future migration en debian 10 jeedom v4

Merci

Salut Lafouine,

Je me permets moi-même de rebondir sur ton post car j’ai le même souci.
J’ai dl une image de debian 9 et vais tenter une install sur avec la V3 stable voir si j’y arrive.
Sinon je reprendrais du début les manips d’Akenad… en espérant que mon niveau 0 en linux ne soit pas le problème majeur de cette aventure !

Pour ta part, as-tu réussi l’install ?

Merci
Yann

Malgré avoir suivi à la lettre le tuto, j’ai toujours une erreur à la fin de l’installation de Jeedom.
Est-il possible d’avoir de l’aide ?

Hello,

A mon avis ça serait plus simple d’ouvrir ton propre topic, en détaillant au maximum ce que tu as fait, ta config, et au minimum le message d’erreur…

Edit: et la version de jeedom, on la connait ici mais met la dans ton topic

1 J'aime

Bonjour !
Merci pour ce sujet détaillé et clair !
Utilisateur de Jeedom depuis la Mini+, puis Rpi2, puis Rpi3 (sur SD puis SSD), je cherchais à passer sur une machine plus homogène (sans hub usb ou disque ssd qui traînent dans la baie) et je me suis tourné vers le Z83-V.

J’ai installé Debian 10 Buster sans souci (à part avec les drivers/firmwares wifi/BT que je n’utiliserai de toute façon pas).
Puis Jeedom (v4 par défaut) avec les infos trouvées sur ce sujet.
J’ai restauré une sauvegarde de mon installation existante, tout était ok (en v3), puis forcé une mise à jour en V4.
Tout est ok pour l’instant.
Je n’utilise pas de designs donc j’ai juste eu à reprendre quelques visuels sur le Dashboard.
Il me reste le gros morceau, passer du Razberry à une clé Z-Wave Gen5.

2 J'aimes

Bonjour,
Certain deconseille de passer en debian 10 pour jeedom, il en est quoi officiellement ?
Je suis comme vous en VM sur proxmox
Merci.

Bonjour @kris1208,
Les annonces officielles sont dans la catégorie « Annonces officielles ».
(L’image Jeedom pour la VM Freebox Delta est une Buster).

akenad :slight_smile:

Bonjour
Je viens d’essayer de faire l’install sur la dernière version debian 10.3 et à la fin il annule l’install de jeedomerreur%20jeedom

Bonjour @PeterKalel,

Il semble qu’il y ait eu des modifications sur les scripts de Jeedom très récemment.
à l’étape 9 de install.sh, la commande :
php /var/www/html/install/install.php mode=force
retourne une erreur.

Voir ici : https://community.jeedom.com/t/19484
et ici (bug suite mise à jour Jeedom 4.0.43) : https://community.jeedom.com/t/19426

Il y a eu hier une correction de bug dans core/config/jeedom.config.php

akenad :slight_smile:

Super c’est bon ça marche
Merci

Ben voilà ce que c’est, ça t’apprendra a écrire en khêTon :wink:

1 J'aime

Bonjour @franckam6,

Ce sujet ne traite pas de clé USB ni du bluetooth.
Merci de bien vouloir ouvrir un sujet dédié.

Edit : sujet crée par @franckam6 ici : https://community.jeedom.com/t/25228

akenad :slight_smile:

Désolé pas de soucis .

Bonjour
J’ai beau essayé plusieurs fois j’ai toujours se message
pouvez-vous m’aidez ?Capture Jeedom VM

Bonjour @Jean-christophe,

Taille disque trop petite.

akenad :slight_smile:

yes la classe merci beaucoup
je me suis pris la tète t’imagne pas
encore merci
mais c’est étonnant sur les tutos ils disent que 4go suffisent