[RTEX] Debian 10 - Buster - netinst - amd64 - Jeedom V4

Tags: #<Tag:0x00007f2833ff2000> #<Tag:0x00007f2833ff1f38>

Bonjour @Loic,

J’ai mis à jour le 1er post en conséquence.

akenad :slight_smile:

Bonsoir tout le monde
hou la la …que c’est …embrouillant pour pas dire compliqué…
Je vais attendre un peu que la procedure soit plus simple !!!
(je ferai peut etre un essai sur une vm de test… )

Bonjour @leon-99,

c’est très simple, tu installes Buster dans une VM,
puis tu installes Jeedom comme indiqué dans la documentation officielle ici :
https://jeedom.github.io/documentation/installation/fr_FR/index#tocAnchor-1-32

akenad :slight_smile:

Oui akenad… c’est ce que je vais faire …ca me permettra de tester au moins mes widgets… (et de faire un peu joujou avec)

Bonjour
Tuto parfait pour creer une VM sur un Synology, ainsi que l’install de Debian9 ou 10 puis de jeedom (j’ai pu retrouver la V3.33 et la V4 sans probleme…bien que ce soit compliqué!!)
Mon seul probleme c’est que sur un DS218+ c’est impossible a travailler, mon jeedom est trop lourd (220 Mo avec 3,5 ans de données) et le CPU du NAS flirte en permanence avec les 95% au point au ma VM s’arrete toute seule !!! Sur un jeedom recent (40 Mo) que j’ai pu recuperer c’est presque OK
Mon RPI 3B+ est bien plus performant.
Je vais commencer a regarder coté NUC

Bonsoir.
Pourriez vous être plus clair sur l’installation de la V4.

si j’ai bien compris la V4 n’est pas compatible strech et la V3 pas compatible buster :slight_smile:
Nous voilà bien déjà :slight_smile:

Mais bon j’imagine que la procédure est d’installer une V3 qui marchotte en Buster.
Restaurer sa backup
Migrer en V4 c’est bien ça ?

La v4 est compatible strech
Je tourne avec et aucun soucis

Déplus les smarts ne sont pas sous debian 10 donc la v4 tourne dessus

Bonjour @bartounet,

L’objectif de ce topic est plutôt clair, comme l’indique son titre et son premier post, il traite principalement de l’installation d’une Jeedom V4 sur une Buster.
Pour éviter de partir dans toutes les directions, il n’a pas vocation à se prononcer sur les compatibilités dans d’autres cas d’usages.

akenad :slight_smile:

Bonjour,
En v3-deb9, si je bascule en V4-deb9. Puis que je fais une sauvegarde de la V4-deb9.
Ensuite je crée une VM “neuve” Debian 10 et jeedom V4, si je restaure ma sauvegarde, je serai en debian 9 ou 10 ?
Et si je suis en debian 10, est ce que la sauvegarde V4-deb9 d’avant sera totalement fonctionnelle ?
Merci pour vos réponses

Hello
Après une restauration, la version de Jeedom est la version du backup.
La version de debian ne change pas.

@Claude69 je te remercie pour se retour rapide.
Je vais tester la v4, comment faite vous pour faire ces tests ?
Peut-on avoir sur deux VM la gateway Xiaomi et ces capteurs par exemple ?
Et pour les scénario, on crée des virtuel “virtuel” et on voit si le scénarii les fait réagir comme s’ils étaient vrai ? Mais pour que les scénario marchent, il faut souvent des données d’entrée, donc de vrai capteur…
Que de question…

Si je ne dis pas de bêtises, la gateway émet en broadcast sur le réseau et le plugin Xiaomi écoute ces trames donc je dirais oui ça devrait fonctionner sans problème.

Et tu peux même sauter directement de Debian 9 à Debian 10, même si perso je préfère repartir d’une installation propre. Mais si tu veux faire un test, tu clones ta VM v3-deb9 et tu passes en V4 puis Debian 10 (même si il n’y a aucune obligation à passer en Debian 10 aujourd’hui).

Merci, avec Xiaomi, c’est ce que j’ai fait.
Mais là je tests la v4 et c’est pas simple…Ces tuiles sont widget, je n’arrive pas à m’y faire, j’essaies de trouver comment les personnaliser et ça m’énerve de pas trouver. Ou alors ce n’est plus possible ?
Rien sur la doc dans Virtuel, dashboard…On ne sait pas à quoi correspond : line, hygrothermo etc… il faut tout tester. Et d’ailleur le Hygrothemographe, c’est bien un widget, donc ou peut on les créer ? Je vais arrêter de pourrir le post, désolé.
Pour le reste, le jeedom v4 tourne pour l’instant sur deb10 en VM proxmox. nickel ce tuto.

Le plugin widget n’est pas compatible avec la v4 et il faut passer par le menu widget du core où tu pourras créer des widgets personnalisés.

Ok, vu, je vais tester. Merci.
Par contre y a t’il de la doc sur que sont les widget de base rain, etc… des images de résultat. Vu aussi doc widget du core, mais bon, pas grand chose dedans pour des débutants. Ce qui était bien en v3 c’était de prendre des widgets existant et de pouvoir les adapter à notre besoin…
Allez je vais essayer de faire quelques choses, encore merci.

1 J'aime

Bonjour à tous, j’ai une question sur l’installation de Jeedom.
Depuis pratiquement 2 ans, Jeedom tourne sur un Nuc Hystou Core-i3-5005U 8 Mo de mémoire SANS VM Debian 9 strech 64 bits.
Depuis 1 mois j’avais des erreurs 502 page blanche corrigé en modifiant le fichier php.ini je suis passé de 128M à 512M problème résolu.
Depuis 2 semaines j’ai des lenteurs qui mène au redémarrage du Nuc, la roue verte tourne pendant longtemps sans arrêt.
Au démarrage c’est super fluide, après quelques manipulations plus rien.
Depuis hier je suis passé à la V4 mais évidemment il n’y a pas de changement à mon problème.
J’ai enlevé les logs des scénarios et des plugins, désactivé plusieurs plugins mais rien.
J’ai fais un test fibre qui monte à 94 mo montant et 85 mo descendant ping à 13.
J’ai aussi un Raspberry Pi2 avec un Jeedom V3 de secours quand il tourne même problème de lenteur.

[2019-11-03 11:03:16][INFO] : Arrêt de camera::pull(), PID : 2033
[2019-11-03 16:42:58][INFO] : Arrêt de camera::pull(), PID : 1759
[2019-11-04 11:10:37][INFO] : Arrêt de plugin::cronHourly(), PID : 
[2019-11-04 11:10:38][INFO] : Arrêt de Monitoring::pull(), PID : 19474
[2019-11-04 12:17:47][INFO] : Arrêt de jeedom::cronHourly(), PID : 
[2019-11-04 12:17:48][INFO] : Arrêt de plugin::cron15(), PID : 
[2019-11-04 12:17:49][INFO] : Arrêt de plugin::cron30(), PID : 
[2019-11-04 12:17:51][INFO] : Arrêt de plugin::checkDeamon(), PID : 
[2019-11-04 12:17:52][INFO] : Arrêt de cache::persist(), PID : 
[2019-11-04 12:17:53][INFO] : Arrêt de tadohome::miseajour(), PID : 
[2019-11-04 12:17:54][INFO] : Arrêt de scenario::control(), PID : 
[2019-11-04 12:17:55][INFO] : Arrêt de Monitoring::pull(), PID : 
[2019-11-04 17:47:13][INFO] : Arrêt de camera::pull(), PID : 2049
[2019-11-04 17:48:36][INFO] : Arrêt de camera::pull(), PID : 9096
[Tue Nov 05 04:38:17.783414 2019] [:error] [pid 5994] [client 127.0.0.1:48862] PHP Warning:  file_put_contents(): Only 0 of 37517 bytes written, possibly out of free disk space in /var/www/html/vendor/doctrine/cache/lib/Doctrine/Common/Cache/FileCache.php on line 254
[Tue Nov 05 04:39:52.381935 2019] [:error] [pid 5994] [client 127.0.0.1:48862] PHP Warning:  file_put_contents(): Only 0 of 323 bytes written, possibly out of free disk space in /var/www/html/vendor/doctrine/cache/lib/Doctrine/Common/Cache/FileCache.php on line 254
[Tue Nov 05 04:40:10.570871 2019] [:error] [pid 5994] [client 127.0.0.1:48862] PHP Warning:  file_put_contents(): Only 0 of 417 bytes written, possibly out of free disk space in /var/www/html/vendor/doctrine/cache/lib/Doctrine/Common/Cache/FileCache.php on line 254
[Tue Nov 05 04:40:26.616469 2019] [:error] [pid 5994] [client 127.0.0.1:48862] PHP Warning:  file_put_contents(): Only 0 of 37517 bytes written, possibly out of free disk space in /var/www/html/vendor/doctrine/cache/lib/Doctrine/Common/Cache/FileCache.php on line 254

Pouvez-vous me dire si il est indispensable d’utiliser une VM sur un PC Linux pour utiliser Jeedom ?
Merci d’avance.
Eric

Non il n’est pas indispensable de passer par une VM , heureusement.
Tu sera toujours plus performant en direct sur le matériel.
Après c’est toujours appréciable de mutualiser les ressources pour faire autre chose, c’est pour cela qu’on virtualise entre autre.

Pour ton problème, on voit un problème d’espace disque non ??

Bonjour Bartounet, mon PC Hystou à un SSD de 240Go ce matin avec le plugin monitoring l’espace disque était rempli à 3% je crois.
nuc
Jeedom et le seul programme sur le PC.
sant%C3%A9

Merci beaucoup
Eric

Ok il doit parler de mémoire cache alors.

Que faire pour la mémoire cache ?
J’ai trouvé sur le forum des gens qui ont les mêmes problèmes que moi.
Ils parlent du RFXCOM, je l’avais mise à jour.
Je crois que vais remettre le fichier de base.
Encore merci
Eric