[Résolu] Problème dépendance GSH

Tags: #<Tag:0x00007f752964a5c8>

Bonjour à tous,

J’ai mon plugin GSH qui me fait des siennes depuis quelques jours.
En effet, j’ai une réinstallation des dépendances qui n’arrête pas de se faire, je m’en suis rendu compte grâce aux notifications.

Par contre : si je fais une commande vocale : tout fonctionne :sweat:
La google home prend bien la commande et tout est OK. Si je désactive le plugin, cela ne fonctionne plus…bizarre

L’état du plugin :
plugin

Quand on regarde les Logs j’ai ceci :

********************************************************
*             Installation des dépendances             *
********************************************************
Atteint :1 http://phoscon.de/apt/deconz buster InRelease
Atteint :2 http://deb.debian.org/debian buster InRelease
Atteint :3 http://security.debian.org/debian-security buster/updates InRelease
Atteint :4 http://deb.debian.org/debian buster-updates InRelease
Atteint :5 https://deb.nodesource.com/node_14.x buster InRelease
Lecture des listes de paquets…
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
apt-utils est déjà la version la plus récente (1.8.2.3).
build-essential est déjà la version la plus récente (12.6).
git est déjà la version la plus récente (1:2.20.1-2+deb10u3).
lsb-release est déjà la version la plus récente (10.2019051400).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
[Check Version NodeJS actuelle : Aucune : [  KO  ]
Installation de NodeJS 14
Utilisation du dépot officiel

## Installing the NodeSource Node.js 14.x repo...


## Populating apt-get cache...

+ apt-get update
Atteint :1 http://deb.debian.org/debian buster InRelease
Atteint :2 http://security.debian.org/debian-security buster/updates InRelease
Atteint :3 http://deb.debian.org/debian buster-updates InRelease
Atteint :4 http://phoscon.de/apt/deconz buster InRelease
Atteint :5 https://deb.nodesource.com/node_14.x buster InRelease
Lecture des listes de paquets…

## Confirming "buster" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_14.x/dists/buster/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | gpg --dearmor | tee /usr/share/keyrings/nodesource.gpg >/dev/null

## Creating apt sources list file for the NodeSource Node.js 14.x repo...

+ echo 'deb [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_14.x buster main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src [signed-by=/usr/share/keyrings/nodesource.gpg] https://deb.nodesource.com/node_14.x buster main' >> /etc/apt/sources.list.d/nodesource.list

## Running `apt-get update` for you...

+ apt-get update
Atteint :1 http://deb.debian.org/debian buster InRelease
Atteint :2 http://security.debian.org/debian-security buster/updates InRelease
Atteint :3 http://phoscon.de/apt/deconz buster InRelease
Atteint :4 http://deb.debian.org/debian buster-updates InRelease
Atteint :5 https://deb.nodesource.com/node_14.x buster InRelease
Lecture des listes de paquets…

## Run `sudo apt-get install -y nodejs` to install Node.js 14.x and npm
## You may also need development tools to build native addons:
     sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
     curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | gpg --dearmor | sudo tee /usr/share/keyrings/yarnkey.gpg >/dev/null
     echo "deb [signed-by=/usr/share/keyrings/yarnkey.gpg] https://dl.yarnpkg.com/debian stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
     sudo apt-get update && sudo apt-get install yarn


Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Les NOUVEAUX paquets suivants seront installés :
  nodejs
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/24,9 Mo dans les archives.
Après cette opération, 121 Mo d'espace disque supplémentaires seront utilisés.
Sélection du paquet nodejs précédemment désélectionné.
(Lecture de la base de données... 
(Lecture de la base de données... 5%
(Lecture de la base de données... 10%
(Lecture de la base de données... 15%
(Lecture de la base de données... 20%
(Lecture de la base de données... 25%
(Lecture de la base de données... 30%
(Lecture de la base de données... 35%
(Lecture de la base de données... 40%
(Lecture de la base de données... 45%
(Lecture de la base de données... 50%
(Lecture de la base de données... 55%
(Lecture de la base de données... 60%
(Lecture de la base de données... 65%
(Lecture de la base de données... 70%
(Lecture de la base de données... 75%
(Lecture de la base de données... 80%
(Lecture de la base de données... 85%
(Lecture de la base de données... 90%
(Lecture de la base de données... 95%
(Lecture de la base de données... 100%
(Lecture de la base de données... 71142 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../nodejs_14.17.6-deb-1nodesource1_amd64.deb ...
Dépaquetage de nodejs (14.17.6-deb-1nodesource1) ...
Paramétrage de nodejs (14.17.6-deb-1nodesource1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
/var/www/html/plugins/gsh/core/class/../../resources/install_apt.sh: ligne 138: nodejs : commande introuvable
[Check Version NodeJS après install :  : [  KO  ] -> relancez les dépendances
[Check Prefix : /usr and sudo prefix : /usr and www-data prefix : /usr : [  OK  ]
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 npm : Dépend: nodejs (>= 6.11~) mais ne sera pas installé
       Dépend: node-abbrev (>= 1.1.1~) mais ne sera pas installé
       Dépend: node-ansi-regex (>= 3.0~) mais ne sera pas installé
       Dépend: node-ansistyles (>= 0.1.3~) mais ne sera pas installé
       Dépend: node-aproba (>= 1.2~) mais ne sera pas installé
       Dépend: node-archy (>= 1.0~) mais ne sera pas installé
       Dépend: node-cacache (>= 10.0.4~) mais ne sera pas installé
       Dépend: node-bluebird (>= 3.5.1~) mais ne sera pas installé
       Dépend: node-call-limit (>= 1.1~) mais ne sera pas installé
       Dépend: node-chownr (>= 1.0.1~) mais ne sera pas installé
       Dépend: node-config-chain (>= 1.1.11~) mais ne sera pas installé
       Dépend: node-detect-indent (>= 5.0~) mais ne sera pas installé
       Dépend: node-detect-newline (>= 2.1~) mais ne sera pas installé
       Dépend: node-editor (>= 1.0~) mais ne sera pas installé
       Dépend: node-fs-vacuum (>= 1.2.10~) mais ne sera pas installé
       Dépend: node-fs-write-stream-atomic (>= 1.0.10~) mais ne sera pas installé
       Dépend: node-glob (>= 7.1.2~) mais ne sera pas installé
       Dépend: node-graceful-fs (>= 4.1.11~) mais ne sera pas installé
       Dépend: node-has-unicode (>= 2.0.1~) mais ne sera pas installé
       Dépend: node-hosted-git-info (>= 2.6~) mais ne sera pas installé
       Dépend: node-iferr (>= 0.1.5~) mais ne sera pas installé
       Dépend: node-inflight (>= 1.0.6~) mais ne sera pas installé
       Dépend: node-inherits (>= 2.0.3~) mais ne sera pas installé
       Dépend: node-ini (>= 1.3.5~) mais ne sera pas installé
       Dépend: node-npm-package-arg mais ne sera pas installé
       Dépend: node-promzard mais ne sera pas installé
       Dépend: node-jsonstream (>= 1.3.2~) mais ne sera pas installé
       Dépend: node-json-parse-better-errors (>= 1.0.1~) mais ne sera pas installé
       Dépend: node-lazy-property (>= 1.0~) mais ne sera pas installé
       Dépend: node-libnpx (>= 10.0.1~) mais ne sera pas installé
       Dépend: node-lockfile (>= 1.0.3~) mais ne sera pas installé
       Dépend: node-lru-cache (>= 4.1.1~) mais ne sera pas installé
       Dépend: node-mississippi (>= 3.0~) mais ne sera pas installé
       Dépend: node-mkdirp (>= 0.3.3) mais ne sera pas installé
       Dépend: node-move-concurrently (>= 1.0.1~) mais ne sera pas installé
       Dépend: node-nopt mais ne sera pas installé
       Dépend: node-normalize-package-data (>= 2.4~) mais ne sera pas installé
       Dépend: node-gyp (>= 3.6.2~) mais ne sera pas installé
       Dépend: node-resolve-from (>= 4.0~) mais ne sera pas installé
       Dépend: node-encoding mais ne sera pas installé
       Dépend: node-errno mais ne sera pas installé
       Dépend: node-npmlog (>= 4.1.2~) mais ne sera pas installé
       Dépend: node-once (>= 1.4~) mais ne sera pas installé
       Dépend: node-opener (>= 1.4.3~) mais ne sera pas installé
       Dépend: node-osenv (>= 0.1.5~) mais ne sera pas installé
       Dépend: node-path-is-inside (>= 1.0.2~) mais ne sera pas installé
       Dépend: node-promise-inflight (>= 1.0.1~) mais ne sera pas installé
       Dépend: node-ansi mais ne sera pas installé
       Dépend: node-qw (>= 1.0.1~) mais ne sera pas installé
       Dépend: node-read (>= 1.0.7~) mais ne sera pas installé
       Dépend: node-read-package-json (>= 2.0.13~) mais ne sera pas installé
       Dépend: node-request (>= 2.83~) mais ne sera pas installé
       Dépend: node-retry (>= 0.10.1~) mais ne sera pas installé
       Dépend: node-rimraf (>= 2.6.2~) mais ne sera pas installé
       Dépend: node-safe-buffer (>= 5.1.1~) mais ne sera pas installé
       Dépend: node-semver (>= 5.5~) mais ne sera pas installé
       Dépend: node-sha (>= 2.0.1~) mais ne sera pas installé
       Dépend: node-slide (>= 1.1.6~) mais ne sera pas installé
       Dépend: node-sorted-object (>= 2.0.1~) mais ne sera pas installé
       Dépend: node-from2 mais ne sera pas installé
       Dépend: node-stream-iterate mais ne sera pas installé
       Dépend: node-ssri (>= 5.2.4~) mais ne sera pas installé
       Dépend: node-strip-ansi (>= 4.0~) mais ne sera pas installé
       Dépend: node-tar (>= 4.4~) mais ne sera pas installé
       Dépend: node-text-table (>= 0.2~) mais ne sera pas installé
       Dépend: node-uid-number (>= 0.0.6~) mais ne sera pas installé
       Dépend: node-unique-filename (>= 1.1~) mais ne sera pas installé
       Dépend: node-unpipe (>= 1.0~) mais ne sera pas installé
       Dépend: node-boxen (>= 1.2.1~) mais ne sera pas installé
       Dépend: node-import-lazy mais ne sera pas installé
       Dépend: node-is-npm (>= 1.0~) mais ne sera pas installé
       Dépend: node-latest-version (>= 3.0~) mais ne sera pas installé
       Dépend: node-semver-diff (>= 2.0~) mais ne sera pas installé
       Dépend: node-xdg-basedir (>= 3.0~) mais ne sera pas installé
       Dépend: node-validate-npm-package-name (>= 3.0~) mais ne sera pas installé
       Dépend: node-which (>= 1.3~) mais ne sera pas installé
       Dépend: node-wrappy (>= 1.0.2~) mais ne sera pas installé
       Dépend: node-write-file-atomic (>= 2.3~) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
audited 65 packages in 0.542s
found 2 vulnerabilities (1 low, 1 high)
  run `npm audit fix` to fix them, or `npm audit` for details
********************************************************
*             Installation terminée                    *
********************************************************

Du coup, je suis passé en mode console pour corriger cela, mais j’ai toujours un problème.
Si je tente via npm audit :
node 02

L’état des paquets :
node 00

Si je regarde dans la partie admin de Jeedom j’ai des erreurs
GSH correction

Et pourtant, ça me dit que tout est ok si je clique sur corriger.
D’ailleurs, ça ne veux pas on plus corriger script et restart apache :thinking:
GSH correction 2

Est-ce que qu’un aurait une idée car cela génère pas mal de défaut et de log.

Merci par avance !!

Max

Hello,
J’ai exactement le même problème, j’ai ouvert un ticket samedi pour ce problème et @Loic ma informé que :
Assistance Jeedom on September 11, 2021 at 1:49pm wrote:

Bonjour

Vous pouvez ignorer le soucis le démon et les dépendances ne servent qu’à passer la validation Google.

Le sam. 11 sept. 2021 à 15:19, Assistance Jeedom <support@jeedom.com> a écrit :

Masquer les messages précédents

Oui oui je comprends et ça sera corrigé avec jeedom 4.2 on ne peut malheureusement pas le corriger simplement avant.

Bonjour,

Super merci pour cette nouvelle :slight_smile:
J’avoue que je ne savais plus quoi faire a force.
Il reste qu’à attendre du coup !

Bonne journée

Bonjour, @maxredphenix , @maxredphenix

Depuis quel que temps le lien symbolique nodejs n’est plus présent

essayez en ssh la commande suivante :

sudo ln -s `which node` `which node`js

bonne journée

Bonsoir Olive,

Je viens de tenter, mais cela ne change rien apparemment :frowning:
image

Bonne soirée

Il est préférable de ne pas travailler en root …
et de passer plutôt les commandes en sudo
les configuration node sont généralement dans le répertoire utilisateur …
si tu est root ça va pas le faire.

Ah ok.
Je viens de tenter et j’ai ceci en réponse

JeedomV4:~$ sudo ln -s `which node` `which node`js
ln: impossible de créer le lien symbolique '/usr/bin/nodejs': Le fichier existe

C’est donc que le lien symbolique existe maintenant.

Oui je pense :slight_smile:
Je n’ai rien fait et la réinstallation des dépendances à due se faire toute seule par le plugin car ce soir c’est bon.

Encore merci

1 J'aime

Super donc tu peut solutionner le sujet merci.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.