Relance toutes les 4 secondes du dashboard Jeedom suite à mise à jour de plugins

Bonjour,

suite à des mises à jour de plugins jeedom, j’ai régulièrement des problèmes d’affichage du dashboard car celui ci se relance automatiquement toutes les 4 à 5 secondes et sans s’arrêter.

J’ai ce problème sur Chrome, mais pas sur l’ancienne version de Edge. La nouvelle version de Edge basée sur chromium présente la même anomalie.

Cela dure pendant plusieurs jours et fini par s’arrêter sans raison que je comprenne.

Est il possible d’identifier ce qui se passe et de faire en sorte que cela n’arrive plus

Merci à ceux qui peuvent m’aider

Bonjour,

Il faudrait que tu listes tes plugins, particulièrement les plugin tiers.
que tu donnes ta version de jeedom aussi :wink:
des traces “réseau” (via la console de dev du browser) seraient bien aussi

moi aussi j’ai eu ce problème hier. j’ai rebboté et ce n’est pas encore revenu

En fait je ne peux pas car comme le dashboard se relance toutes les 4 secondes je ne peux accéder à rien, ni à mes plugins, ni à mes scenarios,
je vais attendre de cela s’arrete pour faire la liste et vous la fournir
ma version de jeedom est la dernière en date en version 3.

Je viens de rebooter et rien de changé

Tes plugins tu dois les connaitre plus ou moins de mémoire non? en plus tu dis que tu ne l’as pas sur edge donc au pire tu sais aller voir via edge…

et la trace réseau de l’outils dev c’est aussi possible… F12 > onglet réseau

mais si rien n’est possible et qu’on ne sait avoir aucune info, on ne va savoir donner aucune réponse :wink:

Essaye d’ajouter &rescue=1 a la fin de l’adresse URL.

Bonjour avec & rescue=1 j’arrive à voir mes plugins au niveau de l’arborescence / je vous les cites
JPI, Monitoring, Nut-free, Oprimize, Tasklauncher, Xeecloud, alarm, alexapi, ash, blea, broadlink, calendar, conso, darksky, dayinfo, domogeek, ephemeride, ethalsurveillance, gardenasmartsys, geoloc, geotrav, gsh, iftt, imperihome, jeelink, leelog, kroomba, lightsmanagement, luminotherapie, mail, mobile, mode, netatmo thermostat, netatmo weather, netatmopro, networks, openvpn, openzwave, orvibo, outilsdev, philipshue, ping, plex, script, smartercoffee, sonos3, spotify, squeezboxcontrol, surveillancestation, telegram, tradfry, ttswebserver, vigilancemeteo, virual, weather, widget, wifilightv2, xiaomitalk, xiaomihome

jeedom en 3.3.35

j’ai fait F12 onglet reseau, mais cela bouge sans arret, comment récuperer les infos ?

Quel est ce plug-in ?
Pas trouvé sur le market.
Si c’est “optimize” il casse jeedom.
N’install pas des plugins qui ne viennent pas du market.

C’est effectivement optimize, je vais le supprimer

Il va probablement falloir forcer un update du core et des plugins si optimize à modifié des fichiers.
Quand c’est fait, tu pourras voir si le problème continue ou pas

Cela semble efficace, je n’ai plus le problème, merci pour l’aide… et les infos sur les plugins

Bonjour,

J’ai le même problème, mes plugin sont les suivants :
Agenda - stable
Alarme - stable
Alexa - API - beta
AlternativeMarketForJeedom (AlternativeMarketForJeedom) - master
Bluetooth Advertisement (blea) - stable
Broadlink (broadlink) - stable
Caméra (camera) - stable
Dash Button (dashbutton) - beta
Freebox OS (Freebox_OS) - beta
Google Cast (googlecast) - stable
Heatzy (heatzy) - stable
HorlogeHtc (horlogehtc) - stable
IFTTT (ifttt) - stable
JPI Plugin (JPI) - stable
Mail (mail) - stable
Meross (meross) - master
Monitoring (Monitoring) - stable
Network (networks) - stable
Nut_free (Nut_free) - stable
Objets SmartLife/Tuya (SmartLife) - master
PushBullet (pushbullet) - stable
Script (script) - stable
Sigri Linky (sigri_linky) - master
SqueezeBox Control (squeezeboxcontrol) - stable
Thermostat (thermostat) - stable
TV LG (lgTV) - stable
Vigilance Météo (vigilancemeteo) - stable
Virtuel (virtual) - stable
Volet proportionel (voletProp) - stable
Weather (weather) - stable
Widget (widget) - stable
wifilightV2 (wifilightV2) - stable
Xiaomi Home (xiaomihome) - stable
Merci pour votre aide.

paw et jpi sont-ils bien lancés sur ton périphérique Android ?

Je ne suis pas chez moi, mais je viens de désactiver le plugin JPI et maintenant je n’ai plus le problème. Donc effectivement il doit falloir aller chercher de ce coté.
Merci

Bonjour,

J’ai eu le même problème à plusieurs reprises. Pour ma part, c’était JPI le coupable.

Comme par hasard, je vois que vous l’avez en commun pour beaucoup d’entre-vous. Je l’ai résolu… en forçant manuellement à se rafraichir une fois (je n’avais pas d’info dans l’équipement, et dès que les infos sont revenues, tout est rentré dans l’ordre) (je ne sais plus si j’ai du désactiver et réactiver le plugin ou seulement utiliser la commande action pour rafraichir les info).

Pour info, pour cerner le problème, j’ai procédé en affichant mon dashboard objet par objet… Si JPI n’est pas le coupable pour certains d’entre-vous, je vous propose de faire de même pour approcher la cause du problème. Pour accéder à Jeedom normalement, allez sur une autre page que le dashboard (rajouter après votre ip : “?p=plugin” par exemple pour tomber sur la page des plugins directement).

exemple : http://monAdresseIpJeedom/index.php?&p=plugin
(pas besoin de vous dire de remplaccer par votre adresse ip…)

Bon diagnostiques, en espérant que cela puisse vous aider,

Bonne journée à tous,
Pierre (Mav3656)
Helper Officiel Jeedom

Tu as fait comment pour rafraichir JPI manuellement une fois ?

Merci pour tes commentaires et apports

Mon équipement est un Galaxy note 3. J’ai un onglet “commandes systèmes” et dedans j’ai le volume, et quelques autres commandes dont une commande action pour rafraîchir les infos.

Tu peux aussi essayer de désactiver le plugin JPI et le réactiver.

D’ailleurs, commence par regarder si quand JPI est désactivé tu arrives a afficher ton dashboard. Si tu n’y arrives pas, c’est qu’il y a un autre problème ailleurs. Tu peux alors procéder comme indiqué dans mon poste précédant en affichant objet par objet pour cibler le problème. Tu peux désactiver d’autres plugins également si nécessaire.

Bonne soirée,
Pierre (Mav3656)
Helper Officiel Jeedom

Pour l’instant je n’ai plus le problème depuis la reinstallation du core jeedom…

Si cela revient je suivrai ton protocole

Merci

Bonjour à tous,

Je vous confirme que pour moi c’était bien JPI qui faisait des siennes. Un petit refresh et tout est rentré dans l’ordre.

Hello,
Pour info, le plugin timeline semble aussi poser probleme.

Dans la console, je vois aussi :
jquery.min.js?md5=220afd743d9e9643852e31a135a9f3ae:2 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.

Ca pourrait expliquer les freeze.